From: Sakari Ailus <sakari.ailus@iki.fi>
To: Ricardo Ribalda <ribalda@chromium.org>
Cc: Laurent Pinchart <laurent.pinchart@ideasonboard.com>,
Mauro Carvalho Chehab <mchehab@kernel.org>,
linux-media@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2/3] media: uvcvideo: Refactor uvc_query_ctrl
Date: Tue, 8 Oct 2024 12:01:19 +0000 [thread overview]
Message-ID: <ZwUfD5Kfzv93-46f@valkosipuli.retiisi.eu> (raw)
In-Reply-To: <20241008-uvc-readless-v1-2-042ac4581f44@chromium.org>
Hi Ricardo,
On Tue, Oct 08, 2024 at 07:06:15AM +0000, Ricardo Ribalda wrote:
> Move the query control error logic to its own function.
> There is no functional change introduced by this patch.
>
> Signed-off-by: Ricardo Ribalda <ribalda@chromium.org>
> ---
> drivers/media/usb/uvc/uvc_video.c | 45 ++++++++++++++++++++++-----------------
> 1 file changed, 26 insertions(+), 19 deletions(-)
>
> diff --git a/drivers/media/usb/uvc/uvc_video.c b/drivers/media/usb/uvc/uvc_video.c
> index 853dfb7b5f7b..a57272a2c9e1 100644
> --- a/drivers/media/usb/uvc/uvc_video.c
> +++ b/drivers/media/usb/uvc/uvc_video.c
> @@ -67,30 +67,12 @@ static const char *uvc_query_name(u8 query)
> }
> }
>
> -int uvc_query_ctrl(struct uvc_device *dev, u8 query, u8 unit,
> - u8 intfnum, u8 cs, void *data, u16 size)
> +static int uvc_query_ctrl_error(struct uvc_device *dev, u8 intfnum, void *data)
> {
> int ret;
> u8 error;
> u8 tmp;
>
> - ret = __uvc_query_ctrl(dev, query, unit, intfnum, cs, data, size,
> - UVC_CTRL_CONTROL_TIMEOUT);
> - if (likely(ret == size))
> - return 0;
> -
> - if (ret > 0 && ret < size) {
> - memset(data + ret, 0, size - ret);
> - return 0;
> - }
> -
> - if (ret != -EPIPE) {
> - dev_err(&dev->udev->dev,
> - "Failed to query (%s) UVC control %u on unit %u: %d (exp. %u).\n",
> - uvc_query_name(query), cs, unit, ret, size);
> - return ret ? ret : -EPIPE;
> - }
> -
> /* Reuse data[0] to request the error code. */
> tmp = *(u8 *)data;
>
> @@ -135,6 +117,31 @@ int uvc_query_ctrl(struct uvc_device *dev, u8 query, u8 unit,
> return -EPIPE;
> }
>
> +int uvc_query_ctrl(struct uvc_device *dev, u8 query, u8 unit,
> + u8 intfnum, u8 cs, void *data, u16 size)
> +{
> + int ret;
> +
> + ret = __uvc_query_ctrl(dev, query, unit, intfnum, cs, data, size,
> + UVC_CTRL_CONTROL_TIMEOUT);
> + if (likely(ret == size))
> + return 0;
> +
> + if (ret == -EPIPE)
> + return uvc_query_ctrl_error(dev, intfnum, data);
> +
> + dev_err(&dev->udev->dev,
> + "Failed to query (%s) UVC control %u on unit %u: %d (exp. %u).\n",
> + uvc_query_name(query), cs, unit, ret, size);
This message should probably be printed after the check below.
I'd actually move the below check before the ret == -EPIPE check as it's a
successful case (and changing the condition to <= would make the ret ==
size check redundant).
> +
> + if (ret > 0 && ret < size) {
> + memset(data + ret, 0, size - ret);
> + return 0;
> + }
> +
> + return ret ? ret : -EPIPE;
> +}
> +
> static const struct usb_device_id elgato_cam_link_4k = {
> USB_DEVICE(0x0fd9, 0x0066)
> };
>
--
Kind regards,
Sakari Ailus
next prev parent reply other threads:[~2024-10-08 12:01 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-10-08 7:06 [PATCH 0/3] media: uvcvideo: Support partial control reads and minor changes Ricardo Ribalda
2024-10-08 7:06 ` [PATCH 1/3] media: uvcvideo: Support partial control reads Ricardo Ribalda
2024-10-08 11:52 ` Sakari Ailus
2024-10-08 7:06 ` [PATCH 2/3] media: uvcvideo: Refactor uvc_query_ctrl Ricardo Ribalda
2024-10-08 12:01 ` Sakari Ailus [this message]
2024-10-08 13:22 ` Ricardo Ribalda
2024-10-08 13:31 ` Sakari Ailus
2024-10-08 13:38 ` Ricardo Ribalda
2024-10-08 14:53 ` Sakari Ailus
2024-10-08 7:06 ` [PATCH 3/3] media: uvcvideo: Add more logging to uvc_query_ctrl_error() Ricardo Ribalda
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ZwUfD5Kfzv93-46f@valkosipuli.retiisi.eu \
--to=sakari.ailus@iki.fi \
--cc=laurent.pinchart@ideasonboard.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=mchehab@kernel.org \
--cc=ribalda@chromium.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®