From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-5.7 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI,NICE_REPLY_A,SPF_HELO_NONE, SPF_PASS,USER_AGENT_SANE_1 autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 5EB84C4338F for ; Mon, 26 Jul 2021 13:09:12 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 2DBCC60F45 for ; Mon, 26 Jul 2021 13:09:12 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S233231AbhGZM2m (ORCPT ); Mon, 26 Jul 2021 08:28:42 -0400 Received: from foss.arm.com ([217.140.110.172]:51660 "EHLO foss.arm.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S232572AbhGZM2j (ORCPT ); Mon, 26 Jul 2021 08:28:39 -0400 Received: from usa-sjc-imap-foss1.foss.arm.com (unknown [10.121.207.14]) by usa-sjc-mx-foss1.foss.arm.com (Postfix) with ESMTP id E9D9811B3; Mon, 26 Jul 2021 06:09:07 -0700 (PDT) Received: from [10.57.36.146] (unknown [10.57.36.146]) by usa-sjc-imap-foss1.foss.arm.com (Postfix) with ESMTPSA id 27C2E3F70D; Mon, 26 Jul 2021 06:09:06 -0700 (PDT) Subject: Re: [PATCH 16/23] iommu/arm-smmu: Prepare for multiple DMA domain types To: Joerg Roedel Cc: will@kernel.org, iommu@lists.linux-foundation.org, linux-arm-kernel@lists.infradead.org, linux-kernel@vger.kernel.org, suravee.suthikulpanit@amd.com, baolu.lu@linux.intel.com, john.garry@huawei.com, dianders@chromium.org References: <04220b3420c2c513490450f37de109182364f235.1626888445.git.robin.murphy@arm.com> From: Robin Murphy Message-ID: Date: Mon, 26 Jul 2021 14:09:00 +0100 User-Agent: Mozilla/5.0 (Windows NT 10.0; rv:78.0) Gecko/20100101 Thunderbird/78.12.0 MIME-Version: 1.0 In-Reply-To: Content-Type: text/plain; charset=utf-8; format=flowed Content-Language: en-GB Content-Transfer-Encoding: 7bit Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 2021-07-26 13:46, Joerg Roedel wrote: > On Wed, Jul 21, 2021 at 07:20:27PM +0100, Robin Murphy wrote: >> - if (type == IOMMU_DOMAIN_DMA && using_legacy_binding) >> + if ((type & __IOMMU_DOMAIN_DMA_API) && using_legacy_binding) > > Hmm, I wonder whether it is time to introduce helpers for these checks? > > Something like iommu_domain_is_dma() is more readable. Ha, I had exactly that at one point, except I think in the order of iommu_is_dma_domain() :) The end result didn't seem to give enough extra clarity to justify the header churn for me, but I'm happy to be wrong about that if you prefer. Cheers, Robin.