mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Krzysztof Kozlowski <krzk@kernel.org>
To: Oleh Kuzhylnyi <kuzhylol@gmail.com>,
	Dmitry Torokhov <dmitry.torokhov@gmail.com>
Cc: Rob Herring <robh@kernel.org>, Conor Dooley <conor+dt@kernel.org>,
	Sasha Finkelstein <fnkl.kernel@gmail.com>,
	Javier Carrasco <javier.carrasco.cruz@gmail.com>,
	Linus Walleij <linus.walleij@linaro.org>,
	Javier Martinez Canillas <javierm@redhat.com>,
	Janne Grunau <j@jannau.net>,
	Igor Opaniuk <igor.opaniuk@gmail.com>,
	Neal Gompa <neal@gompa.dev>, Jeff LaBundy <jeff@labundy.com>,
	Neil Armstrong <neil.armstrong@linaro.org>,
	linux-input@vger.kernel.org, devicetree@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v8 1/2] dt-bindings: input: touchscreen: add hynitron cst816x
Date: Mon, 30 Jun 2025 08:33:33 +0200	[thread overview]
Message-ID: <a14cb1e8-a0c3-4451-8c75-07e175f4620d@kernel.org> (raw)
In-Reply-To: <20250629162523.291887-1-kuzhylol@gmail.com>

On 29/06/2025 18:25, Oleh Kuzhylnyi wrote:
> Add documentation for Hynitron CST816x series touchscreen bindings.
> 
> Signed-off-by: Oleh Kuzhylnyi <kuzhylol@gmail.com>
> ---
> Changes in v8:
>  - Use linux,keycodes to map touch gestures to key events
>  - Refactore binding properties based on feedback from Jeff LaBundy
>    and Krzysztof Kozlowski to align with official documentation

This is vague. Anything can be "refactor". What changed specifically?

b4 diff shows no changes.


> 
> Changes in v7:
>  - Introduce the gestures field along with its sub-fields
>  - Make reset-gpio property optional
>  - Extend main description
>  - Remove "touchscreen" reference
> 
> Changes in v6:
>  - Fix minor tweak adviced by Krzysztof:
>  - Move additionalProperties field after required
> 
> Changes in v5:
>  - No code changes
> 
> Changes in v4:
>  - Add Conor's Dooley "Reviewed-by" tag
> 
> Changes in v3:
>  - Rename filename to hynitron,cst816s.yaml
>  - Update description with display details
> 
> Changes in v2:
>  - Apply pin definitions and DT headers
>  - Use generic name for DT node
>  - Drop status field
> 
>  .../input/touchscreen/hynitron,cst816x.yaml   | 82 +++++++++++++++++++
>  1 file changed, 82 insertions(+)
>  create mode 100644 Documentation/devicetree/bindings/input/touchscreen/hynitron,cst816x.yaml
> 
> diff --git a/Documentation/devicetree/bindings/input/touchscreen/hynitron,cst816x.yaml b/Documentation/devicetree/bindings/input/touchscreen/hynitron,cst816x.yaml
> new file mode 100644
> index 000000000000..0d358463d7f8
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/input/touchscreen/hynitron,cst816x.yaml
> @@ -0,0 +1,82 @@
> +# SPDX-License-Identifier: (GPL-2.0-only OR BSD-2-Clause)
> +%YAML 1.2
> +---
> +$id: http://devicetree.org/schemas/input/touchscreen/hynitron,cst816x.yaml#
> +$schema: http://devicetree.org/meta-schemas/core.yaml#
> +
> +title: Hynitron CST816x Series Capacitive Touch controller
> +
> +maintainers:
> +  - Oleh Kuzhylnyi <kuzhylol@gmail.com>
> +
> +description: |
> +  Bindings for CST816x high performance self-capacitance touch chip series
> +  with single point gesture and real two-point operation.
> +
> +properties:
> +  compatible:
> +    enum:
> +      - hynitron,cst816s
> +
> +  reg:
> +    maxItems: 1
> +
> +  interrupts:
> +    maxItems: 1
> +
> +  reset-gpios:
> +    maxItems: 1
> +
> +  linux,keycodes:
> +    minItems: 1
> +    maxItems: 16
> +    description: |
> +      Specifies the numeric keycodes associated with each available gesture in
> +      the following order (enter 0 for unused and reserved gestures):
> +      0: Touch
> +      1: Swipe up
> +      2: Swipe down
> +      3: Swipe left
> +      4: Swipe right
> +      5-11: Reserved
> +      12: Long press
> +      13-15: Reserved

Fields like "reserved" makes no sense. If this is reserved, why would it
be put into the DTS?

No, just list the items with description:
minItems: 1
items:
  - description: Touch gesture (although what is a touch gesture? This
is just a touch....)
  - description: ...


> +
> +required:
> +  - compatible
> +  - reg
> +  - interrupts


Where is (or why there is no) the ref to touchscreen.yaml?

> +
> +additionalProperties: false

And this not unevaluatedProperties then?

> +
> +examples:
> +  - |
> +    #include <dt-bindings/gpio/gpio.h>
> +    #include <dt-bindings/input/linux-event-codes.h>
> +    #include <dt-bindings/interrupt-controller/irq.h>
> +    i2c {
> +          #address-cells = <1>;
> +          #size-cells = <0>;

Messed indentation.

> +          touchscreen@15 {
> +              compatible = "hynitron,cst816s";
> +              reg = <0x15>;
> +              interrupt-parent = <&gpio0>;
> +              interrupts = <4 IRQ_TYPE_EDGE_RISING>;
> +              reset-gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
> +              linux,keycodes = <BTN_TOUCH>,




Best regards,
Krzysztof

      parent reply	other threads:[~2025-06-30  6:33 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-06-29 16:25 Oleh Kuzhylnyi
2025-06-29 16:25 ` [PATCH v8 2/2] input: add hynitron cst816x series touchscreen Oleh Kuzhylnyi
2025-07-01  4:52   ` kernel test robot
2025-06-30  6:33 ` Krzysztof Kozlowski [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=a14cb1e8-a0c3-4451-8c75-07e175f4620d@kernel.org \
    --to=krzk@kernel.org \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=dmitry.torokhov@gmail.com \
    --cc=fnkl.kernel@gmail.com \
    --cc=igor.opaniuk@gmail.com \
    --cc=j@jannau.net \
    --cc=javier.carrasco.cruz@gmail.com \
    --cc=javierm@redhat.com \
    --cc=jeff@labundy.com \
    --cc=kuzhylol@gmail.com \
    --cc=linus.walleij@linaro.org \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=neal@gompa.dev \
    --cc=neil.armstrong@linaro.org \
    --cc=robh@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®