mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Gustavo A. R. Silva" <gustavo@embeddedor.com>
To: Sebastian Reichel <sebastian.reichel@collabora.com>,
	Wei Ming Chen <jj251510319013@gmail.com>
Cc: linux-kernel@vger.kernel.org, linux-pm@vger.kernel.org,
	Kees Cook <keescook@chromium.org>
Subject: Re: [PATCH] power: supply: oplc_battery: Use fallthrough pseudo-keyword
Date: Fri, 4 Jun 2021 07:14:28 -0500	[thread overview]
Message-ID: <a1593ef1-3a5b-b036-7744-b724be5a9629@embeddedor.com> (raw)
In-Reply-To: <20210604115424.3jjkrdd4ysbuamka@earth.universe>



On 6/4/21 06:54, Sebastian Reichel wrote:
> [+cc Kees and Gustavo]
> 
> Hi,
> 
> On Fri, May 07, 2021 at 08:47:24PM +0800, Wei Ming Chen wrote:
>> Add pseudo-keyword macro fallthrough[1]
>>
>> [1] https://www.kernel.org/doc/html/latest/process/deprecated.html?highlight=fallthrough#implicit-switch-case-fall-through
>>
>> Signed-off-by: Wei Ming Chen <jj251510319013@gmail.com>
>> ---
> 
> I suppose completely empty case branch is also ok and just not
> documented? I mean it does not hurt much in this case, but quite

Exactly; it's not documented because it doesn't need to be marked
with fallthrough; :)

Not sure what was the motivation for this patch.

--
Gustavo

> a few power-supply drivers have something like this and it would
> IMHO reduce readability to add fallthrough; to all of them.
> 
> property_is_writable(dev, prop) {
>     switch (prop) {
>         case A:
>         case C:
>         case E:
>             return true;
>         default:
>             return false;
>     }
> }
> 
> Thanks,
> 
> -- Sebastian
> 
>>  drivers/power/supply/olpc_battery.c | 1 +
>>  1 file changed, 1 insertion(+)
>>
>> diff --git a/drivers/power/supply/olpc_battery.c b/drivers/power/supply/olpc_battery.c
>> index e0476ec06601..743b7f1cf9ea 100644
>> --- a/drivers/power/supply/olpc_battery.c
>> +++ b/drivers/power/supply/olpc_battery.c
>> @@ -238,6 +238,7 @@ static int olpc_bat_get_charge_full_design(union power_supply_propval *val)
>>  	case POWER_SUPPLY_TECHNOLOGY_LiFe:
>>  		switch (mfr) {
>>  		case 1: /* Gold Peak, fall through */
>> +			fallthrough;
>>  		case 2: /* BYD */
>>  			val->intval = 2800000;
>>  			break;
>> -- 
>> 2.25.1
>>

      reply	other threads:[~2021-06-04 12:13 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-05-07 12:47 Wei Ming Chen
2021-06-04 11:54 ` Sebastian Reichel
2021-06-04 12:14   ` Gustavo A. R. Silva [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=a1593ef1-3a5b-b036-7744-b724be5a9629@embeddedor.com \
    --to=gustavo@embeddedor.com \
    --cc=jj251510319013@gmail.com \
    --cc=keescook@chromium.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=sebastian.reichel@collabora.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®