From: Damon Ding <damon.ding@rock-chips.com>
To: Nicolas Frattaroli <nicolas.frattaroli@collabora.com>,
hjc@rock-chips.com, heiko@sntech.de, andy.yan@rock-chips.com,
maarten.lankhorst@linux.intel.com, mripard@kernel.org,
tzimmermann@suse.de, airlied@gmail.com, simona@ffwll.ch,
robh@kernel.org, krzk+dt@kernel.org, conor+dt@kernel.org,
andrzej.hajda@intel.com, neil.armstrong@linaro.org,
rfoss@kernel.org
Cc: Laurent.pinchart@ideasonboard.com, jonas@kwiboo.se,
jernej.skrabec@gmail.com, alchark@gmail.com,
cristian.ciocaltea@collabora.com,
sebastian.reichel@collabora.com, kever.yang@rock-chips.com,
dmitry.baryshkov@oss.qualcomm.com, luca.ceresoli@bootlin.com,
dianders@chromium.org, m.szyprowski@samsung.com,
dri-devel@lists.freedesktop.org, devicetree@vger.kernel.org,
linux-arm-kernel@lists.infradead.org,
linux-rockchip@lists.infradead.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v1 3/4] drm/bridge: analogix_dp: Add support for RK3576
Date: Tue, 17 Mar 2026 09:29:50 +0800 [thread overview]
Message-ID: <a24e2a09-86a6-4c59-b219-7bfe9c74a4a5@rock-chips.com> (raw)
In-Reply-To: <2032185.PYKUYFuaPT@workhorse>
Hi Nicolas,
On 3/16/2026 7:14 PM, Nicolas Frattaroli wrote:
> On Tuesday, 10 March 2026 11:53:06 Central European Standard Time Damon Ding wrote:
>> Expand enum analogix_dp_devtype with RK3576_EDP, and add max_link_rate
>> and max_lane_count configs for it.
>>
>> Signed-off-by: Damon Ding <damon.ding@rock-chips.com>
>> ---
>> drivers/gpu/drm/bridge/analogix/analogix_dp_core.c | 1 +
>> include/drm/bridge/analogix_dp.h | 3 ++-
>> 2 files changed, 3 insertions(+), 1 deletion(-)
>>
>> diff --git a/drivers/gpu/drm/bridge/analogix/analogix_dp_core.c b/drivers/gpu/drm/bridge/analogix/analogix_dp_core.c
>> index fe7158d9edde..c4e49e8186ab 100644
>> --- a/drivers/gpu/drm/bridge/analogix/analogix_dp_core.c
>> +++ b/drivers/gpu/drm/bridge/analogix/analogix_dp_core.c
>> @@ -1248,6 +1248,7 @@ static int analogix_dp_dt_parse_pdata(struct analogix_dp_device *dp)
>> video_info->max_link_rate = 0x0A;
>> video_info->max_lane_count = 0x04;
>> break;
>> + case RK3576_EDP:
>> case RK3588_EDP:
>> video_info->max_link_rate = 0x14;
>> video_info->max_lane_count = 0x04;
>> diff --git a/include/drm/bridge/analogix_dp.h b/include/drm/bridge/analogix_dp.h
>> index 854af692229b..d1a6e6d44a2b 100644
>> --- a/include/drm/bridge/analogix_dp.h
>> +++ b/include/drm/bridge/analogix_dp.h
>> @@ -16,12 +16,13 @@ enum analogix_dp_devtype {
>> EXYNOS_DP,
>> RK3288_DP,
>> RK3399_EDP,
>> + RK3576_EDP,
>> RK3588_EDP,
>> };
>>
>> static inline bool is_rockchip(enum analogix_dp_devtype type)
>> {
>> - return type == RK3288_DP || type == RK3399_EDP || type == RK3588_EDP;
>> + return type == RK3288_DP || type == RK3399_EDP || type == RK3576_EDP || type == RK3588_EDP;
>
> I think we can make this easier to read with a switch statement. In
> a separate patch, we may also want to rename `is_rockchip` to
> `analogix_dp_is_rockchip`, as e.g. rockchip_drm_vop.c and exynos_dp.c
> both include his header file as well.
>
> Switch statement would make the function look something like:
>
> static inline bool is_rockchip(enum analogix_dp_devtype type)
> {
> switch (type) {
> case RK3288_DP:
> case RK3399_EDP:
> case RK3576_EDP:
> case RK3588_EDP:
> return true;
> default:
> return false;
> }
> }
>
Good idea, will do in v2. :-)
Best regards,
Damon
next prev parent reply other threads:[~2026-03-17 3:52 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-03-10 10:53 [PATCH v1 0/4] Add eDP " Damon Ding
2026-03-10 10:53 ` [PATCH v1 1/4] dt-bindings: display: rockchip: analogix-dp: Add " Damon Ding
2026-03-11 13:01 ` Krzysztof Kozlowski
2026-03-13 2:07 ` Damon Ding
2026-03-10 10:53 ` [PATCH v1 2/4] arm64: dts: rockchip: Add eDP node " Damon Ding
2026-03-16 11:31 ` Nicolas Frattaroli
2026-03-17 1:37 ` Damon Ding
2026-03-10 10:53 ` [PATCH v1 3/4] drm/bridge: analogix_dp: Add support " Damon Ding
2026-03-16 11:14 ` Nicolas Frattaroli
2026-03-17 1:29 ` Damon Ding [this message]
2026-03-10 10:53 ` [PATCH v1 4/4] drm/rockchip: " Damon Ding
2026-03-16 11:35 ` Nicolas Frattaroli
2026-03-10 11:11 ` [PATCH v1 0/4] Add eDP " Damon Ding
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=a24e2a09-86a6-4c59-b219-7bfe9c74a4a5@rock-chips.com \
--to=damon.ding@rock-chips.com \
--cc=Laurent.pinchart@ideasonboard.com \
--cc=airlied@gmail.com \
--cc=alchark@gmail.com \
--cc=andrzej.hajda@intel.com \
--cc=andy.yan@rock-chips.com \
--cc=conor+dt@kernel.org \
--cc=cristian.ciocaltea@collabora.com \
--cc=devicetree@vger.kernel.org \
--cc=dianders@chromium.org \
--cc=dmitry.baryshkov@oss.qualcomm.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=heiko@sntech.de \
--cc=hjc@rock-chips.com \
--cc=jernej.skrabec@gmail.com \
--cc=jonas@kwiboo.se \
--cc=kever.yang@rock-chips.com \
--cc=krzk+dt@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-rockchip@lists.infradead.org \
--cc=luca.ceresoli@bootlin.com \
--cc=m.szyprowski@samsung.com \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=neil.armstrong@linaro.org \
--cc=nicolas.frattaroli@collabora.com \
--cc=rfoss@kernel.org \
--cc=robh@kernel.org \
--cc=sebastian.reichel@collabora.com \
--cc=simona@ffwll.ch \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®