From: kuiliang Shi <seakeel@gmail.com>
To: Vincent Guittot <vincent.guittot@linaro.org>, alexs@kernel.org
Cc: Ingo Molnar <mingo@redhat.com>,
Peter Zijlstra <peterz@infradead.org>,
Juri Lelli <juri.lelli@redhat.com>,
Dietmar Eggemann <dietmar.eggemann@arm.com>,
Steven Rostedt <rostedt@goodmis.org>,
Ben Segall <bsegall@google.com>, Mel Gorman <mgorman@suse.de>,
Daniel Bristot de Oliveira <bristot@redhat.com>,
Valentin Schneider <vschneid@redhat.com>,
"open list:SCHEDULER" <linux-kernel@vger.kernel.org>,
Ricardo Neri <ricardo.neri-calderon@linux.intel.com>
Subject: Re: [PATCH v5 3/5] sched/fair: Rework sched_use_asym_prio() and sched_asym_prefer()
Date: Fri, 23 Feb 2024 11:52:37 +0800 [thread overview]
Message-ID: <a26c0db2-79a6-4662-9ca6-7e7105cdac03@gmail.com> (raw)
In-Reply-To: <CAKfTPtDtf0WhtWV-eO2hMUpP2rDgTgUBPbHZYWMuytYJ9ifU5w@mail.gmail.com>
On 2/14/24 12:51 AM, Vincent Guittot wrote:
> On Sat, 10 Feb 2024 at 12:36, <alexs@kernel.org> wrote:
>>
>> From: Alex Shi <alexs@kernel.org>
>>
>> sched_use_asym_prio() and sched_asym_prefer() are used together in various
>> places. Consolidate them into a single function sched_asym().
>>
>> The existing sched_group_asym() is only used when collecting statistics
>
> nit: The existing sched_asym()
Hi Vincent,
Thanks for all reviewing. Do I need to update this for next version? or just fix it during merge?
Alex
>
>> of a scheduling group. Rename it as sched_group_asym(), and remove the
>> obsolete function description.
>>
>> This makes the code easier to read. No functional changes.
>>
>> Tested-by: Ricardo Neri <ricardo.neri-calderon@linux.intel.com>
>> Signed-off-by: Alex Shi <alexs@kernel.org>
>> Cc: Ricardo Neri <ricardo.neri-calderon@linux.intel.com>
>> Cc: Valentin Schneider <vschneid@redhat.com>
>> Cc: Vincent Guittot <vincent.guittot@linaro.org>
>> Cc: Peter Zijlstra <peterz@infradead.org>
>> Cc: Ingo Molnar <mingo@redhat.com>
>> Reviewed-by: Ricardo Neri <ricardo.neri-calderon@linux.intel.com>
>
> Reviewed-by: Vincent Guittot <vincent.guittot@linaro.org>
>
>> ---
>> kernel/sched/fair.c | 45 ++++++++++++++++++++-------------------------
>> 1 file changed, 20 insertions(+), 25 deletions(-)
>>
>> diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
>> index 607dc310b355..426eda9eda57 100644
>> --- a/kernel/sched/fair.c
>> +++ b/kernel/sched/fair.c
>> @@ -9746,8 +9746,18 @@ static bool sched_use_asym_prio(struct sched_domain *sd, int cpu)
>> return sd->flags & SD_SHARE_CPUCAPACITY || is_core_idle(cpu);
>> }
>>
>> +static inline bool sched_asym(struct sched_domain *sd, int dst_cpu, int src_cpu)
>> +{
>> + /*
>> + * First check if @dst_cpu can do asym_packing load balance. Only do it
>> + * if it has higher priority than @src_cpu.
>> + */
>> + return sched_use_asym_prio(sd, dst_cpu) &&
>> + sched_asym_prefer(dst_cpu, src_cpu);
>> +}
>> +
>> /**
>> - * sched_asym - Check if the destination CPU can do asym_packing load balance
>> + * sched_group_asym - Check if the destination CPU can do asym_packing balance
>> * @env: The load balancing environment
>> * @sgs: Load-balancing statistics of the candidate busiest group
>> * @group: The candidate busiest group
>> @@ -9755,34 +9765,21 @@ static bool sched_use_asym_prio(struct sched_domain *sd, int cpu)
>> * @env::dst_cpu can do asym_packing if it has higher priority than the
>> * preferred CPU of @group.
>> *
>> - * SMT is a special case. If we are balancing load between cores, @env::dst_cpu
>> - * can do asym_packing balance only if all its SMT siblings are idle. Also, it
>> - * can only do it if @group is an SMT group and has exactly on busy CPU. Larger
>> - * imbalances in the number of CPUS are dealt with in find_busiest_group().
>> - *
>> - * If we are balancing load within an SMT core, or at PKG domain level, always
>> - * proceed.
>> - *
>> * Return: true if @env::dst_cpu can do with asym_packing load balance. False
>> * otherwise.
>> */
>> static inline bool
>> -sched_asym(struct lb_env *env, struct sg_lb_stats *sgs, struct sched_group *group)
>> +sched_group_asym(struct lb_env *env, struct sg_lb_stats *sgs, struct sched_group *group)
>> {
>> - /* Ensure that the whole local core is idle, if applicable. */
>> - if (!sched_use_asym_prio(env->sd, env->dst_cpu))
>> - return false;
>> -
>> /*
>> - * CPU priorities does not make sense for SMT cores with more than one
>> + * CPU priorities do not make sense for SMT cores with more than one
>> * busy sibling.
>> */
>> - if (group->flags & SD_SHARE_CPUCAPACITY) {
>> - if (sgs->group_weight - sgs->idle_cpus != 1)
>> - return false;
>> - }
>> + if ((group->flags & SD_SHARE_CPUCAPACITY) &&
>> + (sgs->group_weight - sgs->idle_cpus != 1))
>> + return false;
>>
>> - return sched_asym_prefer(env->dst_cpu, group->asym_prefer_cpu);
>> + return sched_asym(env->sd, env->dst_cpu, group->asym_prefer_cpu);
>> }
>>
>> /* One group has more than one SMT CPU while the other group does not */
>> @@ -9938,7 +9935,7 @@ static inline void update_sg_lb_stats(struct lb_env *env,
>> /* Check if dst CPU is idle and preferred to this group */
>> if (!local_group && env->sd->flags & SD_ASYM_PACKING &&
>> env->idle != CPU_NOT_IDLE && sgs->sum_h_nr_running &&
>> - sched_asym(env, sgs, group)) {
>> + sched_group_asym(env, sgs, group)) {
>> sgs->group_asym_packing = 1;
>> }
>>
>> @@ -11037,8 +11034,7 @@ static struct rq *find_busiest_queue(struct lb_env *env,
>> * SMT cores with more than one busy sibling.
>> */
>> if ((env->sd->flags & SD_ASYM_PACKING) &&
>> - sched_use_asym_prio(env->sd, i) &&
>> - sched_asym_prefer(i, env->dst_cpu) &&
>> + sched_asym(env->sd, i, env->dst_cpu) &&
>> nr_running == 1)
>> continue;
>>
>> @@ -11908,8 +11904,7 @@ static void nohz_balancer_kick(struct rq *rq)
>> * preferred CPU must be idle.
>> */
>> for_each_cpu_and(i, sched_domain_span(sd), nohz.idle_cpus_mask) {
>> - if (sched_use_asym_prio(sd, i) &&
>> - sched_asym_prefer(i, cpu)) {
>> + if (sched_asym(sd, i, cpu)) {
>> flags = NOHZ_STATS_KICK | NOHZ_BALANCE_KICK;
>> goto unlock;
>> }
>> --
>> 2.43.0
>>
next prev parent reply other threads:[~2024-02-23 3:52 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-02-10 11:39 [PATCH v5 1/5] sched/topology: Remove duplicate descriptions from TOPOLOGY_SD_FLAGS alexs
2024-02-10 11:39 ` [PATCH v5 2/5] sched/fair: Remove unused parameters alexs
2024-02-13 16:45 ` Vincent Guittot
2024-02-28 22:00 ` [tip: sched/core] sched/fair: Remove unused parameter from sched_asym() tip-bot2 for Alex Shi
2024-02-10 11:39 ` [PATCH v5 3/5] sched/fair: Rework sched_use_asym_prio() and sched_asym_prefer() alexs
2024-02-13 16:51 ` Vincent Guittot
2024-02-23 3:52 ` kuiliang Shi [this message]
2024-02-28 22:00 ` [tip: sched/core] " tip-bot2 for Alex Shi
2024-02-10 11:39 ` [PATCH v5 4/5] sched/fair: Check the SD_ASYM_PACKING flag in sched_use_asym_prio() alexs
2024-02-13 17:02 ` Vincent Guittot
2024-02-28 22:00 ` [tip: sched/core] " tip-bot2 for Alex Shi
2024-02-10 11:39 ` [PATCH v5 5/5] sched: rename SD_SHARE_PKG_RESOURCES to SD_SHARE_LLC alexs
2024-02-13 7:01 ` Barry Song
2024-02-13 7:21 ` Barry Song
2024-02-28 22:00 ` [tip: sched/core] sched/topology: Rename " tip-bot2 for Alex Shi
2024-02-13 16:45 ` [PATCH v5 1/5] sched/topology: Remove duplicate descriptions from TOPOLOGY_SD_FLAGS Vincent Guittot
2024-02-28 22:00 ` [tip: sched/core] " tip-bot2 for Alex Shi
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=a26c0db2-79a6-4662-9ca6-7e7105cdac03@gmail.com \
--to=seakeel@gmail.com \
--cc=alexs@kernel.org \
--cc=bristot@redhat.com \
--cc=bsegall@google.com \
--cc=dietmar.eggemann@arm.com \
--cc=juri.lelli@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mgorman@suse.de \
--cc=mingo@redhat.com \
--cc=peterz@infradead.org \
--cc=ricardo.neri-calderon@linux.intel.com \
--cc=rostedt@goodmis.org \
--cc=vincent.guittot@linaro.org \
--cc=vschneid@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®