mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Markus Elfring <Markus.Elfring@web.de>
To: Biancaa Ramesh <biancaa2210329@ssn.edu.in>,
	Sudip Mukherjee <sudipm.mukherjee@gmail.com>
Cc: linux-kernel@vger.kernel.org, linux-media@vger.kernel.org,
	Andy Walls <awalls@md.metrocast.net>,
	Mauro Carvalho Chehab <mchehab@kernel.org>
Subject: Re: [PATCH] parport_cs: Refactor probe function and improve error logging
Date: Wed, 22 Oct 2025 18:30:40 +0200	[thread overview]
Message-ID: <a2bbe001-80dc-43ab-9cc9-3bf497731183@web.de> (raw)
In-Reply-To: <20251021190021.173748-1-biancaa2210329@ssn.edu.in>

> - Replaced pr_notice with dev_err for proper kernel error logging.
> - Added explicit cleanup of link->priv on failure in probe and config.
> - Improved comments and readability in parport_probe() and parport_config().
> - Ensured allocation checks are consistent (kzalloc returns checked).
> - Minor refactoring for clarity and maintainability.

Thanks for your try to adjust two function implementations.
https://elixir.bootlin.com/linux/v6.18-rc2/source/drivers/parport/parport_cs.c#L83-L162

I see possibilities to improve such a change description another bit.
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/process/submitting-patches.rst?h=v6.18-rc2#n81

Please recheck the indentation approach accordingly.
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/process/coding-style.rst?h=v6.18-rc2#n18> -- 
> ::DISCLAIMER::
> The 
> contents of this e-mail and any attachment(s) are confidential and
…

Please avoid such unwanted information for communication by the means of public mailing lists.
https://subspace.kernel.org/etiquette.html#do-not-include-confidentiality-disclaimers

Regards,
Markus

  parent reply	other threads:[~2025-10-22 16:31 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-10-21 19:00 [PATCH] pcmcia/parport_cs: " Biancaa Ramesh
2025-10-22 14:09 ` kernel test robot
2025-10-22 17:55   ` [PATCH] Subject: [PATCH v2] pcmcia/parport_cs: fix probe function syntax and error handling Biancaa Ramesh
2025-10-22 18:16     ` Markus Elfring
2025-10-22 16:30 ` Markus Elfring [this message]
2025-10-22 20:24 ` [PATCH] pcmcia/parport_cs: Refactor probe function and improve error logging kernel test robot

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=a2bbe001-80dc-43ab-9cc9-3bf497731183@web.de \
    --to=markus.elfring@web.de \
    --cc=awalls@md.metrocast.net \
    --cc=biancaa2210329@ssn.edu.in \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=mchehab@kernel.org \
    --cc=sudipm.mukherjee@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®