From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-3.8 required=3.0 tests=HEADER_FROM_DIFFERENT_DOMAINS, INCLUDES_PATCH,MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id BDB82CA9EA0 for ; Tue, 22 Oct 2019 09:07:41 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.kernel.org (Postfix) with ESMTP id 9822320663 for ; Tue, 22 Oct 2019 09:07:41 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1731396AbfJVJHk (ORCPT ); Tue, 22 Oct 2019 05:07:40 -0400 Received: from smtprelay0193.hostedemail.com ([216.40.44.193]:38322 "EHLO smtprelay.hostedemail.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1731234AbfJVJHk (ORCPT ); Tue, 22 Oct 2019 05:07:40 -0400 Received: from filter.hostedemail.com (clb03-v110.bra.tucows.net [216.40.38.60]) by smtprelay08.hostedemail.com (Postfix) with ESMTP id 119F2182CF666; Tue, 22 Oct 2019 09:07:38 +0000 (UTC) X-Session-Marker: 6A6F6540706572636865732E636F6D X-HE-Tag: veil63_252ba08252f48 X-Filterd-Recvd-Size: 4166 Received: from XPS-9350.home (unknown [47.151.135.224]) (Authenticated sender: joe@perches.com) by omf13.hostedemail.com (Postfix) with ESMTPA; Tue, 22 Oct 2019 09:07:35 +0000 (UTC) Message-ID: Subject: Re: [PATCH 1/7] debugfs: Add debugfs_create_xul() for hexadecimal unsigned long From: Joe Perches To: Geert Uytterhoeven Cc: Greg Kroah-Hartman , Ludovic Desroches , Ulf Hansson , Nicolas Ferre , Alexandre Belloni , Jaehoon Chung , "David S . Miller" , "Rafael J . Wysocki" , Johannes Berg , Linux MMC List , Linux ARM , netdev , linux-wireless , Linux Kernel Mailing List Date: Tue, 22 Oct 2019 02:07:34 -0700 In-Reply-To: References: <20191021143742.14487-1-geert+renesas@glider.be> <20191021143742.14487-2-geert+renesas@glider.be> <0f91839d858fcb03435ebc85e61ee4e75371ff37.camel@perches.com> Content-Type: text/plain; charset="ISO-8859-1" User-Agent: Evolution 3.32.1-2 MIME-Version: 1.0 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, 2019-10-22 at 10:03 +0200, Geert Uytterhoeven wrote: > Hi Joe, Hey again Geert. > On Mon, Oct 21, 2019 at 5:37 PM Joe Perches wrote: > > On Mon, 2019-10-21 at 16:37 +0200, Geert Uytterhoeven wrote: > > > The existing debugfs_create_ulong() function supports objects of > > > type "unsigned long", which are 32-bit or 64-bit depending on the > > > platform, in decimal form. To format objects in hexadecimal, various > > > debugfs_create_x*() functions exist, but all of them take fixed-size > > > types. > > > > > > Add a debugfs helper for "unsigned long" objects in hexadecimal format. > > > This avoids the need for users to open-code the same, or introduce > > > bugs when casting the value pointer to "u32 *" or "u64 *" to call > > > debugfs_create_x{32,64}(). > > [] > > > diff --git a/include/linux/debugfs.h b/include/linux/debugfs.h > > [] > > > @@ -356,4 +356,14 @@ static inline ssize_t debugfs_write_file_bool(struct file *file, > > > > > > #endif > > > > > > +static inline void debugfs_create_xul(const char *name, umode_t mode, > > > + struct dentry *parent, > > > + unsigned long *value) > > > +{ > > > + if (sizeof(*value) == sizeof(u32)) > > > + debugfs_create_x32(name, mode, parent, (u32 *)value); > > > + else > > > + debugfs_create_x64(name, mode, parent, (u64 *)value); > > > > trivia: the casts are unnecessary. > > They are necessary, in both calls (so using #ifdef as suggested below > won't help): Silly thinko, (I somehow thought the compiler would eliminate the code after the branch not taken, but of course it has to compile it first... oops) though the #ifdef should work. > > This might be more sensible using #ifdef > > > > static inline void debugfs_create_xul(const char *name, umode_t mode, > > struct dentry *parent, > > unsigned long *value) > > { > > #if BITS_PER_LONG == 64 > > debugfs_create_x64(name, mode, parent, value); > > #else > > debugfs_create_x32(name, mode, parent, value); > > #endif > > } > > ... at the expense of the compiler checking only one branch. > > Just like "if (IS_ENABLED(CONFIG_)" (when possible) is preferred > over "#ifdef CONFIG_" because of compile-coverage, I think using > "if" here is better than using "#if". True if all compilers will always eliminate the unused branch.