From: Alex Elder <elder@riscstar.com>
To: Andy Shevchenko <andy.shevchenko@gmail.com>
Cc: gregkh@linuxfoundation.org, jirislaby@kernel.org,
robh@kernel.org, krzk+dt@kernel.org, conor+dt@kernel.org,
dlan@gentoo.org, benjamin.larsson@genexis.eu,
bastien.curutchet@bootlin.com, andriy.shevchenko@linux.intel.com,
u.kleine-koenig@baylibre.com, lkundrak@v3.sk,
devicetree@vger.kernel.org, linux-serial@vger.kernel.org,
spacemit@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 3/3] serial: 8250_of: manage bus clock in suspend/resume
Date: Fri, 11 Apr 2025 14:36:04 -0500 [thread overview]
Message-ID: <a3b2d0cc-c055-4cf0-9e03-3ea73041642a@riscstar.com> (raw)
In-Reply-To: <Z_ltyAO-OBzl0adV@surfacebook.localdomain>
On 4/11/25 2:30 PM, Andy Shevchenko wrote:
> Fri, Apr 11, 2025 at 10:44:18AM -0500, Alex Elder kirjoitti:
>> Save the bus clock pointer in the of_serial_info structure, and use
>> that to disable the bus clock on suspend and re-enable it on resume.
>
> ...
>
>> if (!port->uartclk) {
>> - struct clk *bus_clk;
>> -
>> - bus_clk = devm_clk_get_optional_enabled(dev, "bus");
>> - if (IS_ERR(bus_clk)) {
>> - ret = dev_err_probe(dev, PTR_ERR(bus_clk), "failed to get bus clock\n");
>> + info->bus_clk = devm_clk_get_optional_enabled(dev, "bus");
>> + if (IS_ERR(info->bus_clk)) {
>> + ret = dev_err_probe(dev, PTR_ERR(info->bus_clk),
>> + "failed to get bus clock\n");
>> goto err_pmruntime;
>> }
>>
>> /* If the bus clock is required, core clock must be named */
>> - info->clk = devm_clk_get_enabled(dev, bus_clk ? "core" : NULL);
>> + info->clk = devm_clk_get_enabled(dev, info->bus_clk ? "core" : NULL);
>> if (IS_ERR(info->clk)) {
>> ret = dev_err_probe(dev, PTR_ERR(info->clk), "failed to get clock\n");
>
> While the first patch against this file looks okay now, this one inherits the
> same problem (seems like not enought thinking about the code representation).
>
> Instead of rewritting half of the lines you just introduced (which is also a
> bad practice), add a one-liner that assigns a field to the local variable.
So you want me to re-spin this again so that I use the local variable?
I understand what you're saying based on ease of review, but this
is a simple patch and the change is very understandable, and the
code is no more or less clear when using the local variable.
-Alex
>
>> goto err_pmruntime;
>
>
next prev parent reply other threads:[~2025-04-11 19:36 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-04-11 15:44 [PATCH v3 0/3] serial: 8250_of: support an optional bus clock Alex Elder
2025-04-11 15:44 ` [PATCH v3 1/3] dt-bindings: serial: 8250: support an optional second clock Alex Elder
2025-04-11 15:44 ` [PATCH v3 2/3] serial: 8250_of: add support for an optional bus clock Alex Elder
2025-04-11 19:31 ` Andy Shevchenko
2025-04-11 15:44 ` [PATCH v3 3/3] serial: 8250_of: manage bus clock in suspend/resume Alex Elder
2025-04-11 19:30 ` Andy Shevchenko
2025-04-11 19:36 ` Alex Elder [this message]
2025-04-11 19:44 ` Andy Shevchenko
2025-04-11 19:56 ` Alex Elder
2025-04-11 20:15 ` Andy Shevchenko
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=a3b2d0cc-c055-4cf0-9e03-3ea73041642a@riscstar.com \
--to=elder@riscstar.com \
--cc=andriy.shevchenko@linux.intel.com \
--cc=andy.shevchenko@gmail.com \
--cc=bastien.curutchet@bootlin.com \
--cc=benjamin.larsson@genexis.eu \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=dlan@gentoo.org \
--cc=gregkh@linuxfoundation.org \
--cc=jirislaby@kernel.org \
--cc=krzk+dt@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-serial@vger.kernel.org \
--cc=lkundrak@v3.sk \
--cc=robh@kernel.org \
--cc=spacemit@lists.linux.dev \
--cc=u.kleine-koenig@baylibre.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®