mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Joe Perches <joe@perches.com>
To: Sven Van Asbroeck <thesven73@gmail.com>
Cc: Greg KH <gregkh@linuxfoundation.org>,
	Dan Carpenter <dan.carpenter@oracle.com>,
	devel@driverdev.osuosl.org,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 1/2] MAINTAINERS: Add entry for fieldbus subsystem
Date: Thu, 23 May 2019 14:02:16 -0700	[thread overview]
Message-ID: <a3c036b12979ab7269917247a683eeb63df71d58.camel@perches.com> (raw)
In-Reply-To: <CAGngYiUnRSSPLDhXeAg5E0pM_-ZbNV9qpOarSemDdpwLPRZeqA@mail.gmail.com>

On Thu, 2019-05-23 at 16:23 -0400, Sven Van Asbroeck wrote:
> On Thu, May 23, 2019 at 4:00 PM Joe Perches <joe@perches.com> wrote:
> > trivia: anybuss looks like a misspelling.
> > It might be better as anybus-s.
> This came up as well during the review process. When we insert a separator,
> the include files start looking like anybus-s-controller.h, and the structs
> become like struct anybus_s_ops. It then no longer looks like a misspelling,
> but becomes harder to read?
> 
> An alternative solution is to get rid of the 's' suffix altogether. Anybus-S
> is the only flavour we support right now. Although that may obviously
> change in the future.

anybuss just looked odd to me.

Whatever you choose is up to you and
no doubt you'll choose well.

cheers, Joe



      reply	other threads:[~2019-05-23 21:02 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-05-23 19:53 Sven Van Asbroeck
2019-05-23 19:53 ` [PATCH 2/2] MAINTAINERS: Add entry for anybuss drivers Sven Van Asbroeck
2019-05-23 20:00 ` [PATCH 1/2] MAINTAINERS: Add entry for fieldbus subsystem Joe Perches
2019-05-23 20:23   ` Sven Van Asbroeck
2019-05-23 21:02     ` Joe Perches [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=a3c036b12979ab7269917247a683eeb63df71d58.camel@perches.com \
    --to=joe@perches.com \
    --cc=dan.carpenter@oracle.com \
    --cc=devel@driverdev.osuosl.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=thesven73@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®