From: Hans Zhang <18255117159@163.com>
To: lpieralisi@kernel.org, bhelgaas@google.com, mani@kernel.org,
ilpo.jarvinen@linux.intel.com, kwilczynski@kernel.org
Cc: robh@kernel.org, jingoohan1@gmail.com, linux-pci@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v13 0/6] Refactor capability search into common macros
Date: Tue, 24 Jun 2025 23:09:39 +0800 [thread overview]
Message-ID: <a499a2cb-1755-423d-95a0-c87746c128d2@163.com> (raw)
In-Reply-To: <20250607161405.808585-1-18255117159@163.com>
Dear Ilpo,
Gentle ping.
Best regards,
Hans
On 2025/6/8 00:13, Hans Zhang wrote:
> Dear Maintainers,
>
> This patch series addresses long-standing code duplication in PCI
> capability discovery logic across the PCI core and controller drivers.
> The existing implementation ties capability search to fully initialized
> PCI device structures, limiting its usability during early controller
> initialization phases where device/bus structures may not yet be
> available.
>
> The primary goal is to decouple capability discovery from PCI device
> dependencies by introducing a unified framework using config space
> accessor-based macros. This enables:
>
> 1. Early Capability Discovery: Host controllers (e.g., Cadence, DWC)
> can now perform capability searches during pre-initialization stages
> using their native config accessors.
>
> 2. Code Consolidation: Common logic for standard and extended capability
> searches is refactored into shared macros (`PCI_FIND_NEXT_CAP_TTL` and
> `PCI_FIND_NEXT_EXT_CAPABILITY`), eliminating redundant implementations.
>
> 3. Safety and Maintainability: TTL checks are centralized within the
> macros to prevent infinite loops, while hardcoded offsets in drivers
> are replaced with dynamic discovery, reducing fragility.
>
> Key improvements include:
> - Driver Conversions: DesignWare and Cadence drivers are migrated to
> use the new macros, removing device-specific assumptions and ensuring
> consistent error handling.
>
> - Enhanced Readability: Magic numbers are replaced with symbolic
> constants, and config space accessors are standardized for clarity.
>
> - Backward Compatibility: Existing PCI core behavior remains unchanged.
>
> ---
> Changes since v12:
> - Modify some commit messages, code format issues, and optimize the function return values.
>
> Changes since v11:
> - Resolved some compilation warning.
> - Add some include.
> - Add the *** BLURB HERE *** description(Corrected by Mani and Krzysztof).
>
> Changes since v10:
> - The patch [v10 2/6] remove #include <uapi/linux/pci_regs.h> and add macro definition comments.
> - The patch [v10 3/6] remove #include <uapi/linux/pci_regs.h> and commit message were modified.
> - The other patches have not been modified.
>
> Changes since v9:
> - Resolved [v9 4/6] compilation error.
> The latest 6.15 rc1 merge __dw_pcie_find_vsec_capability, which uses
> dw_pcie_find_next_ext_capability.
> - The other patches have not been modified.
>
> Changes since v8:
> - Split patch.
> - The patch commit message were modified.
> - Other patches(4/6, 5/6, 6/6) are unchanged.
>
> Changes since v7:
> - Patch 2/5 and 3/5 compilation error resolved.
> - Other patches are unchanged.
>
> Changes since v6:
> - Refactor capability search into common macros.
> - Delete pci-host-helpers.c and MAINTAINERS.
>
> Changes since v5:
> - If you put the helpers in drivers/pci/pci.c, they unnecessarily enlarge
> the kernel's .text section even if it's known already at compile time
> that they're never going to be used (e.g. on x86).
> - Move the API for find capabilitys to a new file called
> pci-host-helpers.c.
> - Add new patch for MAINTAINERS.
>
> Changes since v4:
> - Resolved [v4 1/4] compilation warning.
> - The patch subject and commit message were modified.
>
> Changes since v3:
> - Resolved [v3 1/4] compilation error.
> - Other patches are not modified.
>
> Changes since v2:
> - Add and split into a series of patches.
> ---
>
> Hans Zhang (6):
> PCI: Introduce generic bus config read helper function
> PCI: Clean up __pci_find_next_cap_ttl() readability
> PCI: Refactor capability search into common macros
> PCI: dwc: Use common PCI host bridge APIs for finding the capabilities
> PCI: cadence: Use common PCI host bridge APIs for finding the
> capabilities
> PCI: cadence: Use cdns_pcie_find_*capability to avoid hardcode
>
> drivers/pci/access.c | 15 ++++
> .../pci/controller/cadence/pcie-cadence-ep.c | 38 ++++----
> drivers/pci/controller/cadence/pcie-cadence.c | 30 +++++++
> drivers/pci/controller/cadence/pcie-cadence.h | 18 ++--
> drivers/pci/controller/dwc/pcie-designware.c | 83 ++++--------------
> drivers/pci/pci.c | 76 +++-------------
> drivers/pci/pci.h | 87 +++++++++++++++++++
> include/uapi/linux/pci_regs.h | 3 +
> 8 files changed, 196 insertions(+), 154 deletions(-)
>
>
> base-commit: ec7714e4947909190ffb3041a03311a975350fe0
next prev parent reply other threads:[~2025-06-24 15:10 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-06-07 16:13 Hans Zhang
2025-06-07 16:14 ` [PATCH v13 1/6] PCI: Introduce generic bus config read helper function Hans Zhang
2025-06-07 16:14 ` [PATCH v13 2/6] PCI: Clean up __pci_find_next_cap_ttl() readability Hans Zhang
2025-06-07 16:14 ` [PATCH v13 3/6] PCI: Refactor capability search into common macros Hans Zhang
2025-07-15 22:47 ` Bjorn Helgaas
2025-07-16 16:04 ` Hans Zhang
2025-07-21 8:20 ` Ilpo Järvinen
2025-06-07 16:14 ` [PATCH v13 4/6] PCI: dwc: Use common PCI host bridge APIs for finding the capabilities Hans Zhang
2025-06-07 16:14 ` [PATCH v13 5/6] PCI: cadence: " Hans Zhang
2025-06-07 16:14 ` [PATCH v13 6/6] PCI: cadence: Use cdns_pcie_find_*capability to avoid hardcode Hans Zhang
2025-06-24 15:09 ` Hans Zhang [this message]
2025-07-08 7:30 ` [PATCH v13 0/6] Refactor capability search into common macros Manivannan Sadhasivam
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=a499a2cb-1755-423d-95a0-c87746c128d2@163.com \
--to=18255117159@163.com \
--cc=bhelgaas@google.com \
--cc=ilpo.jarvinen@linux.intel.com \
--cc=jingoohan1@gmail.com \
--cc=kwilczynski@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=lpieralisi@kernel.org \
--cc=mani@kernel.org \
--cc=robh@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®