From: "Satyam Sharma" <satyam.sharma@gmail.com>
To: "Christoph Lameter" <clameter@sgi.com>
Cc: akpm@linux-foundation.org, "Nate Diller" <nate.diller@gmail.com>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH] zero_user_page uses in fs/buffer.c and fs/libfs.c
Date: Mon, 30 Apr 2007 12:23:50 +0530 [thread overview]
Message-ID: <a781481a0704292353v34ea217fpbbf732465dd652e8@mail.gmail.com> (raw)
In-Reply-To: <Pine.LNX.4.64.0704292313060.3018@schroedinger.engr.sgi.com>
On 4/30/07, Christoph Lameter <clameter@sgi.com> wrote:
> There are a couple of places where kmap_atomic is surrounding two
> memory operations. Usually only one of them is performed. So it is
> possible to also use zero_user_page there.
I do like the patch, but would prefer if you'd give a better/correct
rationale here. "Usually only one of them is performed" is not exactly
correct to say, as it is perfectly (and frequently so) possible for
both of (block_end > to) and (block_start < from) to be true for the
same page for the prepare_write cases.
A simple "Replace open-coded kmap_atomic() and kunmap_atomic()
surrounding two memory clear operations with zero_user_page(), as both
memory operations act on the same page" would have been better.
Perhaps you were more worried with the additional overhead of two
successive kmap_atomic() and kunmap_atomic() calls for the same page
in the two resulting zero_user_page()'s (if both conditions evaluate
to true for the same page), but that would still be a price to pay to
replace the current open-coding.
> --- linux-2.6.21-rc7-mm1.orig/fs/libfs.c 2007-04-25 00:24:10.000000000 -0700
> +++ linux-2.6.21-rc7-mm1/fs/libfs.c 2007-04-25 00:25:56.000000000 -0700
> @@ -337,12 +337,12 @@ int simple_prepare_write(struct file *fi
> unsigned from, unsigned to)
> {
> if (!PageUptodate(page)) {
> - if (to - from != PAGE_CACHE_SIZE) {
> - void *kaddr = kmap_atomic(page, KM_USER0);
> - memset(kaddr, 0, from);
> - memset(kaddr + to, 0, PAGE_CACHE_SIZE - to);
> - flush_dcache_page(page);
> - kunmap_atomic(kaddr, KM_USER0);
> + if (to - from != PAGE_CACHE_SIZE)
> + if (from)
> + zero_user_page(page, 0, from, KM_USER0);
> + if (to < PAGE_CACHE_SIZE)
> + zero_user_page(page, to,
> + PAGE_CACHE_SIZE - to, KM_USER0);
Why the two additional condition checks? The previous code didn't have
(or need) them, so this patch clearly does something more than simply
replacing open-coding with zero_user_page().
Either you've fixed an issue (in which case this should've been a
different patch with the accompanying explanation) or else I don't see
what we gain with the additional if's. Again, we still do incur the
overhead of two successive kmap_atomic() / kunmap_atomic() calls for
the same page in order to replace the open-coding.
next prev parent reply other threads:[~2007-04-30 6:53 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-04-30 6:14 Christoph Lameter
2007-04-30 6:53 ` Satyam Sharma [this message]
2007-04-30 7:04 ` Christoph Lameter
2007-05-02 0:26 ` Andrew Morton
2007-05-02 1:09 ` Christoph Lameter
2007-05-02 2:16 ` Nate Diller
2007-05-02 2:27 ` Nate Diller
2007-05-02 3:58 ` Christoph Lameter
2007-05-02 4:09 ` Andrew Morton
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=a781481a0704292353v34ea217fpbbf732465dd652e8@mail.gmail.com \
--to=satyam.sharma@gmail.com \
--cc=akpm@linux-foundation.org \
--cc=clameter@sgi.com \
--cc=linux-kernel@vger.kernel.org \
--cc=nate.diller@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome