From: Paul Durrant <xadimgnik@gmail.com>
To: Sean Christopherson <seanjc@google.com>,
Paolo Bonzini <pbonzini@redhat.com>
Cc: kvm@vger.kernel.org, linux-kernel@vger.kernel.org,
syzbot+106a4f72b0474e1d1b33@syzkaller.appspotmail.com,
David Woodhouse <dwmw2@infradead.org>
Subject: Re: [PATCH 1/3] KVM: Add helpers to consolidate gfn_to_pfn_cache's page split check
Date: Thu, 21 Mar 2024 11:07:50 +0000 [thread overview]
Message-ID: <a80b46a2-d07a-466e-b2b3-bed685292e47@xen.org> (raw)
In-Reply-To: <20240320001542.3203871-2-seanjc@google.com>
On 20/03/2024 00:15, Sean Christopherson wrote:
> Add a helper to check that the incoming length for a gfn_to_pfn_cache is
> valid with respect to the cache's GPA and/or HVA. To avoid activating a
> cache with a bogus GPA, a future fix will fork the page split check in
> the inner refresh path into activate() and the public rerfresh() APIs, at
nit: typo
> which point KVM will check the length in three separate places.
>
> Deliberately keep the "page offset" logic open coded, as the only other
> path that consumes the offset, __kvm_gpc_refresh(), already needs to
> differentiate between GPA-based and HVA-based caches, and it's not obvious
> that using a helper is a net positive in overall code readability.
>
> Note, for GPA-based caches, this has a subtle side effect of using the GPA
> instead of the resolved HVA in the check() path, but that should be a nop
> as the HVA offset is derived from the GPA, i.e. the two offsets are
> identical, barring a KVM bug.
>
> Signed-off-by: Sean Christopherson <seanjc@google.com>
> ---
> virt/kvm/pfncache.c | 27 +++++++++++++++++++--------
> 1 file changed, 19 insertions(+), 8 deletions(-)
>
Reviewed-by: Paul Durrant <paul@xen.org>
next prev parent reply other threads:[~2024-03-21 11:07 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-03-20 0:15 [PATCH 0/3] KVM: Fix for a mostly benign gpc WARN Sean Christopherson
2024-03-20 0:15 ` [PATCH 1/3] KVM: Add helpers to consolidate gfn_to_pfn_cache's page split check Sean Christopherson
2024-03-20 8:20 ` David Woodhouse
2024-03-21 11:07 ` Paul Durrant [this message]
2024-03-20 0:15 ` [PATCH 2/3] KVM: Check validity of offset+length of gfn_to_pfn_cache prior to activation Sean Christopherson
2024-03-20 8:20 ` David Woodhouse
2024-03-21 11:11 ` Paul Durrant
2024-03-20 0:15 ` [PATCH 3/3] KVM: Explicitly disallow activatating a gfn_to_pfn_cache with INVALID_GPA Sean Christopherson
2024-03-20 8:20 ` David Woodhouse
2024-03-21 11:13 ` Paul Durrant
2024-03-22 11:39 ` [PATCH 0/3] KVM: Fix for a mostly benign gpc WARN David Woodhouse
2024-04-08 23:21 ` Sean Christopherson
2024-04-09 2:33 ` David Woodhouse
2024-04-09 14:28 ` Sean Christopherson
2024-04-09 2:01 ` Sean Christopherson
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=a80b46a2-d07a-466e-b2b3-bed685292e47@xen.org \
--to=xadimgnik@gmail.com \
--cc=dwmw2@infradead.org \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=paul@xen.org \
--cc=pbonzini@redhat.com \
--cc=seanjc@google.com \
--cc=syzbot+106a4f72b0474e1d1b33@syzkaller.appspotmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®