mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Dave Young" <hidave.darkstar@gmail.com>
To: "Greg KH" <gregkh@suse.de>
Cc: linux-kernel@vger.kernel.org
Subject: Re: The use of KOBJ_NAME_LEN
Date: Tue, 4 Dec 2007 16:22:13 +0800	[thread overview]
Message-ID: <a8e1da0712040022x6403ced5n62ff1a7a2d219e7c@mail.gmail.com> (raw)
In-Reply-To: <20071204082027.GA3014@suse.de>

On Dec 4, 2007 4:20 PM, Greg KH <gregkh@suse.de> wrote:
> On Tue, Dec 04, 2007 at 03:53:15PM +0800, Dave Young wrote:
> > On Dec 4, 2007 3:46 PM, Greg KH <gregkh@suse.de> wrote:
> > > On Tue, Dec 04, 2007 at 02:45:47PM +0800, Dave Young wrote:
> > > > Hi,
> > > > Does the KOBJ_NAME_LEN really means the limit of kobject name length? seems
> > > > not . And if it's true, is the KOBJ_NAME_LEN of 20 enough to use?
> > >
> > > No, not anymore, the kobject name is totally dynamic.
> >
> > Eh, Why does this macro still exist? If KOBJ_NAME_LEN is really
> > needed, maybe it should be renamed to something else to avoid
> > misleading.
>
> Right now other .h files use it also.  It isn't hurting anything for
> now, and Kay has some patches he is working on to get rid of the static
> bus_id array, which will then let us get rid of that define entirely.
>

Good to know, thanks!

> thanks,
>
> greg k-h
>

      reply	other threads:[~2007-12-04  8:22 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-12-04  6:45 Dave Young
2007-12-04  6:50 ` Robert P. J. Day
2007-12-04  7:17   ` Dave Young
2007-12-04  7:46   ` Greg KH
2007-12-04  8:02     ` Robert P. J. Day
2007-12-04  7:46 ` Greg KH
2007-12-04  7:53   ` Dave Young
2007-12-04  8:20     ` Greg KH
2007-12-04  8:22       ` Dave Young [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=a8e1da0712040022x6403ced5n62ff1a7a2d219e7c@mail.gmail.com \
    --to=hidave.darkstar@gmail.com \
    --cc=gregkh@suse.de \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®