From: Juergen Gross <jgross@suse.com>
To: Borislav Petkov <bp@alien8.de>, Josh Poimboeuf <jpoimboe@redhat.com>
Cc: x86@kernel.org, linux-kernel@vger.kernel.org,
Andy Lutomirski <luto@kernel.org>,
Linus Torvalds <torvalds@linux-foundation.org>,
Sasha Levin <alexander.levin@verizon.com>,
live-patching@vger.kernel.org, Jiri Slaby <jslaby@suse.cz>,
Ingo Molnar <mingo@kernel.org>, "H. Peter Anvin" <hpa@zytor.com>,
Peter Zijlstra <peterz@infradead.org>,
Mike Galbraith <efault@gmx.de>,
Chris Wright <chrisw@sous-sol.org>,
Alok Kataria <akataria@vmware.com>,
Rusty Russell <rusty@rustcorp.com.au>,
virtualization@lists.linux-foundation.org,
Boris Ostrovsky <boris.ostrovsky@oracle.com>,
xen-devel@lists.xenproject.org,
Thomas Gleixner <tglx@linutronix.de>
Subject: Re: [PATCH 03/13] x86/paravirt: Convert native patch assembly code strings to macros
Date: Fri, 17 Nov 2017 20:10:13 +0100 [thread overview]
Message-ID: <a9531df0-0a48-e695-a05a-56e654f9dfbb@suse.com> (raw)
In-Reply-To: <20171117180713.e4up3dwrszpatka6@pd.tnic>
On 17/11/17 19:07, Borislav Petkov wrote:
> On Wed, Oct 04, 2017 at 10:58:24AM -0500, Josh Poimboeuf wrote:
>> Convert the hard-coded native patch assembly code strings to macros to
>> facilitate sharing common code between 32-bit and 64-bit.
>>
>> These macros will also be used by a future patch which requires the GCC
>> extended asm syntax of two '%' characters instead of one when specifying
>> a register name.
>>
>> Signed-off-by: Josh Poimboeuf <jpoimboe@redhat.com>
>> ---
>> arch/x86/include/asm/special_insns.h | 24 ++++++++++++++++++++++++
>> arch/x86/kernel/paravirt_patch_32.c | 21 +++++++++++----------
>> arch/x86/kernel/paravirt_patch_64.c | 29 +++++++++++++++--------------
>> 3 files changed, 50 insertions(+), 24 deletions(-)
>>
>> diff --git a/arch/x86/include/asm/special_insns.h b/arch/x86/include/asm/special_insns.h
>> index ac402c6fc24b..0549c5f2c1b3 100644
>> --- a/arch/x86/include/asm/special_insns.h
>> +++ b/arch/x86/include/asm/special_insns.h
>> @@ -6,6 +6,30 @@
>>
>> #include <asm/nops.h>
>>
>> +#ifdef CONFIG_X86_64
>> +# define _REG_ARG1 "%rdi"
>> +# define NATIVE_IDENTITY_32 "mov %edi, %eax"
>
> Yeah, that "identity" looks strange. How about NATIVE_NOOP and
> NATIVE_NOOP_32 ?
Those are not NOPs. They return the identical value which was passed to
them. So identity isn't a bad name after all.
>
>> +# define NATIVE_USERGS_SYSRET64 "swapgs; sysretq"
>> +#else
>> +# define _REG_ARG1 "%eax"
>> +#endif
>> +
>> +#define _REG_RET "%" _ASM_AX
>> +
>> +#define NATIVE_ZERO "xor " _REG_ARG1 ", " _REG_ARG1
>
> NATIVE_ZERO_OUT
>
> I guess. NATIVE_ZERO reads like the native representation of 0 :-)
NATIVE_ZERO_ARG1?
Juergen
next prev parent reply other threads:[~2017-11-17 19:10 UTC|newest]
Thread overview: 59+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-10-04 15:58 [PATCH 00/13] x86/paravirt: Make pv ops code generation more closely match reality Josh Poimboeuf
2017-10-04 15:58 ` [PATCH 01/13] x86/paravirt: remove wbinvd() paravirt interface Josh Poimboeuf
2017-10-24 13:17 ` Juergen Gross
2017-11-17 14:39 ` Borislav Petkov
2017-10-04 15:58 ` [PATCH 02/13] x86/paravirt: Fix output constraint macro names Josh Poimboeuf
2017-10-25 9:33 ` Juergen Gross
2017-11-16 20:50 ` Josh Poimboeuf
2017-11-17 6:55 ` Juergen Gross
2017-10-04 15:58 ` [PATCH 03/13] x86/paravirt: Convert native patch assembly code strings to macros Josh Poimboeuf
2017-10-25 9:46 ` Juergen Gross
2017-11-16 21:04 ` Josh Poimboeuf
2017-11-17 18:07 ` Borislav Petkov
2017-11-17 19:10 ` Juergen Gross [this message]
2017-11-17 19:42 ` Josh Poimboeuf
2017-11-18 10:20 ` Juergen Gross
2017-11-18 13:17 ` Josh Poimboeuf
2017-10-04 15:58 ` [PATCH 04/13] x86/paravirt: Convert DEF_NATIVE macro to GCC extended asm syntax Josh Poimboeuf
2017-10-25 10:03 ` Juergen Gross
2017-10-04 15:58 ` [PATCH 05/13] x86/paravirt: Move paravirt asm macros to paravirt-asm.h Josh Poimboeuf
2017-10-25 10:32 ` Juergen Gross
2017-10-04 15:58 ` [PATCH 06/13] x86/paravirt: Clean up paravirt-asm.h Josh Poimboeuf
2017-10-25 10:59 ` Juergen Gross
2017-10-04 15:58 ` [PATCH 07/13] x86/paravirt: Simplify ____PVOP_CALL() Josh Poimboeuf
2017-10-25 11:01 ` Juergen Gross
2017-11-22 16:35 ` Borislav Petkov
2017-10-04 15:58 ` [PATCH 08/13] x86/paravirt: Clean up paravirt_types.h Josh Poimboeuf
2017-10-25 11:08 ` Juergen Gross
2017-11-22 20:46 ` Borislav Petkov
2017-10-04 15:58 ` [PATCH 09/13] x86/asm: Convert ALTERNATIVE*() assembler macros to preprocessor macros Josh Poimboeuf
2017-10-25 11:14 ` Juergen Gross
2017-10-04 15:58 ` [PATCH 10/13] x86/alternative: Support indirect call replacement Josh Poimboeuf
2017-10-25 11:25 ` Juergen Gross
2017-11-16 21:19 ` Josh Poimboeuf
2017-11-17 5:46 ` Juergen Gross
2017-11-17 19:52 ` H. Peter Anvin
2017-10-04 15:58 ` [PATCH 11/13] x86/paravirt: Add paravirt alternatives infrastructure Josh Poimboeuf
2017-10-05 20:35 ` Boris Ostrovsky
2017-10-06 14:32 ` Josh Poimboeuf
2017-10-06 15:29 ` Boris Ostrovsky
2017-10-06 16:30 ` Josh Poimboeuf
2017-10-12 19:11 ` Boris Ostrovsky
2017-10-12 19:27 ` [Xen-devel] " Andrew Cooper
2017-10-12 19:53 ` Boris Ostrovsky
2017-10-16 18:18 ` Boris Ostrovsky
2017-10-17 5:24 ` Josh Poimboeuf
2017-10-17 13:58 ` Boris Ostrovsky
2017-10-17 14:36 ` Josh Poimboeuf
2017-10-17 15:36 ` Boris Ostrovsky
2017-10-17 20:17 ` Josh Poimboeuf
2017-10-17 20:36 ` Boris Ostrovsky
2017-10-17 20:50 ` Josh Poimboeuf
2017-10-17 20:59 ` Boris Ostrovsky
2017-10-17 21:03 ` Josh Poimboeuf
2017-10-17 13:10 ` Brian Gerst
2017-10-17 14:05 ` Boris Ostrovsky
2017-10-04 15:58 ` [PATCH 12/13] objtool: Add support for new .pv_altinstructions section Josh Poimboeuf
2017-10-04 15:58 ` [PATCH 13/13] x86/paravirt: Convert natively patched pv ops to use paravirt alternatives Josh Poimboeuf
2017-10-06 7:35 ` [Xen-devel] [PATCH 00/13] x86/paravirt: Make pv ops code generation more closely match reality Vitaly Kuznetsov
2017-10-06 14:36 ` Josh Poimboeuf
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=a9531df0-0a48-e695-a05a-56e654f9dfbb@suse.com \
--to=jgross@suse.com \
--cc=akataria@vmware.com \
--cc=alexander.levin@verizon.com \
--cc=boris.ostrovsky@oracle.com \
--cc=bp@alien8.de \
--cc=chrisw@sous-sol.org \
--cc=efault@gmx.de \
--cc=hpa@zytor.com \
--cc=jpoimboe@redhat.com \
--cc=jslaby@suse.cz \
--cc=linux-kernel@vger.kernel.org \
--cc=live-patching@vger.kernel.org \
--cc=luto@kernel.org \
--cc=mingo@kernel.org \
--cc=peterz@infradead.org \
--cc=rusty@rustcorp.com.au \
--cc=tglx@linutronix.de \
--cc=torvalds@linux-foundation.org \
--cc=virtualization@lists.linux-foundation.org \
--cc=x86@kernel.org \
--cc=xen-devel@lists.xenproject.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome