mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Xiao Guangrong <xiaoguangrong.eric@gmail.com>
To: Xiao Guangrong <guangrong.xiao@gmail.com>,
	kvm@vger.kernel.org, x86@kernel.org,
	linux-kernel@vger.kernel.org, Paolo Bonzini <pbonzini@redhat.com>,
	rkrcmar@redhat.com, Dan Williams <dan.j.williams@intel.com>,
	ivan.d.cuevas.escareno@intel.com, karthik.kumar@intel.com,
	Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>,
	Olif Chapman <olif.chapman@oracle.com>,
	Ingo Molnar <mingo@redhat.com>
Subject: Re: [PATCH v4 3/3] KVM: MMU: consider host cache mode in MMIO page check
Date: Fri, 3 Nov 2017 17:24:43 +0800	[thread overview]
Message-ID: <a9c1e3ec-e9da-331d-a003-983b3f91430a@gmail.com> (raw)
In-Reply-To: <20171103090244.swsna6h4hk5j4bdh@hz-desktop>



On 11/03/2017 05:02 PM, Haozhong Zhang wrote:
> On 11/03/17 16:51 +0800, Haozhong Zhang wrote:
>> On 11/03/17 14:54 +0800, Xiao Guangrong wrote:
>>>
>>>
>>> On 11/03/2017 01:53 PM, Haozhong Zhang wrote:
>>>> Some reserved pages, such as those from NVDIMM DAX devices, are
>>>> not for MMIO, and can be mapped with cached memory type for better
>>>> performance. However, the above check misconceives those pages as
>>>> MMIO.  Because KVM maps MMIO pages with UC memory type, the
>>>> performance of guest accesses to those pages would be harmed.
>>>> Therefore, we check the host memory type by lookup_memtype() in
>>>> addition and only treat UC/UC- pages as MMIO.
>>>>
>>>> Signed-off-by: Haozhong Zhang <haozhong.zhang@intel.com>
>>>> Reported-by: Cuevas Escareno, Ivan D <ivan.d.cuevas.escareno@intel.com>
>>>> Reported-by: Kumar, Karthik <karthik.kumar@intel.com>
>>>> ---
>>>>    arch/x86/kvm/mmu.c | 19 ++++++++++++++++++-
>>>>    1 file changed, 18 insertions(+), 1 deletion(-)
>>>>
>>>> diff --git a/arch/x86/kvm/mmu.c b/arch/x86/kvm/mmu.c
>>>> index 0b481cc9c725..e9ed0e666a83 100644
>>>> --- a/arch/x86/kvm/mmu.c
>>>> +++ b/arch/x86/kvm/mmu.c
>>>> @@ -2708,7 +2708,24 @@ static bool mmu_need_write_protect(struct kvm_vcpu *vcpu, gfn_t gfn,
>>>>    static bool kvm_is_mmio_pfn(kvm_pfn_t pfn)
>>>>    {
>>>>    	if (pfn_valid(pfn))
>>>> -		return !is_zero_pfn(pfn) && PageReserved(pfn_to_page(pfn));
>>>> +		return !is_zero_pfn(pfn) && PageReserved(pfn_to_page(pfn)) &&
>>>> +			/*
>>>> +			 * Some reserved pages, such as those from
>>>> +			 * NVDIMM DAX devices, are not for MMIO, and
>>>> +			 * can be mapped with cached memory type for
>>>> +			 * better performance. However, the above
>>>> +			 * check misconceives those pages as MMIO.
>>>> +			 * Because KVM maps MMIO pages with UC memory
>>>> +			 * type, the performance of guest accesses to
>>>> +			 * those pages would be harmed. Therefore, we
>>>> +			 * check the host memory type in addition and
>>>> +			 * only treat UC/UC- pages as MMIO.
>>>> +			 *
>>>> +			 * pat_pfn_is_uc() works only when PAT is enabled,
>>>> +			 * so check pat_enabled() as well.
>>>> +			 */
>>>> +			(!pat_enabled() ||
>>>> +			 pat_pfn_is_uc(kvm_pfn_t_to_pfn_t(pfn)));
>>>
>>> Can it be compiled if !CONFIG_PAT?
>>
>> Yes.
>>
>> What I check via pat_enabled() is not only whether PAT support is
>> compiled, but also whether PAT is enabled at runtime.
>>
>>>
>>> It would be better if we move pat_enabled out of kvm as well,
>>
>> Surely I can combine them in one function like
>>
>> bool pat_pfn_is_uc(pfn_t pfn)
>> {
>> 	enum page_cache_mode cm;
>>
>> 	if (!pat_enabled())
>> 		return false;
>>
>> 	cm = lookup_memtype(pfn_t_to_phys(pfn));
>>
>> 	return cm == _PAGE_CACHE_MODE_UC || cm == _PAGE_CACHE_MODE_UC_MINUS;
>> }
> 
> In addition, I think it's better to split this function into
> pat_pfn_is_uc() and pat_pfn_is_uc_minus() to avoid additional
> confusion.

Why not use pat_pfn_is_uc_or_uc_minus(). :)

  reply	other threads:[~2017-11-03  9:24 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-11-03  5:53 [PATCH v4 0/3] KVM: MMU: fix kvm_is_mmio_pfn() Haozhong Zhang
2017-11-03  5:53 ` [PATCH v4 1/3] x86/mm: add function to check if a pfn is UC/UC- Haozhong Zhang
2017-11-03  5:53 ` [PATCH v4 2/3] KVM: add converters between pfn_t and kvm_pfn_t Haozhong Zhang
2017-11-03 13:21   ` Dan Williams
2017-11-08  2:47     ` Haozhong Zhang
2017-11-03  5:53 ` [PATCH v4 3/3] KVM: MMU: consider host cache mode in MMIO page check Haozhong Zhang
2017-11-03  6:54   ` Xiao Guangrong
2017-11-03  8:51     ` Haozhong Zhang
2017-11-03  9:02       ` Haozhong Zhang
2017-11-03  9:24         ` Xiao Guangrong [this message]
2017-11-03  9:29           ` Haozhong Zhang
2017-11-08  3:42             ` Xiao Guangrong
2017-11-03  9:10       ` Xiao Guangrong
2017-11-03  9:27         ` Haozhong Zhang
2017-11-08  3:34       ` Haozhong Zhang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=a9c1e3ec-e9da-331d-a003-983b3f91430a@gmail.com \
    --to=xiaoguangrong.eric@gmail.com \
    --cc=dan.j.williams@intel.com \
    --cc=guangrong.xiao@gmail.com \
    --cc=ivan.d.cuevas.escareno@intel.com \
    --cc=karthik.kumar@intel.com \
    --cc=konrad.wilk@oracle.com \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=olif.chapman@oracle.com \
    --cc=pbonzini@redhat.com \
    --cc=rkrcmar@redhat.com \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®