From: Lukas Wunner <lukas@wunner.de>
To: Bjorn Helgaas <helgaas@kernel.org>
Cc: linux-pci@vger.kernel.org,
Manivannan Sadhasivam <manivannan.sadhasivam@linaro.org>,
Cyril Brulebois <kibi@debian.org>,
Nicolas Saenz Julienne <nsaenz@kernel.org>,
Lorenzo Pieralisi <lorenzo.pieralisi@arm.com>,
Krzysztof Wilczy??ski <kwilczynski@kernel.org>,
Bartosz Golaszewski <brgl@bgdev.pl>,
Jim Quinlan <james.quinlan@broadcom.com>,
bcm-kernel-feedback-list@broadcom.com,
linux-kernel@vger.kernel.org, Bjorn Helgaas <bhelgaas@google.com>
Subject: Re: [PATCH] PCI/pwrctrl: Skip creating platform device unless CONFIG_PCI_PWRCTL enabled
Date: Sat, 24 May 2025 08:29:46 +0200 [thread overview]
Message-ID: <aDFnWhFa9ZGqr67T@wunner.de> (raw)
In-Reply-To: <20250524024207.GA1598583@bhelgaas>
On Fri, May 23, 2025 at 09:42:07PM -0500, Bjorn Helgaas wrote:
> What I would prefer is something like the first paragraph in that
> section: the #ifdef in a header file that declares the function and
> defines a no-op stub, with the implementation in some pwrctrl file.
pci_pwrctrl_create_device() is static, but it is possible to #ifdef
the whole function in the .c file and provide the stub in an #else
branch. That's easier to follow than #ifdef'ing portions of the
function.
Thanks,
Lukas
next prev parent reply other threads:[~2025-05-24 6:29 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-05-23 20:17 Bjorn Helgaas
2025-05-23 21:26 ` Lukas Wunner
2025-05-24 2:42 ` Bjorn Helgaas
2025-05-24 6:29 ` Lukas Wunner [this message]
2025-05-24 8:51 ` Manivannan Sadhasivam
2025-05-27 22:25 ` Bjorn Helgaas
2025-05-29 19:23 ` Jim Quinlan
2025-05-30 3:16 ` Manivannan Sadhasivam
2025-05-30 3:13 ` Manivannan Sadhasivam
2025-06-20 0:06 ` Florian Fainelli
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aDFnWhFa9ZGqr67T@wunner.de \
--to=lukas@wunner.de \
--cc=bcm-kernel-feedback-list@broadcom.com \
--cc=bhelgaas@google.com \
--cc=brgl@bgdev.pl \
--cc=helgaas@kernel.org \
--cc=james.quinlan@broadcom.com \
--cc=kibi@debian.org \
--cc=kwilczynski@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=lorenzo.pieralisi@arm.com \
--cc=manivannan.sadhasivam@linaro.org \
--cc=nsaenz@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®