From: Yury Norov <yury.norov@gmail.com>
To: "Rafael J. Wysocki" <rafael@kernel.org>
Cc: Daniel Lezcano <daniel.lezcano@linaro.org>,
linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] cpuidle: dt: fix opencoded for_each_cpu() in idle_state_valid()
Date: Mon, 7 Jul 2025 11:30:58 -0400 [thread overview]
Message-ID: <aGvoMhLuX0-zIFVk@yury> (raw)
In-Reply-To: <CAJZ5v0h7CeO+vG4BVcdc=XxcWMRY+OmhrWxtrAS59T-uK1KDOw@mail.gmail.com>
On Wed, Jul 02, 2025 at 08:27:21PM +0200, Rafael J. Wysocki wrote:
> On Wed, Jun 4, 2025 at 11:39 PM Yury Norov <yury.norov@gmail.com> wrote:
> >
> > From: Yury Norov [NVIDIA] <yury.norov@gmail.com>
> >
> > The function opencodes the for_each_cpu_from() by using an open for-loop.
> > Fix that in sake of readability.
> >
> > While there, drop the 'valid' variable as it's pretty useless here.
> >
> > Signed-off-by: Yury Norov [NVIDIA] <yury.norov@gmail.com>
> > ---
> > drivers/cpuidle/dt_idle_states.c | 14 +++++---------
> > 1 file changed, 5 insertions(+), 9 deletions(-)
> >
> > diff --git a/drivers/cpuidle/dt_idle_states.c b/drivers/cpuidle/dt_idle_states.c
> > index 97feb7d8fb23..558d49838990 100644
> > --- a/drivers/cpuidle/dt_idle_states.c
> > +++ b/drivers/cpuidle/dt_idle_states.c
> > @@ -98,7 +98,6 @@ static bool idle_state_valid(struct device_node *state_node, unsigned int idx,
> > {
> > int cpu;
> > struct device_node *cpu_node, *curr_state_node;
> > - bool valid = true;
> >
> > /*
> > * Compare idle state phandles for index idx on all CPUs in the
> > @@ -107,20 +106,17 @@ static bool idle_state_valid(struct device_node *state_node, unsigned int idx,
> > * retrieved from. If a mismatch is found bail out straight
> > * away since we certainly hit a firmware misconfiguration.
> > */
> > - for (cpu = cpumask_next(cpumask_first(cpumask), cpumask);
> > - cpu < nr_cpu_ids; cpu = cpumask_next(cpu, cpumask)) {
> > + cpu = cpumask_first(cpumask) + 1;
>
> Doing
>
> cpu = cpumask_next(cpumask_first(cpumask), cpumask);
>
> here might save a few iterations for sparse cpumasks.
For that it's better to use cpumask_nth(1).
I believe there will be no benefit in calling cpumask_next() before
entering the loop because for_each_cpu_from() is based on it, and it
will be called anyways.
I can send v2 with cpumask_nth() change if you like it better. Please
let me know.
Thanks,
Yury
> > + for_each_cpu_from(cpu, cpumask) {
> > cpu_node = of_cpu_device_node_get(cpu);
> > curr_state_node = of_get_cpu_state_node(cpu_node, idx);
> > - if (state_node != curr_state_node)
> > - valid = false;
> > -
> > of_node_put(curr_state_node);
> > of_node_put(cpu_node);
> > - if (!valid)
> > - break;
> > + if (state_node != curr_state_node)
> > + return false;
> > }
> >
> > - return valid;
> > + return true;
> > }
> >
> > /**
> > --
> > 2.43.0
> >
next prev parent reply other threads:[~2025-07-07 15:31 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-06-04 21:39 Yury Norov
2025-07-02 18:27 ` Rafael J. Wysocki
2025-07-07 15:30 ` Yury Norov [this message]
2025-07-07 16:11 ` Rafael J. Wysocki
2025-07-10 12:54 ` Rafael J. Wysocki
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aGvoMhLuX0-zIFVk@yury \
--to=yury.norov@gmail.com \
--cc=daniel.lezcano@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=rafael@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®