mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Sean Christopherson <seanjc@google.com>
To: Mark Brown <broonie@kernel.org>
Cc: Kees Cook <kees@kernel.org>, Shuah Khan <shuah@kernel.org>,
	linux-kselftest@vger.kernel.org,  linux-kernel@vger.kernel.org,
	Vincent Mailhol <mailhol.vincent@wanadoo.fr>,
	 Arnaldo Carvalho de Melo <acme@redhat.com>,
	Paolo Bonzini <pbonzini@redhat.com>
Subject: Re: [PATCH] selftests: harness: Rework is_signed_type() to avoid collision with overflow.h
Date: Wed, 20 Aug 2025 08:15:41 -0700	[thread overview]
Message-ID: <aKXmnRTBzNklwdYk@google.com> (raw)
In-Reply-To: <aKXFKaJuZZTbAbJD@google.com>

On Wed, Aug 20, 2025, Sean Christopherson wrote:
> On Wed, Aug 20, 2025, Mark Brown wrote:
> > On Tue, Jun 24, 2025 at 04:19:30PM -0700, Sean Christopherson wrote:
> > > Rename is_signed_type() to is_signed_var() to avoid colliding with a macro
> > > of the same name defined by linux/overflow.h.  Note, overflow.h's version
> > > takes a type as the input, whereas the harness's version takes a variable!
> > 
> > This patch is in -next and is causing widespread breakage in the
> > selftests -next on at least arm and arm64 due to:
> > 
> > make --silent --keep-going --jobs=15 O=/build/stage/build-work INSTALL_PATH=/build/stage/build-work/kselftest_install ARCH=arm64 CROSS_COMPILE=aarch64-linux-gnu- CROSS_COMPILE_COMPAT=arm-linux-gnueabihf- kselftest-install
> > 
> > ...
> > 
> > In file included from test-pcmtest-driver.c:10:
> > ../kselftest_harness.h:59:10: fatal error: linux/overflow.h: No such file or directory
> >    59 | #include <linux/overflow.h>
> >       |          ^~~~~~~~~~~~~~~~~~
> > compilation terminated.
> 
> Argh, many selftests don't add tools/include to their include path.  The least
> awful thing I can think of is to go with a minimal fix to avoid the collision.
> AFAICT, nothing outside of kselftest_harness.h uses is_signed_type(), so this
> shouldn't cause a different flavor of breakage?

I force-pushed a straight rename.  Please holler if that somehow still breaks
builds.

[1/1] selftests: harness: Rename is_signed_type() to avoid collision with overflow.h
      https://github.com/kvm-x86/linux/commit/dce1b33ed743

      reply	other threads:[~2025-08-20 15:15 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-06-24 23:19 Sean Christopherson
2025-06-26 15:06 ` Vincent Mailhol
2025-06-27 20:44 ` Kees Cook
2025-07-07 21:11   ` Sean Christopherson
2025-08-19 23:11 ` Sean Christopherson
2025-08-20 11:11 ` Mark Brown
2025-08-20 12:52   ` Sean Christopherson
2025-08-20 15:15     ` Sean Christopherson [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=aKXmnRTBzNklwdYk@google.com \
    --to=seanjc@google.com \
    --cc=acme@redhat.com \
    --cc=broonie@kernel.org \
    --cc=kees@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-kselftest@vger.kernel.org \
    --cc=mailhol.vincent@wanadoo.fr \
    --cc=pbonzini@redhat.com \
    --cc=shuah@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®