On Mon, Aug 25, 2025 at 10:07:10AM -0700, Nathan Chancellor wrote: > On Mon, Aug 25, 2025 at 05:00:37PM +0200, Vlastimil Babka wrote: > > The module export checks are looking for EXPORT_SYMBOL_GPL_FOR_MODULES() > > which was renamed to EXPORT_SYMBOL_FOR_MODULES(). Update the checks. > > > > Fixes: 6d3c3ca4c77e ("module: Rename EXPORT_SYMBOL_GPL_FOR_MODULES to EXPORT_SYMBOL_FOR_MODULES") > > Signed-off-by: Vlastimil Babka > > --- > > I've missed these new checks when renaming the export macro due to my > > git grep being too narrow. My commit went through Christian's vfs tree > > but seems the script is part of kbuild (which is currently Odd fixes). > > If this needs to reach Linus's tree to avoid warnings, it could go via > another vfs fixes pull request with our ack or we could ask him to pick > it up directly (as I am not sure we will have a fixes pull request this > cycle). If it is not urgent, I can pick it up via kbuild-next for 6.18. > I have no strong preference. Hm, you're right, the check will issue false warnings (and misses to warn when it should) without this update. Therefore I think it would be good to get the patch merged soon - even though the warnings are only issued with W=2. So, I second asking for the patch to go via vfs fixes or directly via Linus. If it helps: Acked-by: Nicolas Schier Kind regards, Nicolas