mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Marcus Folkesson <marcus.folkesson@gmail.com>
To: Bartosz Golaszewski <brgl@bgdev.pl>
Cc: Wolfram Sang <wsa+renesas@sang-engineering.com>,
	Peter Rosin <peda@axentia.se>,
	Michael Hennerich <michael.hennerich@analog.com>,
	Andi Shyti <andi.shyti@kernel.org>,
	linux-i2c@vger.kernel.org, linux-kernel@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH RFC 5/7] i2c: davinci: calculate bus freq from Hz instead of kHz
Date: Mon, 22 Sep 2025 16:50:11 +0200	[thread overview]
Message-ID: <aNFiI_4HAP5sBSTP@gmail.com> (raw)
In-Reply-To: <CAMRc=MdMMQxFfkMPHaUg9nMWuW9F1p+PT2i-ggcU5SSFKOVGKQ@mail.gmail.com>

[-- Attachment #1: Type: text/plain, Size: 742 bytes --]


Hi Bartosz,

On Mon, Sep 22, 2025 at 07:42:43AM -0700, Bartosz Golaszewski wrote:
> On Mon, 22 Sep 2025 08:21:00 +0200, Marcus Folkesson
> <marcus.folkesson@gmail.com> said:
> > The bus frequency is unnecessarily converted between Hz and kHz in
> > several places.
> > This is probably an old legacy from the old times (pre-devicetrees)
> > when the davinci_i2c_platform_data took the bus_freq in kHz.
> >
> > Stick to Hz.
> >
> 
> This looks good but would you mind also changing the name of the field to
> bus_freq_hz in order to leave zero change of misinterpreting it in the future?

Thanks for your review!
Sounds fair, I will change the name to bus_freq_hz in v2.

> 
> Bartosz

Best regards,
Marcus Folkesson

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

  reply	other threads:[~2025-09-22 14:50 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-09-22  6:20 [PATCH RFC 0/7] I2C Mux per channel bus speed Marcus Folkesson
2025-09-22  6:20 ` [PATCH RFC 1/7] i2c: core: add callback to change bus frequency Marcus Folkesson
2025-09-22  6:20 ` [PATCH RFC 2/7] i2c: mux: add idle_state property to i2c_mux_core Marcus Folkesson
2025-09-22  6:20 ` [PATCH RFC 3/7] i2c: mux: add support for per channel bus frequency Marcus Folkesson
2025-09-22  6:20 ` [PATCH RFC 4/7] i2c: mux: ltc4306: set correct idle_state in i2c_mux_core Marcus Folkesson
2025-09-22  6:21 ` [PATCH RFC 5/7] i2c: davinci: calculate bus freq from Hz instead of kHz Marcus Folkesson
2025-09-22 14:42   ` Bartosz Golaszewski
2025-09-22 14:50     ` Marcus Folkesson [this message]
2025-09-22  6:21 ` [PATCH RFC 6/7] i2c: davinci: add support for setting bus frequency Marcus Folkesson
2025-09-22 14:43   ` Bartosz Golaszewski
2025-09-22  6:21 ` [PATCH RFC 7/7] docs: i2c: i2c-topology: add section about bus speed Marcus Folkesson
2025-09-23 15:10 ` [PATCH RFC 0/7] I2C Mux per channel " Peter Rosin
2025-09-23 20:37   ` Marcus Folkesson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=aNFiI_4HAP5sBSTP@gmail.com \
    --to=marcus.folkesson@gmail.com \
    --cc=andi.shyti@kernel.org \
    --cc=brgl@bgdev.pl \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-i2c@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=michael.hennerich@analog.com \
    --cc=peda@axentia.se \
    --cc=wsa+renesas@sang-engineering.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®