mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
To: Bartosz Golaszewski <brgl@bgdev.pl>
Cc: Linus Walleij <linus.walleij@linaro.org>,
	Daniel Scally <djrscally@gmail.com>,
	Heikki Krogerus <heikki.krogerus@linux.intel.com>,
	Sakari Ailus <sakari.ailus@linux.intel.com>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	"Rafael J. Wysocki" <rafael@kernel.org>,
	Danilo Krummrich <dakr@kernel.org>,
	Philipp Zabel <p.zabel@pengutronix.de>,
	Krzysztof Kozlowski <krzk@kernel.org>,
	linux-gpio@vger.kernel.org, linux-kernel@vger.kernel.org,
	linux-acpi@vger.kernel.org,
	Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
Subject: Re: [PATCH v4 03/10] software node: allow referencing firmware nodes
Date: Mon, 3 Nov 2025 15:46:25 +0200	[thread overview]
Message-ID: <aQiyMdvUhPQxkpmw@smile.fi.intel.com> (raw)
In-Reply-To: <CAMRc=Md=r7GaO3A_7de+EqzboyA2cqNSTZx7+64VSMvRBb9gpw@mail.gmail.com>

On Mon, Nov 03, 2025 at 11:36:36AM +0100, Bartosz Golaszewski wrote:
> On Mon, Nov 3, 2025 at 10:49 AM Andy Shevchenko
> <andriy.shevchenko@linux.intel.com> wrote:
> > On Mon, Nov 03, 2025 at 10:35:23AM +0100, Bartosz Golaszewski wrote:

...

> > > +#define SOFTWARE_NODE_REF_SWNODE(_ref, ...)                  \
> > > +     __SOFTWARE_NODE_REF(_ref, __VA_ARGS__)
> > > +
> > > +#define SOFTWARE_NODE_REF_FWNODE(_ref, ...)                  \
> > > +     __SOFTWARE_NODE_REF(_ref, __VA_ARGS__)
> > > +
> > > +/* DEPRECATED, use SOFTWARE_NODE_REF_SWNODE() instead. */
> > > +#define SOFTWARE_NODE_REFERENCE(_ref, ...)                   \
> > > +     SOFTWARE_NODE_REF_SWNODE(_ref, __VA_ARGS__)
> >
> > Now, useless.
> 
> No, why? With these changes, SOFTWARE_NODE_REFERENCE()'s name is a bit
> misleading or incomplete, so I'm proposing to start replacing it with
> SOFTWARE_NODE_REF_SWNODE() which is compatible with the former but has
> a better name.

It's an unneeded churn. I don't see a confusion here. One may interpret
That it is a reference in a software node to another node.

...

> > > -#define PROPERTY_ENTRY_REF(_name_, _ref_, ...)                               \
> > > +#define __PROPERTY_ENTRY_REF(_type, _name, _ref, ...)                        \
> > >  (struct property_entry) {                                            \
> > > -     .name = _name_,                                                 \
> > > +     .name = _name,                                                  \
> > >       .length = sizeof(struct software_node_ref_args),                \
> > >       .type = DEV_PROP_REF,                                           \
> > > -     { .pointer = &SOFTWARE_NODE_REFERENCE(_ref_, ##__VA_ARGS__), }, \
> > > +     { .pointer = &_type(_ref, ##__VA_ARGS__), },                    \
> > >  }
> >
> > Do we need this now? I assume that _Generic() takes case of this.


> Ah, right, it should be done here as well.

Just it should work as is without changes, did I miss anything?

...

> > > +#define PROPERTY_ENTRY_REF_SWNODE(_name, _ref, ...)                  \
> > > +     __PROPERTY_ENTRY_REF(SOFTWARE_NODE_REF_SWNODE,                  \
> > > +                          _name, _ref, __VA_ARGS__)
> > > +
> > > +#define PROPERTY_ENTRY_REF_FWNODE(_name, _ref, ...)                  \
> > > +     __PROPERTY_ENTRY_REF(SOFTWARE_NODE_REF_FWNODE,                  \
> > > +                         _name, _ref, __VA_ARGS__)
> > > +
> > > +/* DEPRECATED, use PROPERTY_ENTRY_REF_SWNODE() instead. */
> > > +#define PROPERTY_ENTRY_REF(_name, _ref, ...)                         \
> > > +     PROPERTY_ENTRY_REF_SWNODE(_name, _ref, __VA_ARGS__)
> >
> > Seems like useless churn.
> 
> This is the same argument as with SOFTWARE_NODE_REF_SWNODE(). It's not
> clear from the name what PROPERTY_ENTRY_REF() is really referencing.

Same answer as above.

...

TL;DR: Let's leave renaming / splitting to another series. It doesn't sound
like a required thingy. Only what I see is unneeded churn.

-- 
With Best Regards,
Andy Shevchenko



  parent reply	other threads:[~2025-11-03 13:46 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-11-03  9:35 [PATCH v4 00/10] reset: rework reset-gpios handling Bartosz Golaszewski
2025-11-03  9:35 ` [PATCH v4 01/10] software node: read the reference args via the fwnode API Bartosz Golaszewski
2025-11-03 10:53   ` Sakari Ailus
2025-11-03  9:35 ` [PATCH v4 02/10] software node: increase the reference of the swnode by its fwnode Bartosz Golaszewski
2025-11-03 10:53   ` Sakari Ailus
2025-11-03  9:35 ` [PATCH v4 03/10] software node: allow referencing firmware nodes Bartosz Golaszewski
2025-11-03  9:49   ` Andy Shevchenko
2025-11-03 10:36     ` Bartosz Golaszewski
2025-11-03 10:52       ` Sakari Ailus
2025-11-03 10:56         ` Bartosz Golaszewski
2025-11-03 13:46       ` Andy Shevchenko [this message]
2025-11-03  9:35 ` [PATCH v4 04/10] gpio: swnode: don't use the swnode's name as the key for GPIO lookup Bartosz Golaszewski
2025-11-03  9:51   ` Andy Shevchenko
2025-11-03 10:53     ` Bartosz Golaszewski
2025-11-18 16:33   ` Charles Keepax
2025-11-18 18:01     ` Bartosz Golaszewski
2025-11-18 18:15       ` Charles Keepax
2025-11-18 18:23         ` Andy Shevchenko
2025-11-19  8:35         ` Bartosz Golaszewski
2025-11-19  8:41           ` Bartosz Golaszewski
2025-11-19  9:13             ` Bartosz Golaszewski
2026-02-09  6:44               ` Dmitry Torokhov
2026-02-09  6:52                 ` Dmitry Torokhov
2026-02-09 12:38                 ` Bartosz Golaszewski
2026-02-09 13:25                   ` Yauhen Kharuzhy
2025-11-03  9:35 ` [PATCH v4 05/10] gpio: swnode: allow referencing GPIO chips by firmware nodes Bartosz Golaszewski
2025-11-03  9:54   ` Andy Shevchenko
2025-11-03  9:35 ` [PATCH v4 06/10] gpio: swnode: update the property definitions Bartosz Golaszewski
2025-11-03  9:57   ` Andy Shevchenko
2025-11-03  9:35 ` [PATCH v4 07/10] reset: order includes alphabetically in reset/core.c Bartosz Golaszewski
2025-11-03  9:35 ` [PATCH v4 08/10] reset: make the provider of reset-gpios the parent of the reset device Bartosz Golaszewski
2025-11-03  9:35 ` [PATCH v4 09/10] reset: gpio: convert the driver to using the auxiliary bus Bartosz Golaszewski
2025-11-03  9:35 ` [PATCH v4 10/10] reset: gpio: use software nodes to setup the GPIO lookup Bartosz Golaszewski
2025-11-03 14:14 ` (subset) [PATCH v4 00/10] reset: rework reset-gpios handling Bartosz Golaszewski

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=aQiyMdvUhPQxkpmw@smile.fi.intel.com \
    --to=andriy.shevchenko@linux.intel.com \
    --cc=bartosz.golaszewski@linaro.org \
    --cc=brgl@bgdev.pl \
    --cc=dakr@kernel.org \
    --cc=djrscally@gmail.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=heikki.krogerus@linux.intel.com \
    --cc=krzk@kernel.org \
    --cc=linus.walleij@linaro.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-gpio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=p.zabel@pengutronix.de \
    --cc=rafael@kernel.org \
    --cc=sakari.ailus@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome