From: Andy Shevchenko <andriy.shevchenko@intel.com>
To: Kurt Borja <kuurtb@gmail.com>
Cc: "David Lechner" <dlechner@baylibre.com>,
"Jonathan Cameron" <jic23@kernel.org>,
"Rob Herring" <robh@kernel.org>,
"Krzysztof Kozlowski" <krzk+dt@kernel.org>,
"Conor Dooley" <conor+dt@kernel.org>,
"Tobias Sperling" <tobias.sperling@softing.com>,
"Nuno Sá" <nuno.sa@analog.com>,
"Andy Shevchenko" <andy@kernel.org>,
linux-iio@vger.kernel.org, devicetree@vger.kernel.org,
linux-kernel@vger.kernel.org,
"Jonathan Cameron" <Jonathan.Cameron@huawei.com>
Subject: Re: [PATCH v3 2/2] iio: adc: Add ti-ads1018 driver
Date: Tue, 2 Dec 2025 16:59:22 +0200 [thread overview]
Message-ID: <aS7-yml5a2yjM28D@smile.fi.intel.com> (raw)
In-Reply-To: <DENT40NRKH0V.3UD0JBGRUSCDS@gmail.com>
On Tue, Dec 02, 2025 at 09:39:34AM -0500, Kurt Borja wrote:
> On Mon Dec 1, 2025 at 6:09 PM -05, David Lechner wrote:
...
> I agree, this naming is a bit confusing.
>
> Andy, are you okay if I revert this back to __ads1018_read_raw()? I can
> add a comment on context.
Only if it doesn't start with __ (double underscore), just find the best suffix
(or prefix?) for it.
TL;DR: I'm against functions without clear semantics to start with __. Usually
this means unlocked in terms of spinlock/mutex/etc. Is it the case here? IIRC
it is not.
--
With Best Regards,
Andy Shevchenko
next prev parent reply other threads:[~2025-12-02 14:59 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-11-29 3:47 [PATCH v3 0/2] iio: Add support for TI ADS1X18 ADCs Kurt Borja
2025-11-29 3:47 ` [PATCH v3 1/2] dt-bindings: iio: adc: Add TI ADS1018/ADS1118 Kurt Borja
2025-11-29 9:25 ` Krzysztof Kozlowski
2025-11-30 3:32 ` Kurt Borja
2025-11-29 3:47 ` [PATCH v3 2/2] iio: adc: Add ti-ads1018 driver Kurt Borja
2025-11-29 14:21 ` Andy Shevchenko
2025-11-29 14:23 ` Andy Shevchenko
2025-11-30 3:31 ` Kurt Borja
2025-11-30 16:45 ` Andy Shevchenko
2025-12-01 16:07 ` David Lechner
2025-12-01 19:47 ` Kurt Borja
2025-12-01 21:53 ` David Lechner
2025-12-02 14:46 ` Kurt Borja
2025-12-06 19:27 ` Jonathan Cameron
2025-12-07 16:01 ` Kurt Borja
2025-11-29 17:08 ` kernel test robot
2025-12-01 23:09 ` David Lechner
2025-12-02 14:39 ` Kurt Borja
2025-12-02 14:59 ` Andy Shevchenko [this message]
2025-12-02 17:49 ` Kurt Borja
2025-12-02 18:04 ` Andy Shevchenko
2025-12-02 16:52 ` Kurt Borja
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aS7-yml5a2yjM28D@smile.fi.intel.com \
--to=andriy.shevchenko@intel.com \
--cc=Jonathan.Cameron@huawei.com \
--cc=andy@kernel.org \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=dlechner@baylibre.com \
--cc=jic23@kernel.org \
--cc=krzk+dt@kernel.org \
--cc=kuurtb@gmail.com \
--cc=linux-iio@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=nuno.sa@analog.com \
--cc=robh@kernel.org \
--cc=tobias.sperling@softing.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®