> The behavior in the regular case is unchanged, spinning for up to 1ms, > but the open-coded poll loop is replaced with read_poll_timeout_atomic() > as suggested by Andrew Lunn. Hmm, spinning 1ms is still a lot. Can't we just use read_poll_timeout() for the whole timeout? I can't see that it will cause a regression. But please correct me if I am wrong. The series looks good for me apart from the above.