The following changes since commit f8f9c1f4d0c7a64600e2ca312dec824a0bc2f1da: Linux 6.19-rc3 (2025-12-28 13:24:26 -0800) are available in the Git repository at: git://git.kernel.org/pub/scm/linux/kernel/git/wsa/linux.git tags/i2c-for-7.0-rc1 for you to fetch changes up to efdc383d1cc28d45cbf5a23b5ffa997010aaacb4: i2c: imx-lpi2c: fix SMBus block read NACK after byte count (2026-02-08 18:17:09 +0100) ---------------------------------------------------------------- i2c-for-7.0-rc1 - core: cleaner fwnode usage - tegra: timing improvements and Tegra264 support - lpi2c: fix SMBus block read NACK after byte count - amd-mp2, designware, mlxbf, rtl9300, spacemit, tegra: cleanups - designware: use a dedicated algorithm for AMD Navi - designware: replace magic numbers with named constants - designware: replace min_t() with min() to avoid u8 truncation - designware: refactor core to enable mode switching - imx-lpi2c: add runtime PM support for IRQ and clock handling - lan9691-i2c: add new driver - rtl9300: use OF helpers directly and avoid fwnode handling - spacemit: add bus reset support - units: add HZ_PER_GHZ and use it in several i2c drivers at24 updates for v7.0-rc1 - add a set of new compatibles to DT bindings - use dev_err_probe() consistently in the driver ---------------------------------------------------------------- Akhil R (4): i2c: tegra: Use separate variables for fast and fastplus i2c: tegra: Update Tegra256 timing parameters i2c: tegra: Add HS mode support i2c: tegra: Add Tegra264 support Andy Shevchenko (14): units: Add HZ_PER_GHZ i2c: mlxbf: Use HZ_PER_GHZ constant instead of custom one i2c: mt65xx: Use HZ_PER_GHZ constant instead of plain number i2c: nomadik: Use HZ_PER_GHZ constant instead of plain number i2c: rk3x: Use HZ_PER_GHZ constant instead of plain number i2c: st: Use HZ_PER_GHZ constant instead of plain number i2c: synquacer: Use HZ_PER_GHZ constant instead of plain number i2c: core: Check for error pointer for fwnode i2c: core: Replace custom implementation of device_match_fwnode() i2c: core: Use dev_fwnode() i2c: mlxbf: Remove unused bus speed definitions i2c: mlxbf: Use HZ_PER_KHZ in the driver i2c: designware: Remove not-going-to-be-supported code for Baikal SoC i2c: designware: Use device_is_compatible() instead of custom approach Artem Shimko (1): i2c: designware: Replace magic numbers with named constants Bartosz Golaszewski (1): eeprom: at24: use dev_err_probe() consistently BenoƮt Monin (3): i2c: designware: Optimize flag reading in i2c_dw_read() i2c: designware: Sort compatible strings in alphabetical order i2c: designware: Add dedicated algorithm for AMD NAVI Carlos Song (2): i2c: imx-lpi2c: Add runtime PM support for IRQ and clock management on i.MX8QXP/8QM i2c: imx-lpi2c: fix SMBus block read NACK after byte count David Laight (1): drivers/i2c/busses: use min() instead of min_t() Encrow Thorne (2): dt-bindings: i2c: spacemit: add optional resets i2c: k1: add reset support FUKAUMI Naoki (1): dt-bindings: eeprom: at24: Add compatible for Belling BL24C04A/BL24C16F Guixin Liu (1): i2c: tegra: remove unused rst Heikki Krogerus (6): i2c: designware: Remove useless driver specific option for I2C target i2c: designware: Remove unnecessary function exports i2c: designware: Combine some of the common functions i2c: designware: Combine the init functions i2c: designware: Enable mode swapping i2c: designware: Remove an unnecessary condition Johan Hovold (1): i2c: amd-mp2: clean up amd_mp2_find_device() Kartik Rajput (2): i2c: tegra: Do not configure DMA if not supported i2c: tegra: Add support for SW mutex register Louis-Alexis Eyraud (1): dt-bindings: i2c: i2c-mt65xx: Add compatible for MT8189 SoC Luca Weiss (2): dt-bindings: eeprom: at24: Add compatible for Giantec GT24P64A dt-bindings: eeprom: at24: Add compatible for Puya P24C128F Robert Marko (1): dt-bindings: i2c: atmel,at91sam: add microchip,lan9691-i2c Rosen Penev (2): i2c: rtl9300: remove const cast i2c: rtl9300: use of instead of fwnode Troy Mitchell (1): i2c: spacemit: drop useless spaces Wolfram Sang (2): Merge tag 'at24-updates-for-v7.0-rc1' of git://git.kernel.org/pub/scm/linux/kernel/git/brgl/linux into i2c/for-mergewindow Merge tag 'i2c-host-6.20' of git://git.kernel.org/pub/scm/linux/kernel/git/andi.shyti/linux into i2c/for-mergewindow with much appreciated quality assurance from ---------------------------------------------------------------- Alex Elder (1): (Rev.) i2c: spacemit: drop useless spaces Andi Shyti (1): (Rev.) units: Add HZ_PER_GHZ Andy Shevchenko (7): (Rev.) i2c: designware: Remove an unnecessary condition (Rev.) i2c: designware: Combine the init functions (Rev.) i2c: designware: Remove unnecessary function exports (Rev.) i2c: designware: Remove useless driver specific option for I2C target (Rev.) i2c: designware: Add dedicated algorithm for AMD NAVI (Rev.) i2c: designware: Sort compatible strings in alphabetical order (Rev.) i2c: designware: Optimize flag reading in i2c_dw_read() AngeloGioacchino Del Regno (8): (Rev.) dt-bindings: i2c: i2c-mt65xx: Add compatible for MT8189 SoC (Rev.) i2c: synquacer: Use HZ_PER_GHZ constant instead of plain number (Rev.) i2c: st: Use HZ_PER_GHZ constant instead of plain number (Rev.) i2c: rk3x: Use HZ_PER_GHZ constant instead of plain number (Rev.) i2c: nomadik: Use HZ_PER_GHZ constant instead of plain number (Rev.) i2c: mt65xx: Use HZ_PER_GHZ constant instead of plain number (Rev.) i2c: mlxbf: Use HZ_PER_GHZ constant instead of custom one (Rev.) units: Add HZ_PER_GHZ Chris Packham (2): (Rev.) i2c: rtl9300: use of instead of fwnode (Rev.) i2c: rtl9300: remove const cast Frank Li (2): (Rev.) i2c: imx-lpi2c: fix SMBus block read NACK after byte count (Rev.) i2c: imx-lpi2c: Add runtime PM support for IRQ and clock management on i.MX8QXP/8QM Heiko Stuebner (1): (Rev.) i2c: rk3x: Use HZ_PER_GHZ constant instead of plain number Jon Hunter (6): (Rev.) i2c: tegra: Add Tegra264 support (Rev.) i2c: tegra: Add support for SW mutex register (Rev.) i2c: tegra: Add HS mode support (Rev.) i2c: tegra: Update Tegra256 timing parameters (Rev.) i2c: tegra: Use separate variables for fast and fastplus (Rev.) i2c: tegra: Do not configure DMA if not supported Konrad Dybcio (1): (Rev.) dt-bindings: eeprom: at24: Add compatible for Puya P24C128F Linus Walleij (2): (Rev.) i2c: nomadik: Use HZ_PER_GHZ constant instead of plain number (Rev.) units: Add HZ_PER_GHZ Patrice Chotard (1): (Rev.) i2c: st: Use HZ_PER_GHZ constant instead of plain number Shyam Sundar S K (1): (Rev.) i2c: amd-mp2: clean up amd_mp2_find_device() Troy Mitchell (2): (Rev.) i2c: k1: add reset support (Rev.) dt-bindings: i2c: spacemit: add optional resets Wolfram Sang (7): (Rev.) i2c: synquacer: Use HZ_PER_GHZ constant instead of plain number (Rev.) i2c: st: Use HZ_PER_GHZ constant instead of plain number (Rev.) i2c: rk3x: Use HZ_PER_GHZ constant instead of plain number (Rev.) i2c: nomadik: Use HZ_PER_GHZ constant instead of plain number (Rev.) i2c: mt65xx: Use HZ_PER_GHZ constant instead of plain number (Rev.) i2c: mlxbf: Use HZ_PER_GHZ constant instead of custom one (Rev.) units: Add HZ_PER_GHZ Documentation/devicetree/bindings/eeprom/at24.yaml | 4 + .../devicetree/bindings/i2c/atmel,at91sam-i2c.yaml | 1 + .../devicetree/bindings/i2c/i2c-mt65xx.yaml | 1 + .../devicetree/bindings/i2c/spacemit,k1-i2c.yaml | 3 + drivers/i2c/busses/Kconfig | 11 +- drivers/i2c/busses/Makefile | 2 +- drivers/i2c/busses/i2c-amd-mp2-pci.c | 8 +- drivers/i2c/busses/i2c-designware-amdisp.c | 4 +- drivers/i2c/busses/i2c-designware-common.c | 246 +++++++++++++++-- drivers/i2c/busses/i2c-designware-core.h | 40 ++- drivers/i2c/busses/i2c-designware-master.c | 187 ++----------- drivers/i2c/busses/i2c-designware-platdrv.c | 72 +---- drivers/i2c/busses/i2c-designware-slave.c | 127 ++------- drivers/i2c/busses/i2c-imx-lpi2c.c | 191 ++++++++++--- drivers/i2c/busses/i2c-k1.c | 19 +- drivers/i2c/busses/i2c-mlxbf.c | 13 +- drivers/i2c/busses/i2c-mt65xx.c | 11 +- drivers/i2c/busses/i2c-nomadik.c | 7 +- drivers/i2c/busses/i2c-rk3x.c | 12 +- drivers/i2c/busses/i2c-rtl9300.c | 17 +- drivers/i2c/busses/i2c-st.c | 3 +- drivers/i2c/busses/i2c-synquacer.c | 3 +- drivers/i2c/busses/i2c-tegra.c | 306 +++++++++++++++++---- drivers/i2c/i2c-core-base.c | 10 +- drivers/misc/eeprom/at24.c | 20 +- include/linux/units.h | 3 + 26 files changed, 781 insertions(+), 540 deletions(-)