mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Cyrill Gorcunov" <gorcunov@gmail.com>
To: "David Woodhouse" <dwmw2@infradead.org>
Cc: "Linux Kernel Mailing List" <linux-kernel@vger.kernel.org>,
	"Ingo Molnar" <mingo@elte.hu>, "H. Peter Anvin" <hpa@zytor.com>
Subject: Re: x86: cleanup - rename VM_MASK to X86_VM_MASK
Date: Wed, 23 Apr 2008 08:59:22 +0400	[thread overview]
Message-ID: <aa79d98a0804222159l5ae49a64n101c4b299a3242ac@mail.gmail.com> (raw)
In-Reply-To: <aa79d98a0804222118me7de773kae498479531a9585@mail.gmail.com>

On Wed, Apr 23, 2008 at 8:18 AM, Cyrill Gorcunov <gorcunov@gmail.com> wrote:
>
> On Wed, Apr 23, 2008 at 6:17 AM, David Woodhouse <dwmw2@infradead.org> wrote:
>  > On Fri, 2008-04-18 at 18:56 +0000, Linux Kernel Mailing List wrote:
>  >  > Gitweb:     http://git.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=6b6891f9c545ccd45d6d8ddfd33ce27c22c271a7
>  >  > Commit:     6b6891f9c545ccd45d6d8ddfd33ce27c22c271a7
>  >  > Parent:     6093015db2bd9e70cf20cdd23be1a50733baafdd
>  >  > Author:     gorcunov@gmail.com <gorcunov@gmail.com>
>  >  > AuthorDate: Fri Mar 28 17:56:57 2008 +0300
>  >  > Committer:  Ingo Molnar <mingo@elte.hu>
>  >  > CommitDate: Thu Apr 17 17:41:33 2008 +0200
>  >  >
>  >  >     x86: cleanup - rename VM_MASK to X86_VM_MASK
>  >  >
>  >  >     This patch renames VM_MASK to X86_VM_MASK (which
>  >  >     in turn defined as alias to X86_EFLAGS_VM) to better
>  >  >     distinguish from virtual memory flags. We can't just
>  >  >     use X86_EFLAGS_VM instead because it is also used
>  >  >     for conditional compilation
>  >  >
>  >  >     Signed-off-by: Cyrill Gorcunov <gorcunov@gmail.com>
>  >  >     Signed-off-by: Ingo Molnar <mingo@elte.hu>
>  >
>  >
>  >  > --- a/include/asm-x86/vm86.h
>  >  > +++ b/include/asm-x86/vm86.h
>  >  > @@ -17,9 +17,9 @@
>  >  >  #define IOPL_MASK    0x00003000
>  >  >  #define NT_MASK              0x00004000
>  >  >  #ifdef CONFIG_VM86
>  >  > -#define VM_MASK              0x00020000
>  >  > +#define X86_VM_MASK  X86_EFLAGS_VM
>  >  >  #else
>  >  > -#define VM_MASK              0 /* ignored */
>  >  > +#define X86_VM_MASK  0 /* No VM86 support */
>  >  >  #endif
>  >  >  #define AC_MASK              0x00040000
>  >  >  #define VIF_MASK     0x00080000      /* virtual interrupt flag */
>  >
>  >  This is user-visible. Yet we're changing the name and also making it
>  >  depend on #ifdef CONFIG_VM86, which is not going to be set in userspace.
>  >  Perhaps it should be within #ifdef __KERNEL__?
>  >
>  >  --
>  >  dwmw2
>  >
>  >
>
>  Thanks David, will check it today evening (i'm in office now)
>

Hi David,

actually, this CONFIG_VM86 was there even before the renaming was done.
The main questions (imo) - is there any user space application who uses
these flags? If they are - then even the idea of this patch was a bit bogus,
and I should *not* remove all these VM86 specific flags but better define them
as aliases on flags from processor-flags.h.

Ingo? Peter?

  reply	other threads:[~2008-04-23  4:59 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <200804181856.m3IIuKd4007403@hera.kernel.org>
2008-04-23  2:17 ` David Woodhouse
2008-04-23  4:18   ` Cyrill Gorcunov
2008-04-23  4:59     ` Cyrill Gorcunov [this message]
2008-04-23 18:12       ` H. Peter Anvin
2008-04-23 18:26         ` Cyrill Gorcunov
2008-04-23 18:58         ` Cyrill Gorcunov
2008-04-23 22:38           ` H. Peter Anvin
2008-04-23 22:48             ` David Woodhouse
2008-04-24  3:25               ` Cyrill Gorcunov
2008-04-24  5:31                 ` David Woodhouse
2008-04-24  5:34                   ` H. Peter Anvin
2008-04-24  8:38                     ` Cyrill Gorcunov
2008-04-27 10:09         ` Pavel Machek
2008-04-27 11:31           ` Rafael J. Wysocki
2008-04-27 11:55             ` Matthew Garrett
2008-04-27 15:46               ` Cyrill Gorcunov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=aa79d98a0804222159l5ae49a64n101c4b299a3242ac@mail.gmail.com \
    --to=gorcunov@gmail.com \
    --cc=dwmw2@infradead.org \
    --cc=hpa@zytor.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®