From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from smtp.kernel.org (aws-us-west-2-korg-mail-1.web.codeaurora.org [10.30.226.201]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 3705E4A32 for ; Sun, 15 Mar 2026 05:02:21 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=10.30.226.201 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1773550942; cv=none; b=k8Tm6HHyaGmb3+aWkw0woiVB+eSXpLMZvvDiVn3/FgwFUVasOjf6OIuEvqegwHI7y9BTkcUILiETIxdP/ktNxkSEhmSQbgZi1YOKhXeBWtrWE2W0YwWupfultPCPhFXMedTl/CY1Kzs0QQ41PLLZGfV92XX3f2+qApwxCrPyYTc= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1773550942; c=relaxed/simple; bh=y/qPg1BOLvx4bG6IThJrAhMyZd/utCNU//A3HXcgTNg=; h=Date:From:To:Cc:Subject:Message-ID:References:MIME-Version: Content-Type:Content-Disposition:In-Reply-To; b=WCR5V45N2xxo1Uo2iyKdmdCu2Ijfb009QkAknCnGaDVniqfnycYnKm2V4CiJzx1DgJiOOV/Q/LFs4cWKakG0dzKHrJ1HmLXiPyfwd5QYiSXWWUE6qI8oiJUaqhKuLhXmQFKj3Up6ljpi6mZtJSBpQbdv3MaVP9YvuiUuv4iLZd8= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b=u7ZgeCv9; arc=none smtp.client-ip=10.30.226.201 Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b="u7ZgeCv9" Received: by smtp.kernel.org (Postfix) with ESMTPSA id 427FDC4CEF7; Sun, 15 Mar 2026 05:02:18 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=kernel.org; s=k20201202; t=1773550941; bh=y/qPg1BOLvx4bG6IThJrAhMyZd/utCNU//A3HXcgTNg=; h=Date:From:To:Cc:Subject:References:In-Reply-To:From; b=u7ZgeCv9fBLbkIaWg5hUsa9LZLq5L/z1fCEpaPAZJ31/l9L1EpVWk40Brbyxt+E9W gm9Ipp3yLCKFsp2J8f0A1XWN4UyQ7q9V5rhTr8eXtCyatOQd3bVjieTLpcEDaZCU06 JZbqDPbLL10cqYKB+gIZNk09jCK5A29Hj2r7gDo71q16hZkMk9+60JADwYc2OuK3RU 5j5yizvjsVRcE8Fv+wKKlU51D5O2RnHZS69kWLaL1SBSaSb+QP2HeqIhM3k+pMNnWq Nuhj35OewMqm00DrASH6FJ1RCImdvC1JrjDO7d+0J+LasAjUz2mB0F5+K3i+BHtoN7 qDp/QszNKmyfw== Date: Sun, 15 Mar 2026 10:32:16 +0530 From: Sumit Garg To: Jens Wiklander Cc: Markus Elfring , Chen Ni , op-tee@lists.trustedfirmware.org, LKML , Ulf Hansson Subject: Re: [PATCH] optee: Check return value of tee_shm_get_va() Message-ID: References: <20260305083312.1040969-1-nichen@iscas.ac.cn> <2e15b2b8-7dd4-4e63-b9a9-a664323ebb36@web.de> Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline Content-Transfer-Encoding: 8bit In-Reply-To: On Thu, Mar 12, 2026 at 12:16:11PM +0100, Jens Wiklander wrote: > On Thu, Mar 12, 2026 at 10:16 AM Sumit Garg wrote: > > > > On Fri, Mar 06, 2026 at 12:52:39PM +0100, Markus Elfring wrote: > > > … > > > > +++ b/drivers/tee/optee/rpc.c > > > > @@ -393,6 +393,11 @@ static void handle_rpc_func_rpmb_frames(struct tee_context *ctx, > > > > params[0].u.memref.shm_offs); > > > > p1 = tee_shm_get_va(params[1].u.memref.shm, > > > > params[1].u.memref.shm_offs); > > > > + if (IS_ERR(p0) || IS_ERR(p1)) { > > > > + arg->ret = TEEC_ERROR_BAD_PARAMETERS; > > > > + goto out; > > > > + } > > > > + > > > > if (rpmb_route_frames(rdev, p0, params[0].u.memref.size, p1, > > > > params[1].u.memref.size)) { > > > > arg->ret = TEEC_ERROR_BAD_PARAMETERS; > > > … > > > > > > How do you think about to use an additional label for the shown > > > error code assignment? > > > https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/process/coding-style.rst?h=v7.0-rc2#n526 > > > > > > > I suppose here you meant to update the label name since it's the same > > error type used by other code paths too. So following label rename > > should be fine I think as per coding guidelines: > > > > s/out/err_dev_put/ > > Wouldn't the name err_dev_put suggest this only occurs in the error path? > Okay, let rather rename it to out_dev_put. -Sumit