From: Frank Li <Frank.li@nxp.com>
To: Josua Mayer <josua@solid-run.com>
Cc: Rob Herring <robh@kernel.org>,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
Conor Dooley <conor+dt@kernel.org>,
Shawn Guo <shawnguo@kernel.org>,
Carlos Song <carlos.song@nxp.com>,
Mikhail Anikin <mikhail.anikin@solid-run.com>,
Yazan Shhady <yazan.shhady@solid-run.com>,
Rabeeh Khoury <rabeeh@solid-run.com>,
"linux-arm-kernel@lists.infradead.org"
<linux-arm-kernel@lists.infradead.org>,
"devicetree@vger.kernel.org" <devicetree@vger.kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v5 04/10] arm64: dts: lx2160a: rename pinmux nodes for readability
Date: Wed, 18 Mar 2026 09:48:40 -0400 [thread overview]
Message-ID: <abqtOFohYjf0q6P1@lizhi-Precision-Tower-5810> (raw)
In-Reply-To: <52a09ab1-ab55-43f9-91fc-c35f6a0d4730@solid-run.com>
On Tue, Mar 17, 2026 at 05:20:20PM +0000, Josua Mayer wrote:
> Hi Frank,
>
> On 3/17/26 02:36, Frank Li wrote:
> > On Sat, Mar 14, 2026 at 01:05:14PM +0100, Josua Mayer wrote:
> >> LX2160A pinmux is done in groups by various length bitfields within
> >> configuration registers.
> >>
> >> Each group of pins is named in the reference manual after a primary
> >> function using soc-specific naming, e.g. IIC1 (for i2c0).
> >>
> >> Hardware block numbering starts from zero in device-tree but one in the
> >> reference manual.
> >>
> >> Rename the already defined pinmux nodes originally added for changing
> >> i2c pins between i2c and gpio functions reflecting the reference manual
> >> name (IIC) in the node name, and the device-tree name (i2c, gpio) in the
> >> label.
> >>
> >> This makes it more clear to future developers that these nodes do in
Needn't 'this' just
Make it more ...
> >> fact configure a group of pins, and helps with cross-referencing
> >> documentation.
> >>
> >> No functional change intended.
> >>
> >> Fixes: 8a1365c7bbc1 ("arm64: dts: lx2160a: add pinmux and i2c gpio to support bus recovery")
> >> Signed-off-by: Josua Mayer <josua@solid-run.com>
> >> ---
> >> arch/arm64/boot/dts/freescale/fsl-lx2160a.dtsi | 64 +++++++++++++-------------
> >> 1 file changed, 32 insertions(+), 32 deletions(-)
> >>
> >> diff --git a/arch/arm64/boot/dts/freescale/fsl-lx2160a.dtsi b/arch/arm64/boot/dts/freescale/fsl-lx2160a.dtsi
> >> index 41c9b4253f4a5..28500e8873909 100644
> >> --- a/arch/arm64/boot/dts/freescale/fsl-lx2160a.dtsi
> >> +++ b/arch/arm64/boot/dts/freescale/fsl-lx2160a.dtsi
> >> @@ -750,8 +750,8 @@ i2c0: i2c@2000000 {
> >> clocks = <&clockgen QORIQ_CLK_PLATFORM_PLL
> >> QORIQ_CLK_PLL_DIV(16)>;
> >> pinctrl-names = "default", "gpio";
> >> - pinctrl-0 = <&i2c0_scl>;
> >> - pinctrl-1 = <&i2c0_scl_gpio>;
> >> + pinctrl-0 = <&i2c0_pins>;
> >> + pinctrl-1 = <&gpio0_3_2_pins>;
> > why need change label name here. It should scl, why need change to pins?
>
> Readability.
>
> It should definitely not be called "scl" precisely because the node
> previously labeled i2c0_scl actually configures both sda and scl together.
This need mention in commit message about why rename.
Frank
>
> And plain "&i2c0" is already taken, so I added _pins.
>
> For the gpios I also changed the label because we are in SoC dtsi,
> and gpios are not specific to sda or scl function.
>
> Further including the gpio numbers in the label helps spotting mistakes.
>
> This patch-set is a story explaining chapter by chapter why initially
> I just reverted the original commit.
>
> sincerely
> Josua Mayer
next prev parent reply other threads:[~2026-03-18 13:48 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-03-14 12:05 [PATCH v5 00/10] arm64: dts: lx2160a: fix pinmux issues, update SolidRun boards Josua Mayer
2026-03-14 12:05 ` [PATCH v5 01/10] arm64: dts: lx2160a-cex7/lx2162a-sr-som: fix usd-cd & gpio pinmux Josua Mayer
2026-03-14 12:11 ` Josua Mayer
2026-03-14 12:05 ` [PATCH v5 02/10] arm64: dts: lx2160a: change i2c0 (iic1) pinmux mask to one bit Josua Mayer
2026-03-14 12:05 ` [PATCH v5 03/10] arm64: dts: lx2160a: remove duplicate pinmux nodes Josua Mayer
2026-03-14 12:05 ` [PATCH v5 04/10] arm64: dts: lx2160a: rename pinmux nodes for readability Josua Mayer
2026-03-17 0:36 ` Frank Li
2026-03-17 17:20 ` Josua Mayer
2026-03-18 13:48 ` Frank Li [this message]
2026-03-24 12:40 ` Josua Mayer
2026-03-14 12:05 ` [PATCH v5 05/10] arm64: dts: lx2160a: add sda gpio references for i2c bus recovery Josua Mayer
2026-03-14 12:05 ` [PATCH v5 06/10] arm64: dts: lx2160a: change zeros to hexadecimal in pinmux nodes Josua Mayer
2026-03-14 12:05 ` [PATCH v5 07/10] arm64: dts: lx2160a: complete pinmux for rcwsr12 configuration word Josua Mayer
2026-03-14 12:05 ` [PATCH v5 08/10] arm64: dts: lx2160a-cex7: add rtc alias Josua Mayer
2026-03-14 12:05 ` [PATCH v5 09/10] arm64: dts: lx2162a-sr-som: add crypto & rtc aliases, model Josua Mayer
2026-03-14 12:05 ` [PATCH v5 10/10] arm64: dts: lx2162a-clearfog: set sfp connector leds function and source Josua Mayer
2026-03-15 12:29 ` Josua Mayer
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=abqtOFohYjf0q6P1@lizhi-Precision-Tower-5810 \
--to=frank.li@nxp.com \
--cc=carlos.song@nxp.com \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=josua@solid-run.com \
--cc=krzk+dt@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mikhail.anikin@solid-run.com \
--cc=rabeeh@solid-run.com \
--cc=robh@kernel.org \
--cc=shawnguo@kernel.org \
--cc=yazan.shhady@solid-run.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®