From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from casper.infradead.org (casper.infradead.org [90.155.50.34]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 3861A3B47D0 for ; Mon, 23 Mar 2026 18:57:45 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=90.155.50.34 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1774292272; cv=none; b=TZwp5LPXUyO9GV/z+4PLKKCNBrVHqNuyJJpB5HunjSHmO46Tb13IQTAC5GUmhXsM6okZi091xJ3nluRVowJLkZvWsduS/1ipmcc/JevAl8j1KAYhnk+1n2TMVQ9ufUc3DDfnKOsuSZtlPEnv0JjR/VOhXGiAE522evwMAWCAkpQ= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1774292272; c=relaxed/simple; bh=a0n0hnQqhd5QB7uWGjPODMOwWYW3el913nemwsYYErc=; h=Date:From:To:Cc:Subject:Message-ID:References:MIME-Version: Content-Type:Content-Disposition:In-Reply-To; b=h/FabWqhdq2BzNe58ZSDuz6NH3gTWUnbRg8Ubvx2jdyNeO2s7+WzuvXkPZOxmuGbB/1hV5p3eDZI/oY0Gf8dgcyVLVvduwgirkAmZtNFNzmBAv/X/7vu+A5jmbpCiLCncqIKsBIjZQ2DJYYlkzFf9jPsM5yOMRNcg44IImaaceA= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=infradead.org; spf=none smtp.mailfrom=infradead.org; dkim=pass (2048-bit key) header.d=infradead.org header.i=@infradead.org header.b=VoyXQGIO; arc=none smtp.client-ip=90.155.50.34 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=infradead.org Authentication-Results: smtp.subspace.kernel.org; spf=none smtp.mailfrom=infradead.org Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=infradead.org header.i=@infradead.org header.b="VoyXQGIO" DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=infradead.org; s=casper.20170209; h=In-Reply-To:Content-Type:MIME-Version: References:Message-ID:Subject:Cc:To:From:Date:Sender:Reply-To: Content-Transfer-Encoding:Content-ID:Content-Description; bh=AGqvBokwlQB1Y/uYMahiXGhIsZdEjFgL1tMnTCpwV94=; b=VoyXQGIOWMvBUFFKdo38tpq+Gg 0tIRYVjohRz4OtcDSA0fj4OcatKcnyJnYECt/iWZrreMTMFoMT9rhGayxw8vhFOG2OcjUAjY18RMw 7cjX9sl1l2jO66NTKy33+d7TTN1zTfnYx42ANJ/ZNiP/VN4b4HDXav0tnKgfGDtgalwx1aiqYW2DI UMOMNS9ntQmpq/v+f3gl/s4XiAmdD4AwStIen1bGyUhMn3BbrAc5APWdD4NFrp+onfI4zMGPd+bxW 7EJx1X6zGSQlOhxgAppRRFkeimC2yTC9fVw0HEotoOnxBe22fa3Jb9JQb11ZXa9+zEk1vjoS9vHKy 4Bpuv4Iw==; Received: from willy by casper.infradead.org with local (Exim 4.98.2 #2 (Red Hat Linux)) id 1w4kSx-0000000CiAc-3HtH; Mon, 23 Mar 2026 18:57:31 +0000 Date: Mon, 23 Mar 2026 18:57:31 +0000 From: Matthew Wilcox To: "David Hildenbrand (Arm)" Cc: Shivank Garg , Andrew Morton , Zi Yan , Matthew Brost , Joshua Hahn , Rakie Kim , Byungchul Park , Gregory Price , Ying Huang , Alistair Popple , linux-mm@kvack.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH] mm/migrate: rename PAGE_ migration flags to FOLIO_MF_ Message-ID: References: <20260323141935.389232-3-shivankg@amd.com> Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: On Mon, Mar 23, 2026 at 04:36:38PM +0100, David Hildenbrand (Arm) wrote: > On 3/23/26 15:46, Matthew Wilcox wrote: > >> if (folio_test_mlocked(src)) > >> - old_page_state |= PAGE_WAS_MLOCKED; > >> + old_folio_state |= FOLIO_MF_WAS_MLOCKED; > > > > I mean, this doesn't make sense any more. PAGE_WAS_MLOCKED is a > > sentence that means something. FOLIO_MF_WAS_MLOCKED doesn't ... unless > > you imagine Samuel L Jackson saying it ... > > :) > > PAGE_WAS_MLOCKED was suboptimal given that the names overlap with things > like PAGE_SHARED or even PAGE_IS_PRESENT. PAGE_SHARED (and friends) are misnamed because really they're PTE flags, not page flags. Then PAGE_IS_* form a namespace for pagemap, which I think is fine. These are PAGE_WAS, so a distinct namespace already. > So using some prefix to indicate that these flag belong logically > together makes sense. Even if it's not a beautiful sentence. FOLIO_WAS_ seems like a fine namespace. Especially since it's local to this file.