From: Petr Mladek <pmladek@suse.com>
To: David Laight <david.laight.linux@gmail.com>,
Rasmus Villemoes <linux@rasmusvillemoes.dk>
Cc: Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
"Masami Hiramatsu (Google)" <mhiramat@kernel.org>,
Steven Rostedt <rostedt@goodmis.org>,
Sergey Senozhatsky <senozhatsky@chromium.org>,
Andrew Morton <akpm@linux-foundation.org>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 1/2] lib/vsprintf: Fix to check field_width and precision
Date: Tue, 24 Mar 2026 17:45:49 +0100 [thread overview]
Message-ID: <acK_vXwxn8pWdWvy@pathway.suse.cz> (raw)
In-Reply-To: <20260323135905.5272127b@pumpkin>
On Mon 2026-03-23 13:59:05, David Laight wrote:
> On Mon, 23 Mar 2026 15:27:31 +0200
> Andy Shevchenko <andriy.shevchenko@linux.intel.com> wrote:
>
> > On Sat, Mar 21, 2026 at 11:41:12PM +0900, Masami Hiramatsu (Google) wrote:
> >
> > > Check the field_width and presition correctly. Previously it depends
> > > on the bitfield conversion from int to check out-of-range error.
> > > However, commit 938df695e98d ("vsprintf: associate the format state
> > > with the format pointer") changed those fields to int.
> > > We need to check the out-of-range correctly without bitfield
> > > conversion.
> >
> > ...
> >
> > > static void
> > > set_field_width(struct printf_spec *spec, int width)
> > > {
> > > - spec->field_width = width;
> > > - if (WARN_ONCE(spec->field_width != width, "field width %d too large", width)) {
> > > - spec->field_width = clamp(width, -FIELD_WIDTH_MAX, FIELD_WIDTH_MAX);
> > > + if (WARN_ONCE(width > FIELD_WIDTH_MAX || width < -FIELD_WIDTH_MAX,
> > > + "field width %d too large", width)) {
> > > + width = clamp(width, -FIELD_WIDTH_MAX, FIELD_WIDTH_MAX);
> > > }
> > > + spec->field_width = width;
> > > }
> > >
> > > static void
> > > set_precision(struct printf_spec *spec, int prec)
> > > {
> > > - spec->precision = prec;
> > > - if (WARN_ONCE(spec->precision != prec, "precision %d too large", prec)) {
> > > - spec->precision = clamp(prec, 0, PRECISION_MAX);
> > > + if (WARN_ONCE(prec > PRECISION_MAX || prec < 0,
> > > + "precision %d too large", prec)) {
> > > + prec = clamp(prec, 0, PRECISION_MAX);
> > > }
> > > + spec->precision = prec;
> > > }
> >
> > Looking at this, perhaps
> >
> > #define clamp_WARN_*(...)
> > ...
It would make sense. But I do not want to force Masami to do so.
> When I looked at this I did wonder whether the compiler would manage to
> only do the comparisons once.
I believe that compilers would optimize this.
> Even if it doesn't the separate WARN is more readable.
>
> Or maybe:
> spec->field_width = clamp(width, -FIELD_WIDTH_MAX, FIELD_WIDTH_MAX);
> WARN_ON(spec->field_width != width, "field width %d too large", width);
But this is fine as well.
> I'd be more worried about the bloat and system panic for all the systems
> with panic_on_warn set (the default for many distos).
> (And, like panic_on_oops, it doesn't give time for the error to get into
> the system logs.)
The WARN_ONCE() has been added by the commit 4d72ba014b4b09 ("lib/vsprintf.c:
warn about too large precisions and field widths"). The motivation was
that it was used also by some %p? modifiers, e.g. for the bitfield size, where
a clamped value might cause more confusion.
I do not want to open a bike shedding whether it is important enough
or not. I agree that it likely is not a reason to panic but it was
there 10 years so I could live with it.
That said, I always thought about introducing a macro which would
print a message+backtrace but it would not panic, e.g. SOFT_WARN()
or INFO() or MSG_AND_BT(level, msg, ...). But it seems to be
out of scope of this patchset.
> I've also just fixed nolibc's handling of %*.*s (which is in 'next' since
> I only wrote it recently), the above is actually broken.
> Negative 'precision' (all values) are fine, they just request the default.
Great catch! We should clamp the precision to (0, PRECISION_MAX). But we
should warn only when it is outside of (-PRECISION_MAX, PRECISION_MAX).
> So the patch needs a big fat NACK...
What is an acceptable solution then, please?
Frankly, I would like to stay on earth. This started as a simple fix
of a regression added a year ago. For me, any solution which
restores the year old behavior is good enough.
We might need to find another volunteer to implement a better
solution, e.g. the new non-panicing MSG_AND_BT() macro.
Alternatively, we could remove the WARN_ONCE() completely.
It looks acceptable for me. But Rasmus would need to agree as well.
Best Regards,
Petr
next prev parent reply other threads:[~2026-03-24 16:45 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-03-21 14:41 [PATCH v3 0/2] lib/vsprintf: Fixes size check Masami Hiramatsu (Google)
2026-03-21 14:41 ` [PATCH v3 1/2] lib/vsprintf: Fix to check field_width and precision Masami Hiramatsu (Google)
2026-03-23 13:27 ` Andy Shevchenko
2026-03-23 13:59 ` David Laight
2026-03-24 16:45 ` Petr Mladek [this message]
2026-03-24 17:24 ` David Laight
2026-03-25 0:33 ` Masami Hiramatsu
2026-03-25 1:17 ` Masami Hiramatsu
2026-03-25 9:14 ` David Laight
2026-03-25 0:26 ` Masami Hiramatsu
2026-03-21 14:41 ` [PATCH v3 2/2] lib/vsprintf: Limit the returning size to INT_MAX Masami Hiramatsu (Google)
2026-03-24 16:50 ` Petr Mladek
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=acK_vXwxn8pWdWvy@pathway.suse.cz \
--to=pmladek@suse.com \
--cc=akpm@linux-foundation.org \
--cc=andriy.shevchenko@linux.intel.com \
--cc=david.laight.linux@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@rasmusvillemoes.dk \
--cc=mhiramat@kernel.org \
--cc=rostedt@goodmis.org \
--cc=senozhatsky@chromium.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome