From: Julia Lawall <julia.lawall@inria.fr>
To: Samuel Abraham <abrahamadekunle50@gmail.com>
Cc: outreachy@lists.linux.dev, gregkh@linuxfoundation.org,
linux-staging@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 5/5] staging: rtl8723bs: modify variable names to comply with kernel naming convention
Date: Fri, 28 Mar 2025 16:13:41 +0100 (CET) [thread overview]
Message-ID: <acd2df4b-6865-d2c0-7bc2-babcc930d03d@inria.fr> (raw)
In-Reply-To: <CADYq+fZd=C-EydjBmkP6Rh6XAJS6Kg1nM7zGhyLrGYiLGkZ8mw@mail.gmail.com>
[-- Attachment #1: Type: text/plain, Size: 1045 bytes --]
On Fri, 28 Mar 2025, Samuel Abraham wrote:
> On Fri, Mar 28, 2025 at 3:55 PM Julia Lawall <julia.lawall@inria.fr> wrote:
> >
> >
> >
> > On Fri, 28 Mar 2025, Abraham Samuel Adekunle wrote:
> >
> > > The variable names use the camelCase naming convention which is not consistent
> > > with Linux kernel naming convention.
> > >
> > > Modify the names to use snake_case in adherence to the Linux kernel approved
> > > naming convention for consistency with the codebase.
> >
> > There is another naming issue that checkpatch perhaps doesn't warn about
> > which is the encoding of types in variable names. You can see some
> > variables with names that start with b for boolean and p for pointer.
> > Those letters shouldn't be used in kernel code.
> >
> > julia
>
> Hello, and thank you very much for your review
> Do I send that as a different standalone patch?
> Or should I send a v2 after attaching the patch to the patchset?
Perhaps find some different files than the ones affected by your patchset
and send a standalone patch.
julia
next prev parent reply other threads:[~2025-03-28 15:13 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-03-28 12:39 [PATCH 0/5] staging: rtl8723bs: code cleanup patches Abraham Samuel Adekunle
2025-03-28 12:39 ` [PATCH 1/5] staging: rtl8723bs: correct coding style by preventing lines from ending with '(' Abraham Samuel Adekunle
2025-03-28 12:39 ` [PATCH 2/5] staging: rtl8723bs: align function return type and name on the same line Abraham Samuel Adekunle
2025-03-28 12:39 ` [PATCH 3/5] staging: rtl8723bs: add spaces around binary and ternary operators Abraham Samuel Adekunle
2025-03-28 12:39 ` [PATCH 4/5] staging: rtl8723bs: correct placement of braces around if-else block Abraham Samuel Adekunle
2025-03-28 12:39 ` [PATCH 5/5] staging: rtl8723bs: modify variable names to comply with kernel naming convention Abraham Samuel Adekunle
2025-03-28 14:55 ` Julia Lawall
2025-03-28 15:08 ` Samuel Abraham
2025-03-28 15:13 ` Julia Lawall [this message]
2025-03-28 15:17 ` Samuel Abraham
2025-04-03 2:35 ` kernel test robot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=acd2df4b-6865-d2c0-7bc2-babcc930d03d@inria.fr \
--to=julia.lawall@inria.fr \
--cc=abrahamadekunle50@gmail.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
--cc=outreachy@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®