mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Joe Perches <joe@perches.com>
To: Nick Desaulniers <ndesaulniers@google.com>, pbonzini@redhat.com
Cc: Matthias Kaehlcke <mka@chromium.org>,
	rkrcmar@redhat.com, Thomas Gleixner <tglx@linutronix.de>,
	hpa@zytor.com, x86@kernel.org, kvm@vger.kernel.org,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] kvm: x86: mmu: Add cast to negated bitmasks in update_permission_bitmask()
Date: Tue, 19 Jun 2018 10:23:13 -0700	[thread overview]
Message-ID: <ad7a9addf043ee7fda8907eff9f83c9709b575dc.camel@perches.com> (raw)
In-Reply-To: <CAKwvOdnhPCDRFMhYiAr2kSCDWrL_gaY8c6XHJ96PupcN-wcDpQ@mail.gmail.com>

On Tue, 2018-06-19 at 10:08 -0700, Nick Desaulniers wrote:
> On Tue, Jun 19, 2018 at 8:19 AM Paolo Bonzini <pbonzini@redhat.com> wrote:
> > 
> > On 15/06/2018 20:45, Nick Desaulniers wrote:
> > > > 
> > > > > In any case I think it it preferable to fix the code over disabling
> > > > > the warning, unless the warning is bogus or there are just too many
> > > > > occurrences.
> > > > 
> > > > Maybe.
> > > 
> > > Spurious warning today, actual bug tomorrow?  I prefer to not to
> > > disable warnings wholesale.  They don't need to find actual bugs to be
> > > useful.  Flagging code that can be further specified does not hurt.
> > > Part of the effort to compile the kernel with different compilers is
> > > to add warning coverage, not remove it.  That said, there may be
> > > warnings that are never useful (or at least due to some invariant that
> > > only affects the kernel).  I cant think of any off the top of my head,
> > > but I'm also not sure this is one.
> > 
> > This one really makes the code uglier though, so I'm not really inclined
> > to applying the patch.
> 
> Note that of the three variables (w, u, x), only u is used later on.
> What about declaring them as negated with the cast, that way there's
> no cast in a ternary?

It'd be simpler to cast in the BYTE_MASK macro itself

Ex:
> 
> diff --git a/arch/x86/kvm/mmu.c b/arch/x86/kvm/mmu.c
> index d594690d8b95..53673ad4b295 100644
> --- a/arch/x86/kvm/mmu.c
> +++ b/arch/x86/kvm/mmu.c
> @@ -4261,8 +4261,9 @@ static void update_permission_bitmask(struct
> kvm_vcpu *vcpu,
>  {
>         unsigned byte;
> 
> -       const u8 x = BYTE_MASK(ACC_EXEC_MASK);
> -       const u8 w = BYTE_MASK(ACC_WRITE_MASK);
> +       const u8 x_not = (u8)~BYTE_MASK(ACC_EXEC_MASK);
> +       const u8 w_not = (u8)~BYTE_MASK(ACC_WRITE_MASK);
> +       const u8 u_not = (u8)~BYTE_MASK(ACC_USER_MASK);
>         const u8 u = BYTE_MASK(ACC_USER_MASK);
> 
> 
>         bool cr4_smep = kvm_read_cr4_bits(vcpu, X86_CR4_SMEP) != 0;
> @@ -4278,11 +4279,11 @@ static void update_permission_bitmask(struct
> kvm_vcpu *vcpu,
>                  */
> 
>                 /* Faults from writes to non-writable pages */
> -               u8 wf = (pfec & PFERR_WRITE_MASK) ? ~w : 0;
> +               u8 wf = (pfec & PFERR_WRITE_MASK) ? w_not : 0;
>                 /* Faults from user mode accesses to supervisor pages */
> -               u8 uf = (pfec & PFERR_USER_MASK) ? ~u : 0;
> +               u8 uf = (pfec & PFERR_USER_MASK) ? u_not : 0;
>                 /* Faults from fetches of non-executable pages*/
> -               u8 ff = (pfec & PFERR_FETCH_MASK) ? ~x : 0;
> +               u8 ff = (pfec & PFERR_FETCH_MASK) ? x_not : 0;
>                 /* Faults from kernel mode fetches of user pages */
>                 u8 smepf = 0;
>                 /* Faults from kernel mode accesses of user pages */
> 
> 
> Maybe you have a better naming scheme than *_not ? What do you think?

It'd be nicer to cast in the BYTE_MASK macro
and using "unsigned byte;" is misleading at best.

---
 arch/x86/kvm/mmu.c | 17 ++++++++---------
 1 file changed, 8 insertions(+), 9 deletions(-)

diff --git a/arch/x86/kvm/mmu.c b/arch/x86/kvm/mmu.c
index d594690d8b95..201711aa99b9 100644
--- a/arch/x86/kvm/mmu.c
+++ b/arch/x86/kvm/mmu.c
@@ -4246,15 +4246,14 @@ reset_ept_shadow_zero_bits_mask(struct kvm_vcpu *vcpu,
 				    boot_cpu_data.x86_phys_bits, execonly);
 }
 
-#define BYTE_MASK(access) \
-	((1 & (access) ? 2 : 0) | \
-	 (2 & (access) ? 4 : 0) | \
-	 (3 & (access) ? 8 : 0) | \
-	 (4 & (access) ? 16 : 0) | \
-	 (5 & (access) ? 32 : 0) | \
-	 (6 & (access) ? 64 : 0) | \
-	 (7 & (access) ? 128 : 0))
-
+#define BYTE_MASK(access)				\
+	((u8)(((access) & 1 ?   2 : 0) |		\
+	      ((access) & 2 ?   4 : 0) |		\
+	      ((access) & 3 ?   8 : 0) |		\
+	      ((access) & 4 ?  16 : 0) |		\
+	      ((access) & 5 ?  32 : 0) |		\
+	      ((access) & 6 ?  64 : 0) |		\
+	      ((access) & 7 ? 128 : 0)))
 
 static void update_permission_bitmask(struct kvm_vcpu *vcpu,
 				      struct kvm_mmu *mmu, bool ept)


  parent reply	other threads:[~2018-06-19 17:23 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-06-15 17:47 Matthias Kaehlcke
2018-06-15 18:04 ` Nick Desaulniers
2018-06-15 18:18   ` Joe Perches
2018-06-15 18:29     ` Matthias Kaehlcke
2018-06-15 18:40       ` Joe Perches
2018-06-15 18:45         ` Nick Desaulniers
2018-06-19 15:19           ` Paolo Bonzini
2018-06-19 17:08             ` Nick Desaulniers
2018-06-19 17:13               ` Paolo Bonzini
2018-06-19 18:38                 ` Matthias Kaehlcke
2018-06-19 17:23               ` Joe Perches [this message]
2018-06-19 17:35                 ` Paolo Bonzini
2018-06-19 18:07                   ` Joe Perches
2018-06-19 18:36                     ` Matthias Kaehlcke
2018-06-19 19:11                       ` Joe Perches
2018-06-19 21:10                         ` Matthias Kaehlcke
2018-06-19 21:55                           ` Joe Perches
2018-06-19 23:45                             ` Matthias Kaehlcke
2018-06-20  0:18                               ` Joe Perches
2018-06-20  1:36                                 ` Matthias Kaehlcke
2018-06-20  8:02                               ` Paolo Bonzini
2018-06-20 23:00                                 ` Matthias Kaehlcke
2018-06-16  3:39 ` kbuild test robot

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ad7a9addf043ee7fda8907eff9f83c9709b575dc.camel@perches.com \
    --to=joe@perches.com \
    --cc=hpa@zytor.com \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mka@chromium.org \
    --cc=ndesaulniers@google.com \
    --cc=pbonzini@redhat.com \
    --cc=rkrcmar@redhat.com \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®