From: Steven Price <steven.price@arm.com>
To: "Adrián Larumbe" <adrian.larumbe@collabora.com>,
"Boris Brezillon" <boris.brezillon@collabora.com>,
"Liviu Dudau" <liviu.dudau@arm.com>,
"Maarten Lankhorst" <maarten.lankhorst@linux.intel.com>,
"Maxime Ripard" <mripard@kernel.org>,
"Thomas Zimmermann" <tzimmermann@suse.de>,
"David Airlie" <airlied@gmail.com>,
"Daniel Vetter" <daniel@ffwll.ch>
Cc: kernel@collabora.com, dri-devel@lists.freedesktop.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 0/7] Support fdinfo runtime and memory stats on Panthor
Date: Thu, 13 Jun 2024 16:28:08 +0100 [thread overview]
Message-ID: <ae1ec268-fd76-48b5-94f9-761565153e12@arm.com> (raw)
In-Reply-To: <20240606005416.1172431-1-adrian.larumbe@collabora.com>
On 06/06/2024 01:49, Adrián Larumbe wrote:
> This patch series enables userspace utilities like gputop and nvtop to
> query a render context's fdinfo file and figure out rates of engine
> and memory utilisation.
>
> Previous discussion can be found at
> https://lore.kernel.org/dri-devel/20240423213240.91412-1-adrian.larumbe@collabora.com/
>
> Changelog:
> v3:
> - Fixed some nits and removed useless bounds check in panthor_sched.c
> - Added support for sysfs profiling knob and optional job accounting
> - Added new patches for calculating size of internal BO's
> v2:
> - Split original first patch in two, one for FW CS cycle and timestamp
> calculations and job accounting memory management, and a second one
> that enables fdinfo.
> - Moved NUM_INSTRS_PER_SLOT to the file prelude
> - Removed nelem variable from the group's struct definition.
> - Precompute size of group's syncobj BO to avoid code duplication.
> - Some minor nits.
>
>
> Adrián Larumbe (7):
> drm/panthor: introduce job cycle and timestamp accounting
> drm/panthor: add DRM fdinfo support
> drm/panthor: enable fdinfo for memory stats
> drm/panthor: add sysfs knob for enabling job profiling
> drm/panthor: support job accounting
> drm/drm_file: add display of driver's internal memory size
> drm/panthor: register size of internal objects through fdinfo
The general shape of what you end up with looks correct, but these
patches are now in a bit of a mess. It's confusing to review when the
accounting is added unconditionally and then a sysfs knob is added which
changes it all to be conditional. Equally that last patch (register size
of internal objects through fdinfo) includes a massive amount of churn
moving everything into an 'fdinfo' struct which really should be in a
separate patch.
Ideally this needs to be reworked into a logical series of patches with
knowledge of what's coming next. E.g. the first patch could introduce
the code for cycle/timestamp accounting but leave it disabled to be then
enabled by the sysfs knob patch.
One thing I did notice though is that I wasn't seeing the GPU frequency
change, looking more closely at this it seems like there's something
dodgy going on with the devfreq code. From what I can make out I often
end up in a situation where all contexts are idle every time tick_work()
is called - I think this is simply because tick_work() is scheduled with
a delay and by the time the delay has hit the work is complete. Nothing
to do with this series, but something that needs looking into. I'm on
holiday for a week but I'll try to look at this when I'm back.
Steve
> Documentation/gpu/drm-usage-stats.rst | 4 +
> drivers/gpu/drm/drm_file.c | 9 +-
> drivers/gpu/drm/msm/msm_drv.c | 2 +-
> drivers/gpu/drm/panfrost/panfrost_drv.c | 2 +-
> drivers/gpu/drm/panthor/panthor_devfreq.c | 10 +
> drivers/gpu/drm/panthor/panthor_device.c | 2 +
> drivers/gpu/drm/panthor/panthor_device.h | 21 ++
> drivers/gpu/drm/panthor/panthor_drv.c | 83 +++++-
> drivers/gpu/drm/panthor/panthor_fw.c | 16 +-
> drivers/gpu/drm/panthor/panthor_fw.h | 5 +-
> drivers/gpu/drm/panthor/panthor_gem.c | 67 ++++-
> drivers/gpu/drm/panthor/panthor_gem.h | 16 +-
> drivers/gpu/drm/panthor/panthor_heap.c | 23 +-
> drivers/gpu/drm/panthor/panthor_heap.h | 6 +-
> drivers/gpu/drm/panthor/panthor_mmu.c | 8 +-
> drivers/gpu/drm/panthor/panthor_mmu.h | 3 +-
> drivers/gpu/drm/panthor/panthor_sched.c | 304 +++++++++++++++++++---
> include/drm/drm_file.h | 7 +-
> 18 files changed, 522 insertions(+), 66 deletions(-)
>
>
> base-commit: 310ec03841a36e3f45fb528f0dfdfe5b9e84b037
next prev parent reply other threads:[~2024-06-13 15:28 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-06-06 0:49 Adrián Larumbe
2024-06-06 0:49 ` [PATCH v3 1/7] drm/panthor: introduce job cycle and timestamp accounting Adrián Larumbe
2024-06-06 0:49 ` [PATCH v3 2/7] drm/panthor: add DRM fdinfo support Adrián Larumbe
2024-06-06 0:49 ` [PATCH v3 3/7] drm/panthor: enable fdinfo for memory stats Adrián Larumbe
2024-06-06 0:49 ` [PATCH v3 4/7] drm/panthor: add sysfs knob for enabling job profiling Adrián Larumbe
2024-06-06 0:49 ` [PATCH v3 5/7] drm/panthor: support job accounting Adrián Larumbe
2024-06-06 0:49 ` [PATCH v3 6/7] drm/drm_file: add display of driver's internal memory size Adrián Larumbe
2024-06-06 8:35 ` Tvrtko Ursulin
2024-06-24 17:47 ` Rob Clark
2024-06-06 0:49 ` [PATCH v3 7/7] drm/panthor: register size of internal objects through fdinfo Adrián Larumbe
2024-06-13 15:28 ` Steven Price [this message]
2024-06-24 11:23 ` [PATCH v3 0/7] Support fdinfo runtime and memory stats on Panthor Adrián Larumbe
2024-07-03 15:29 ` Steven Price
2024-07-03 15:45 ` Boris Brezillon
2024-07-15 20:43 ` Adrián Larumbe
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ae1ec268-fd76-48b5-94f9-761565153e12@arm.com \
--to=steven.price@arm.com \
--cc=adrian.larumbe@collabora.com \
--cc=airlied@gmail.com \
--cc=boris.brezillon@collabora.com \
--cc=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=kernel@collabora.com \
--cc=linux-kernel@vger.kernel.org \
--cc=liviu.dudau@arm.com \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®