mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jacek Anaszewski <jacek.anaszewski@gmail.com>
To: "Michał Kępień" <kernel@kempniu.pl>,
	"Richard Purdie" <rpurdie@rpsys.net>,
	"Pavel Machek" <pavel@ucw.cz>,
	"Matthew Garrett" <mjg59@srcf.ucam.org>,
	"Pali Rohár" <pali.rohar@gmail.com>,
	"Darren Hart" <dvhart@infradead.org>,
	"Andy Shevchenko" <andy@infradead.org>,
	"Jaroslav Kysela" <perex@perex.cz>,
	"Takashi Iwai" <tiwai@suse.com>
Cc: Alex Hung <alex.hung@canonical.com>,
	linux-leds@vger.kernel.org, platform-driver-x86@vger.kernel.org,
	alsa-devel@alsa-project.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 0/7] Move dell-led to drivers/platform/x86
Date: Fri, 17 Feb 2017 23:15:24 +0100	[thread overview]
Message-ID: <ae94a1a6-822d-68f6-3533-b9e1a4d3296a@gmail.com> (raw)
In-Reply-To: <20170217075753.12702-1-kernel@kempniu.pl>

Hi Michał,

Thanks for collecting relevant credits.
I've applied the patchset to the for-4.12 branch of linux-leds.git.

Best regards,
Jacek Anaszewski

On 02/17/2017 08:57 AM, Michał Kępień wrote:
> This patch series moves the dell-led driver from the LED subsystem to
> the x86 platform driver subsystem.
> 
> The original motivation behind this effort was to move all code using
> the dell-smbios module to the x86 platform driver subsystem.  While I
> was investigating the possibilities to do that, it quickly emerged that
> dell-led can and in fact should be moved to the x86 platform driver
> subsystem in its entirety.
> 
> dell-led consists of two major parts:
> 
>   - the part exposing a microphone mute LED interface, introduced in
>     db6d8cc00773 ("dell-led: add mic mute led interface"); this
>     interface is used by sound/pci/hda/dell_wmi_helper.c; while the
>     original implementation used a WMI interface, it was changed to use
>     dell-smbios in cf0d7ea33596 ("dell-led: use dell_smbios_find_token()
>     for finding mic DMI tokens") and 0c41a08e131d ("dell-led: use
>     dell_smbios_send_request() for performing SMBIOS calls"),
> 
>   - the part handling an activity LED present in Dell Latitude 2100
>     netbooks, introduced in 72dcd8d08aca ("leds: Add Dell Business Class
>     Netbook LED driver"); it binds to a specific WMI GUID and then
>     registers a LED device which is controlled using WMI (i.e. it is
>     essentially a WMI driver).
> 
> Patches 1 and 2 clean up the microphone mute LED interface to minimize
> the amount of code moved around.
> 
> Patch 3 updates a variable name in sound/pci/hda/dell_wmi_helper.c so
> that it better matches that variable's role.
> 
> Patch 4 moves the microphone mute LED interface to
> drivers/platform/x86/dell-laptop.c, effectively causing
> sound/pci/hda/dell_wmi_helper.c to depend on CONFIG_DELL_LAPTOP instead
> of CONFIG_LEDS_DELL_NETBOOKS.
> 
> Patch 5 reverts dell-led to the state it was in after its initial commit
> 72dcd8d08aca ("leds: Add Dell Business Class Netbook LED driver") by
> removing all remnants of the microphone mute LED handling code.
> 
> Patch 6 moves all that is left of dell-led (i.e. the activity LED part,
> as originally implemented), to a new module which is placed in
> drivers/platform/x86/dell-wmi-led.c.
> 
> Patch 7 fixes coding style issues in drivers/platform/x86/dell-wmi-led.c
> to make sure it gets a clean start in the x86 platform driver subsystem.
> 
> As all patches except patch 3 in this series affect the LED subsystem,
> the series is based on linux-leds/for-next.
> 
> Changes from v2:
> 
>   - Add patch 7 fixing coding style issues (feedback from Joe and Andy
>     taken into account).
> 
>   - Add leading zero to constants in patch 4.
> 
>   - Move dell-led.h include one line higher in patch 4.
> 
> Changes from v1:
> 
>   - Squash patches 2-4 from v1 into a single patch (#2 in v2).
> 
>   - Add patch 3.
> 
>   - Fix subject pattern in patch 4.
> 
>   - Slight commit message adjustments, including fixing a typo
>     ("COFIG_LEDS_DELL_NETBOOKS") in patch 6.
> 
>   - Remove the name of the module's source file from the header comment
>     in drivers/platform/x86/dell-wmi-led.c to avoid the need to update
>     it in the future.
> 
>  drivers/leds/Kconfig                               |   9 --
>  drivers/leds/Makefile                              |   1 -
>  drivers/platform/x86/Kconfig                       |   8 ++
>  drivers/platform/x86/Makefile                      |   1 +
>  drivers/platform/x86/dell-laptop.c                 |  28 ++++
>  .../dell-led.c => platform/x86/dell-wmi-led.c}     | 141 +++++----------------
>  include/linux/dell-led.h                           |   6 +-
>  sound/pci/hda/dell_wmi_helper.c                    |  30 ++---
>  8 files changed, 86 insertions(+), 138 deletions(-)
>  rename drivers/{leds/dell-led.c => platform/x86/dell-wmi-led.c} (56%)
> 

      parent reply	other threads:[~2017-02-17 22:16 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-02-17  7:57 Michał Kępień
2017-02-17  7:57 ` [PATCH v3 1/7] dell-led: remove GUID check from dell_micmute_led_set() Michał Kępień
2017-02-17  7:57 ` [PATCH v3 2/7] ALSA: hda - use dell_micmute_led_set() instead of dell_app_wmi_led_set() Michał Kępień
2017-02-17  7:57 ` [PATCH v3 3/7] ALSA: hda - rename dell_led_set_func to dell_micmute_led_set_func Michał Kępień
2017-02-17  7:57 ` [PATCH v3 4/7] platform/x86: dell-laptop: import dell_micmute_led_set() from drivers/leds/dell-led.c Michał Kępień
2017-02-17  7:57 ` [PATCH v3 5/7] dell-led: remove code related to mic mute LED Michał Kępień
2017-02-17  7:57 ` [PATCH v3 6/7] dell-led: move driver to drivers/platform/x86/dell-wmi-led.c Michał Kępień
2017-02-17  7:57 ` [PATCH v3 7/7] platform/x86: dell-wmi-led: fix coding style issues Michał Kępień
2017-02-17 22:15 ` Jacek Anaszewski [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ae94a1a6-822d-68f6-3533-b9e1a4d3296a@gmail.com \
    --to=jacek.anaszewski@gmail.com \
    --cc=alex.hung@canonical.com \
    --cc=alsa-devel@alsa-project.org \
    --cc=andy@infradead.org \
    --cc=dvhart@infradead.org \
    --cc=kernel@kempniu.pl \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-leds@vger.kernel.org \
    --cc=mjg59@srcf.ucam.org \
    --cc=pali.rohar@gmail.com \
    --cc=pavel@ucw.cz \
    --cc=perex@perex.cz \
    --cc=platform-driver-x86@vger.kernel.org \
    --cc=rpurdie@rpsys.net \
    --cc=tiwai@suse.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®