mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Shuah Khan <shuah@kernel.org>
To: "Daniel Díaz" <daniel.diaz@linaro.org>,
	"Shuah Khan" <shuahkh@osg.samsung.com>,
	linux-kselftest@vger.kernel.org,
	"Linus Walleij" <linus.walleij@linaro.org>
Cc: Fathi Boudra <fathi.boudra@linaro.org>,
	Bamvor Jian Zhang <bamv2005@gmail.com>,
	Bartosz Golaszewski <brgl@bgdev.pl>,
	"open list:GPIO MOCKUP DRIVER" <linux-gpio@vger.kernel.org>,
	open list <linux-kernel@vger.kernel.org>,
	Shuah Khan <shuah@kernel.org>
Subject: Re: [PATCH v3 1/2] selftests: gpio: restructure Makefile
Date: Tue, 2 Oct 2018 14:55:24 -0600	[thread overview]
Message-ID: <aee2d946-eecb-ca39-0802-9755a01a7312@kernel.org> (raw)
In-Reply-To: <CAEUSe79yNJ_2FsLsxKW6J0dfrJ2HoVvk+_NZGWHCsy_Kc0+pQw@mail.gmail.com>

On 10/02/2018 02:48 PM, Daniel Díaz wrote:
> Hello!
> 
> On Fri, 7 Sep 2018 at 09:35, Daniel Díaz <daniel.diaz@linaro.org> wrote:
>> From: Fathi Boudra <fathi.boudra@linaro.org>
>>
>> This patch cleans up the Makefile by restructuring a couple of
>> things, namely:
>> 1) change explicit paths in targets for variables
>> 2) substitute a variable (BINARIES) for another, part of the
>>    selftests build system (TEST_PROGS_EXTENDED)
>> 3) proper cleaning up of the EXTRA objects
>>
>> The resulting Makefile is much more readable and manageable.
>>
>> Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
>> Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org>
>> ---
>>  tools/testing/selftests/gpio/Makefile | 32 +++++++++++++++-----------------
>>  1 file changed, 15 insertions(+), 17 deletions(-)
>>
>> diff --git a/tools/testing/selftests/gpio/Makefile b/tools/testing/selftests/gpio/Makefile
>> index 4665cdb..a4a01ec8 100644
>> --- a/tools/testing/selftests/gpio/Makefile
>> +++ b/tools/testing/selftests/gpio/Makefile
>> @@ -1,28 +1,26 @@
>>  # SPDX-License-Identifier: GPL-2.0
>>
>> +CFLAGS += -O2 -g -std=gnu99 -Wall -I../../../../usr/include/
>> +LDLIBS += -lmount -I/usr/include/libmount
>> +
>>  TEST_PROGS := gpio-mockup.sh
>> -TEST_FILES := gpio-mockup-sysfs.sh $(BINARIES)
>> -BINARIES := gpio-mockup-chardev
>> -EXTRA_PROGS := ../gpiogpio-event-mon ../gpiogpio-hammer ../gpiolsgpio
>> -EXTRA_DIRS := ../gpioinclude/
>> -EXTRA_OBJS := ../gpiogpio-event-mon-in.o ../gpiogpio-event-mon.o
>> -EXTRA_OBJS += ../gpiogpio-hammer-in.o ../gpiogpio-utils.o ../gpiolsgpio-in.o
>> -EXTRA_OBJS += ../gpiolsgpio.o
>> +TEST_FILES := gpio-mockup-sysfs.sh
>> +TEST_PROGS_EXTENDED := gpio-mockup-chardev
>> +
>> +GPIODIR := ../../../gpio
>> +GPIOOBJ := gpio-utils.o
>>
>>  include ../lib.mk
>>
>> -all: $(BINARIES)
>> +all: $(TEST_PROGS_EXTENDED)
>>
>>  override define CLEAN
>> -       $(RM) $(BINARIES) $(EXTRA_PROGS) $(EXTRA_OBJS)
>> -       $(RM) -r $(EXTRA_DIRS)
>> +       $(RM) $(TEST_PROGS_EXTENDED)
>> +       $(MAKE) -C $(GPIODIR) clean
>>  endef
>>
>> -CFLAGS += -O2 -g -std=gnu99 -Wall -I../../../../usr/include/
>> -LDLIBS += -lmount -I/usr/include/libmount
>> -
>> -$(BINARIES):| khdr
>> -$(BINARIES): ../../../gpio/gpio-utils.o
>> +$(TEST_PROGS_EXTENDED):| khdr
>> +$(TEST_PROGS_EXTENDED): $(GPIODIR)/$(GPIOOBJ)
>>
>> -../../../gpio/gpio-utils.o:
>> -       make ARCH=$(ARCH) CROSS_COMPILE=$(CROSS_COMPILE) -C ../../../gpio
>> +$(GPIODIR)/$(GPIOOBJ):
>> +       $(MAKE) -C $(GPIODIR)
>> --
>> 2.7.4
> 
> Ping on this series.
> 

Thanks for the ping. I will queue these up for 4.20-rc1.

thanks,
-- Shuah

      reply	other threads:[~2018-10-02 20:55 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-09-07 14:34 Daniel Díaz
2018-09-07 14:34 ` [PATCH v3 2/2] selftests: gpio: Fix OUTPUT directory in Makefile Daniel Díaz
2018-10-02 20:48 ` [PATCH v3 1/2] selftests: gpio: restructure Makefile Daniel Díaz
2018-10-02 20:55   ` Shuah Khan [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=aee2d946-eecb-ca39-0802-9755a01a7312@kernel.org \
    --to=shuah@kernel.org \
    --cc=bamv2005@gmail.com \
    --cc=brgl@bgdev.pl \
    --cc=daniel.diaz@linaro.org \
    --cc=fathi.boudra@linaro.org \
    --cc=linus.walleij@linaro.org \
    --cc=linux-gpio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-kselftest@vger.kernel.org \
    --cc=shuahkh@osg.samsung.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome