From: Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org>
To: Javier Carrasco <javier.carrasco@wolfvision.net>,
Rob Herring <robh+dt@kernel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@linaro.org>,
Conor Dooley <conor+dt@kernel.org>,
Liam Girdwood <lgirdwood@gmail.com>,
Mark Brown <broonie@kernel.org>, Jaroslav Kysela <perex@perex.cz>,
Takashi Iwai <tiwai@suse.com>
Cc: Rob Herring <robh@kernel.org>,
devicetree@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-sound@vger.kernel.org, linux-usb@vger.kernel.org
Subject: Re: [PATCH 2/3] ASoC: dt-bindings: xmos,xvf3500: add bindings for XMOS XVF3500
Date: Mon, 15 Jan 2024 21:43:21 +0100 [thread overview]
Message-ID: <aeeb0dfb-87e2-4024-9d4a-0b9529477315@linaro.org> (raw)
In-Reply-To: <16027339-0a82-4dd1-86aa-19fda6e23f88@wolfvision.net>
On 15/01/2024 20:43, Javier Carrasco wrote:
> On 15.01.24 19:11, Krzysztof Kozlowski wrote:
>> On 15/01/2024 17:24, Javier Carrasco wrote:
>>> Do you mean that the XVF3500 should not be represented as a platform
>>> device and instead it should turn into an USB device represented as a
>>> node of an USB controller? Something like this (Rockchip SoC):
>>>
>>> &usb_host1_xhci {
>>> ...
>>>
>>> xvf3500 {
>>> ...
>>> };
>>> };
>>>
>>> Did I get you right or is that not the correct representation? Thank you
>>> again.
>>
>> I believe it should be just like onboard hub. I don't understand why
>> onboard hub was limited to hub, because other USB devices also could be
>> designed similarly by hardware folks :/
>>
>> And if we talk about Linux drivers, then your current solution does not
>> support suspend/resume and device unbind.
>>
>> Best regards,
>> Krzysztof
>>
>
> Actually this series is an attempt to get rid of a misuse of the
> onboard_usb_hub driver by a device that is not a HUB, but requires the
> platform-part of that driver for the initialization.
That's just naming issue, isn't it?
>
> What would be the best approach to provide support upstream? Should I
> turn this driver into a generic USB driver that does what the
> platform-part of the onboard HUB does? Or are we willing to accept
No, because you did not solve the problems I mentioned. This is neither
accurate hardware description nor proper Linux driver model handling PM
and unbind.
> non-HUB devices in the onboard_usb_hub driver even though it supports
> more operations?
>
> I am adding linux-usb to this thread in case someone has other suggestions.
I don't see any difference between this device and onboard hub. The
concept and the problem is the same. Therefore either treat it as as
onboard hub or come with USB-version of PCI power sequencing.
https://lore.kernel.org/all/20240104130123.37115-1-brgl@bgdev.pl/
Best regards,
Krzysztof
next prev parent reply other threads:[~2024-01-15 20:43 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-01-15 9:16 [PATCH 0/3] ALSA: usb: add support " Javier Carrasco
2024-01-15 9:16 ` [PATCH 1/3] dt-bindings: vendor-prefixes: add XMOS Javier Carrasco
2024-01-15 12:58 ` Krzysztof Kozlowski
2024-01-15 9:16 ` [PATCH 2/3] ASoC: dt-bindings: xmos,xvf3500: add bindings for XMOS XVF3500 Javier Carrasco
2024-01-15 13:02 ` Krzysztof Kozlowski
2024-01-15 13:58 ` Javier Carrasco
2024-01-15 14:35 ` Krzysztof Kozlowski
2024-01-15 15:59 ` Javier Carrasco
2024-01-15 16:03 ` Krzysztof Kozlowski
2024-01-15 16:24 ` Javier Carrasco
2024-01-15 18:11 ` Krzysztof Kozlowski
2024-01-15 19:43 ` Javier Carrasco
2024-01-15 20:43 ` Krzysztof Kozlowski [this message]
2024-01-16 7:29 ` Javier Carrasco
2024-01-22 12:01 ` Takashi Iwai
2024-01-22 12:35 ` Javier Carrasco
2024-01-22 12:29 ` Krzysztof Kozlowski
2024-01-22 12:43 ` Javier Carrasco
2024-01-15 9:16 ` [PATCH 3/3] ALSA: usb: add support " Javier Carrasco
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aeeb0dfb-87e2-4024-9d4a-0b9529477315@linaro.org \
--to=krzysztof.kozlowski@linaro.org \
--cc=broonie@kernel.org \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=javier.carrasco@wolfvision.net \
--cc=krzysztof.kozlowski+dt@linaro.org \
--cc=lgirdwood@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-sound@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=perex@perex.cz \
--cc=robh+dt@kernel.org \
--cc=robh@kernel.org \
--cc=tiwai@suse.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®