From: Richard Fitzgerald <rf@opensource.cirrus.com>
To: Charles Keepax <ckeepax@opensource.cirrus.com>
Cc: <broonie@kernel.org>, <linux-kernel@vger.kernel.org>,
<patches@opensource.cirrus.com>, <alsa-devel@alsa-project.org>,
<linux-sound@vger.kernel.org>
Subject: Re: [PATCH 3/4] firmware: cs_dsp: Merge wmfw format log message into INFO message
Date: Wed, 10 Jul 2024 10:09:38 +0100 [thread overview]
Message-ID: <afc1a70b-4ed2-4afe-a506-1ca04d080342@opensource.cirrus.com> (raw)
In-Reply-To: <Zo1YZHiE6WK3d8rm@opensource.cirrus.com>
On 09/07/2024 16:33, Charles Keepax wrote:
> On Tue, Jul 09, 2024 at 03:51:55PM +0100, Richard Fitzgerald wrote:
>> Log the WMFW file format version with the INFO_TEST message.
>>
>> The behaviour of firmware controls depends on the WMFW format version,
>> so this is useful information to log for debugging. But there's no
>> need to use a separate log line just for this value.
>>
>> Signed-off-by: Richard Fitzgerald <rf@opensource.cirrus.com>
>> ---
>> drivers/firmware/cirrus/cs_dsp.c | 3 +--
>> 1 file changed, 1 insertion(+), 2 deletions(-)
>>
>> diff --git a/drivers/firmware/cirrus/cs_dsp.c b/drivers/firmware/cirrus/cs_dsp.c
>> index 1bc2e0b6d40b..141a6c9d6737 100644
>> --- a/drivers/firmware/cirrus/cs_dsp.c
>> +++ b/drivers/firmware/cirrus/cs_dsp.c
>> @@ -1502,7 +1502,6 @@ static int cs_dsp_load(struct cs_dsp *dsp, const struct firmware *firmware,
>> goto out_fw;
>> }
>>
>> - cs_dsp_info(dsp, "Firmware version: %d\n", header->ver);
>> dsp->fw_ver = header->ver;
>>
>> if (header->core != dsp->type) {
>> @@ -1552,7 +1551,7 @@ static int cs_dsp_load(struct cs_dsp *dsp, const struct firmware *firmware,
>> case WMFW_INFO_TEXT:
>> case WMFW_NAME_TEXT:
>> region_name = "Info/Name";
>> - cs_dsp_info(dsp, "%s: %.*s\n", file,
>> + cs_dsp_info(dsp, "%s (rev %d): %.*s\n", file, dsp->fw_ver,
>> min(le32_to_cpu(region->len), 100), region->data);
>
> Are we sure on this one? I don't think a WMFW is required to
> include an INFO/NAME block so it is now possible for this to not
> get printed. Granted I have not seen one that doesn't include
> at least one of these blocks but it isn't required. I think I
> would lean towards keening the separate print personally.
>
> Thanks,
> Charles
The specification says that the first INFO block is mandatory, but
specifications can change so I don't mind leaving it on its own line.
I've just noticed a typo in the commit description (INFO_TEST should be
INFO_TEXT) so I want to send a V2 chain anyway.
next prev parent reply other threads:[~2024-07-10 9:09 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-07-09 14:51 [PATCH 0/4] firmware: cs_dsp: Some small coding improvements Richard Fitzgerald
2024-07-09 14:51 ` [PATCH 1/4] firmware: cs_dsp: Don't allocate temporary buffer for info text Richard Fitzgerald
2024-07-09 14:51 ` [PATCH 2/4] firmware: cs_dsp: Make wmfw and bin filename arguments const char * Richard Fitzgerald
2024-07-09 14:51 ` [PATCH 3/4] firmware: cs_dsp: Merge wmfw format log message into INFO message Richard Fitzgerald
2024-07-09 15:33 ` Charles Keepax
2024-07-10 9:09 ` Richard Fitzgerald [this message]
2024-07-09 14:51 ` [PATCH 4/4] firmware: cs_dsp: Rename fw_ver to wmfw_ver Richard Fitzgerald
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=afc1a70b-4ed2-4afe-a506-1ca04d080342@opensource.cirrus.com \
--to=rf@opensource.cirrus.com \
--cc=alsa-devel@alsa-project.org \
--cc=broonie@kernel.org \
--cc=ckeepax@opensource.cirrus.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-sound@vger.kernel.org \
--cc=patches@opensource.cirrus.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®