mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Andy Shevchenko <andriy.shevchenko@intel.com>
To: Maxwell Doose <m32285159@gmail.com>
Cc: jic23@kernel.org, "David Lechner" <dlechner@baylibre.com>,
	"Nuno Sá" <nuno.sa@analog.com>,
	"Andy Shevchenko" <andy@kernel.org>,
	"open list:IIO SUBSYSTEM AND DRIVERS" <linux-iio@vger.kernel.org>,
	"open list" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v3] iio: imu: kmx61: Use guard(mutex)() family over manual locking
Date: Tue, 5 May 2026 16:08:49 +0300	[thread overview]
Message-ID: <afnr4TjC3DVxkVJt@ashevche-desk.local> (raw)
In-Reply-To: <20260505124706.9862-1-m32285159@gmail.com>

On Tue, May 05, 2026 at 07:47:06AM -0500, Maxwell Doose wrote:
> Include linux/cleanup.h to take advantage of new macros.
> 
> Replace manual mutex_lock() and mutex_unlock() calls across the file
> with guard(mutex)() and scoped_guard() where appropriate. This will help
> modernize the driver with up-to-date functions/macros.
> 
> Remove now redundant gotos and ret variables, as the new RAII macros
> make them unneeded.

Did you compile this version?

...

> -	case IIO_CHAN_INFO_SAMP_FREQ:
> +	case IIO_CHAN_INFO_SAMP_FREQ: {
>  		if (chan->type != IIO_ACCEL && chan->type != IIO_MAGN)
>  			return -EINVAL;
>  
> -		mutex_lock(&data->lock);
> -		ret = kmx61_get_odr(data, val, val2, chan->address);
> -		mutex_unlock(&data->lock);
> +		scoped_guard(mutex, &data->lock)
> +			ret = kmx61_get_odr(data, val, val2, chan->address);
>  		if (ret)
>  			return -EINVAL;
>  		return IIO_VAL_INT_PLUS_MICRO;
>  	}
> +	}

This looks suspicious.

...

Please, slow down and check the patches you sent.

Also, use, if not yet, --histogram when preparing patches, it might make them
more readable.

...

>  	switch (mask) {
> -	case IIO_CHAN_INFO_SAMP_FREQ:
> +	case IIO_CHAN_INFO_SAMP_FREQ: {
>  		if (chan->type != IIO_ACCEL && chan->type != IIO_MAGN)
>  			return -EINVAL;
>  
> -		mutex_lock(&data->lock);
> -		ret = kmx61_set_odr(data, val, val2, chan->address);
> -		mutex_unlock(&data->lock);
> -		return ret;
> -	case IIO_CHAN_INFO_SCALE:
> +		guard(mutex)(&data->lock);

+ blank line.

> +		return kmx61_set_odr(data, val, val2, chan->address);
> +	}
> +	case IIO_CHAN_INFO_SCALE: {
>  		switch (chan->type) {
>  		case IIO_ACCEL:
>  			if (val != 0)
>  				return -EINVAL;
> -			mutex_lock(&data->lock);
> -			ret = kmx61_set_scale(data, val2);
> -			mutex_unlock(&data->lock);
> -			return ret;
> +			guard(mutex)(&data->lock);
> +			return kmx61_set_scale(data, val2);

Missing scope.

>  		default:
>  			return -EINVAL;
>  		}
> +	}
>  	default:
>  		return -EINVAL;
>  	}

...

> -	mutex_lock(&data->lock);
> +	guard(mutex)(&data->lock);

+ blank line.

>  	iio_for_each_active_channel(indio_dev, bit) {
>  		ret = kmx61_read_measurement(data, base, bit);
>  		if (ret < 0) {
> -			mutex_unlock(&data->lock);
> -			goto err;
> +			iio_trigger_notify_done(indio_dev->trig);
> +			return IRQ_HANDLED;
>  		}
>  		buffer[i++] = ret;
>  	}
> -	mutex_unlock(&data->lock);
>  
>  	iio_push_to_buffers(indio_dev, buffer);
> -err:
>  	iio_trigger_notify_done(indio_dev->trig);
>  
>  	return IRQ_HANDLED;

...


> -	mutex_lock(&data->lock);
> +	guard(mutex)(&data->lock);

+ blank line.

>  	kmx61_set_mode(data, KMX61_ALL_STBY, KMX61_ACC | KMX61_MAG, true);
> -	mutex_unlock(&data->lock);

Since guard()() is not like lock/unlock, the blank line is better for
readability. lock/unlock scenarios look&feel as special scope, that's why
the blank lines there are optional.

-- 
With Best Regards,
Andy Shevchenko



  reply	other threads:[~2026-05-05 13:08 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-05-05 12:47 Maxwell Doose
2026-05-05 13:08 ` Andy Shevchenko [this message]
2026-05-05 13:27   ` Maxwell Doose

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=afnr4TjC3DVxkVJt@ashevche-desk.local \
    --to=andriy.shevchenko@intel.com \
    --cc=andy@kernel.org \
    --cc=dlechner@baylibre.com \
    --cc=jic23@kernel.org \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=m32285159@gmail.com \
    --cc=nuno.sa@analog.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®