From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from mail-wm1-f51.google.com (mail-wm1-f51.google.com [209.85.128.51]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id F0E7D3A16AC for ; Mon, 18 May 2026 05:21:22 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=209.85.128.51 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1779081693; cv=none; b=tvYEydqHxTj41f5gHWUhlMCyesHg+8bRr0u05/DO5a4JqBHDv3dF6yUj1WM2rdabkFOZ95DeL8JFybcAQIeyIY/z1vpc93JYo6rs4Kekv+nMRiVqSKgBSjHU4hqNq9Eg7Z/s80tNh0W2Pn+mpT9G0hc0E25sZhKX2uMusF6U34s= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1779081693; c=relaxed/simple; bh=7a10vgNqiEEJQnO5OwPIrltQfJOdBJF3/4hlmQZdvtk=; h=Date:From:To:Cc:Subject:Message-ID:References:MIME-Version: Content-Type:Content-Disposition:In-Reply-To; b=i43gldmrvXU2ypM/JTzvbDGDB4aO8vMNj9JhtbzMT2yK3vmhnsoAB/ehgk36p/CHYKBDf6E8o9/7UjBD6U4fOp7D1Z/4Vx5rCaol5+9UBHQenM1lCljg+ZxWH1Y9gZsOSh9SHIMmy7ct+/6yVDClMJineDv6nOrOwKfOXO7P6/s= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=gmail.com; spf=pass smtp.mailfrom=gmail.com; dkim=pass (2048-bit key) header.d=gmail.com header.i=@gmail.com header.b=SL9bECUX; arc=none smtp.client-ip=209.85.128.51 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=gmail.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=gmail.com Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=gmail.com header.i=@gmail.com header.b="SL9bECUX" Received: by mail-wm1-f51.google.com with SMTP id 5b1f17b1804b1-4891e5b9c1fso13287355e9.2 for ; Sun, 17 May 2026 22:21:19 -0700 (PDT) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20251104; t=1779081675; x=1779686475; darn=vger.kernel.org; h=in-reply-to:content-disposition:mime-version:references:message-id :subject:cc:to:from:date:from:to:cc:subject:date:message-id:reply-to; bh=VCCjvwryD9VPAkOv1op3rNrfZPwIKpZrxwEA329jq+Y=; b=SL9bECUXNmmPLWwYEzaBGftSx1nBOLMAHjeVplwTmIIarxPXSQULf4L4DPBa3vhpHI sEBhsZpMuPsVSrIfsfOIirTMqBMlFv0VjpXWw53aIyCN7Z3Iawky4ccKaQigBCaeFaze VzbiL9DVY2JqcWvAE+jjZffWkdhbDpPWfnvVTm4dMlP8zlTL3g7i9bd3dKJnpKNx3fd0 QMzsL+m0JCu0F3mAI48QiIZEzVicInfPE5gP9LQlX+Sa7wnQGvMcp2W9O79kOAINdt5Z TxoyjG//7wEje320zAJMu3xiI6KarIfYMefYP5rIVfAPik1EpBOf47T+XDKtS8GYgIjk d6MA== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20251104; t=1779081675; x=1779686475; h=in-reply-to:content-disposition:mime-version:references:message-id :subject:cc:to:from:date:x-gm-gg:x-gm-message-state:from:to:cc :subject:date:message-id:reply-to; bh=VCCjvwryD9VPAkOv1op3rNrfZPwIKpZrxwEA329jq+Y=; b=JHV92r3m03e+pd/ryrSlTVZ1wA2rTP/8tAGRrZRhNHCpOI3P8QGWN/skXUAcDT49p5 Gu+RPKRHOonTTV9a4VFP05cs/DoJGVsyuP9wPgUWRK8mG6FBwnNfSx3XwJDfAovx0QNu Ld2PfXvhBaH2D9f+W/ZvXPtZ72/KXN8vGKVYfTmvlxwuIlxF7qYwNPv0Xu+kkN3IRScV DFExHR1Z++wc4D3o+Yodg5qEw++b2rcLAQDsRkdKonPJKvMqncmBbp7B+LQMeXXNwG5W owBPesQCM1uw1hMd5Xxyq/DJx+/spPc6IigxEl6eYrZvociSddO8zxRHnXQsU3dIUfid DsjQ== X-Forwarded-Encrypted: i=1; AFNElJ+aWRUuhJ90T/uzlielAYe1c4E8P50wIqHy03lzVKK9mlQgU/cAJPwrk9jyxInZziT+5wkZyigOyZ+jU+c=@vger.kernel.org X-Gm-Message-State: AOJu0Ywhj9lTizEy6OUGoryNP5GLD83DCweTj2AY07bI0bvoKdcbGDaO /24Iq5HVSXPTooMW4JV1X7Hf+gVmRuoHow+F6bi8FdTZJMyfNtndrTHksx5nsg== X-Gm-Gg: Acq92OH1CrSXxfhVlupIYkBI7u/mkjm69jRvatTHvoxLT80wsG4IqTfs2WhFCnuJJUc dvTQbWs2vbzLb9eGuwRq6dxprjehgPBHDpsqxjKu4ETFGiZonlMcIbnh1Xoq62AYLRbRV9Fqw0v HzA5Yeh4XpouKxLc+UfRdWVlLCHKvOtEh2p4uD5mlBqb4SaZO37f1MwD2kPI3Ar+4mzZSD9qIPR URKUkL+l1nKGlcquncu7x/NTfF2ZZUH7xOWuCqmmjKcmpxDwnSlXehWzl24E+xWDBEAufpyF0QT +W2TdC4eCQTUivUsKPowx8DtUqREbSySlNHUeniZm5OqAnUhrUmTzNDd+x/MrxDoaAlUBYjPG9z muN+t2zSAtGM68gaGHJGsYUhkXY8jV/t1LSYokkyeRf84x7fCXP/3qAkHc94SBXDjCGmEUKoxSp qyruTIooIjg1LhwpF9z1w= X-Received: by 2002:a05:600c:4fd4:b0:48a:581c:ead with SMTP id 5b1f17b1804b1-48fe60ed7b7mr178573245e9.10.1779081675332; Sun, 17 May 2026 22:21:15 -0700 (PDT) Received: from localhost ([196.207.164.177]) by smtp.gmail.com with ESMTPSA id ffacd0b85a97d-45d9adc2209sm31849923f8f.0.2026.05.17.22.21.14 (version=TLS1_3 cipher=TLS_AES_256_GCM_SHA384 bits=256/256); Sun, 17 May 2026 22:21:14 -0700 (PDT) Date: Mon, 18 May 2026 08:21:11 +0300 From: Dan Carpenter To: Sajal Gupta Cc: gregkh@linuxfoundation.org, dennylin0707@gmail.com, khushalchitturi@gmail.com, nikolayof23@gmail.com, khomenkov@mailbox.org, s9430939@naver.com, linux-staging@lists.linux.dev, linux-kernel@vger.kernel.org Subject: Re: [PATCH] staging: rtl8723bs: split multiple assignments in rtw_xmit.c Message-ID: References: <20260517092141.9518-1-sajal2005gupta@gmail.com> Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20260517092141.9518-1-sajal2005gupta@gmail.com> On Sun, May 17, 2026 at 02:51:20PM +0530, Sajal Gupta wrote: > Split multiple assignments into separate statements to comply > with kernel coding style. Fixes the checkpatch warnings: > "multiple assignments should be avoided" > > Signed-off-by: Sajal Gupta > --- > drivers/staging/rtl8723bs/core/rtw_xmit.c | 15 ++++++++++----- > 1 file changed, 10 insertions(+), 5 deletions(-) > > diff --git a/drivers/staging/rtl8723bs/core/rtw_xmit.c b/drivers/staging/rtl8723bs/core/rtw_xmit.c > index 458e471535ad..e30c99eeee89 100644 > --- a/drivers/staging/rtl8723bs/core/rtw_xmit.c > +++ b/drivers/staging/rtl8723bs/core/rtw_xmit.c > @@ -185,7 +185,8 @@ s32 _rtw_init_xmit_priv(struct xmit_priv *pxmitpriv, struct adapter *padapter) > pxmitbuf->phead = pxmitbuf->pbuf; > pxmitbuf->pend = pxmitbuf->pbuf + MAX_XMITBUF_SZ; > pxmitbuf->len = 0; > - pxmitbuf->pdata = pxmitbuf->ptail = pxmitbuf->phead; > + pxmitbuf->ptail = pxmitbuf->phead; > + pxmitbuf->pdata = pxmitbuf->ptail; I find this harder to read. To be honest, I don't really have a problem with the original code. Another option might be to say: pxmitbuf->ptail = pxmitbuf->phead; pxmitbuf->pdata = pxmitbuf->phead; But honestly, I'm not sure it's a very big improvement. We'd probably allow it to just stop people from sending more patches and having another discussion about this. regards, dan carpenter