From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from smtp.kernel.org (aws-us-west-2-korg-mail-alma10-1.taild15c8.ts.net [100.103.45.18]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id B46F43C8738 for ; Tue, 2 Jun 2026 10:07:19 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=100.103.45.18 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1780394840; cv=none; b=bJMhF6UmcYc2B33synUznvkFB9hjNtNi4isail86bnhXw2cs9z65uZGRvGxhl4eQK/08kO2jxNdgzokxIZqNr0qOWDTsn3u71CDQv5MNl7VgKunhx9H3UDjFjsuCewrTaOEmWIRfdv/pYFpWZxWVjVQd98TWM1/zY+HwNCjvF5U= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1780394840; c=relaxed/simple; bh=dsfE2AXQCjec9mpiAvp9GqbfnRwYBNqhekltGkZeApc=; h=Date:From:To:Cc:Subject:Message-ID:References:MIME-Version: Content-Type:Content-Disposition:In-Reply-To; b=uIJhNulM3E4d4PDZMyHdoOZ8VnI0QPrWGVV02s+ffm8kd8/HSZbTQKtAYEdIQPsFdb0vxWaeL6/UtitRdvX6J48M0TOo0F0G0MCx0fx0Z/Li1m0L7z/DkAiP7SGJTKK1ouDHU6JbyQCtI5wwvnjW8WDi8U/W8fsBTbGVwLc+v88= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b=CIyTRGcy; arc=none smtp.client-ip=100.103.45.18 Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b="CIyTRGcy" Received: by smtp.kernel.org (Postfix) with ESMTPSA id 6A9D61F00893; Tue, 2 Jun 2026 10:07:16 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=kernel.org; s=k20260515; t=1780394839; bh=LvrEZ1Qm2WHazRtzBNjRpgbPwHmCJyBaEkTLJd2RyNk=; h=Date:From:To:Cc:Subject:References:In-Reply-To; b=CIyTRGcyakzpJQ8a1U1Cwq8KCq/OgooEP9IRvPAnkF40u4bL9OK3S8KuxPkJc1no1 A7IEdSBBTak6WEjQTFOYo6q6N0v7ySUSbCu/3WK/7+ur4BaJRbkT2+yPgrfdU6vhCL sUrbrmikRM/sbhk/mKVpEA3SZHSLov4e6urc/cjBB5G2tTzhAir6LxKRpOTVMerqk/ LQMDf5HQkFBCRbCj6L1rcYKTm4rWXbQBzzpkNYL25u3ZIfC5BTYwqPk8M4Htux3q4f +UtbG3xuJiTYNsIdmSM0urePQhSgNR07EzTK2/0sw14vGJ8wVsjkQsYj1KD2lGsC1V Q566RBjJ35s9A== Date: Tue, 2 Jun 2026 11:07:13 +0100 From: Lorenzo Stoakes To: "David Hildenbrand (Arm)" Cc: Andrew Morton , Arnd Bergmann , Greg Kroah-Hartman , "Liam R . Howlett" , Vlastimil Babka , Mike Rapoport , Suren Baghdasaryan , Michal Hocko , Jann Horn , Pedro Falcato , linux-kernel@vger.kernel.org, linux-mm@kvack.org Subject: Re: [PATCH v2 3/3] mm/vma: eliminate mmap_action->error_hook, introduce error_filter Message-ID: References: <88aa89e7-aa7e-4abf-babb-a2855bcb3fee@kernel.org> <192ad271-13f0-4e8d-b5c2-feb65392bc6b@kernel.org> Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <192ad271-13f0-4e8d-b5c2-feb65392bc6b@kernel.org> On Tue, Jun 02, 2026 at 11:16:03AM +0200, David Hildenbrand (Arm) wrote: > > >>> /* > >>> - * If specified, this hook is invoked when an error occurred when > >>> - * attempting the selected action. > >>> - * > >>> - * The hook can return an error code in order to filter the error, but > >>> - * it is not valid to clear the error here. > >>> + * If non-zero, filter errors that arise from mmap actions such that we > >>> + * return error_filter instead. Only valid error codes may be specified. > >> > >> Is that really a filter or rather an "error conversion" / "error override". > >> > >> "Filter" to my German brain implies that we would ... filter selected error > >> codes, not convert them to something else? > > > > I thik it's what people tend to call this, it's what I've seen it called anyway! > > You mean for this monstrosity or for a mechanism that translates one value to > another one? In general, but a quick search on lore suggests this might not be as common as I thought. > > > I mean your German brain is being logical :) but by convention going with this > > terminology. > > Sorry, but which convention? Of calling this error 'filtering'. I'll send a quick respin and rename this to error_override then! > > -- > Cheers, > > David Cheers, Lorenzo