On Mon, May 04, 2026 at 06:09:40PM +0200, Uwe Kleine-König (The Capable Hub) wrote: > Initializing a struct using list initializers is hard to read, compared > to that using named initializers is more ideomatic. Convert the macro > used to assign values in the driver's pci_device_id array accordingly. > > This change doesn't introduce any changes to the compiled array on an > x86 and an arm64 build. > > Signed-off-by: Uwe Kleine-König (The Capable Hub) > --- > Hello, > > this is a preparing change for making struct pci_device_id::driver_data an > anonymous union (similar to > https://lore.kernel.org/all/cover.1776579304.git.u.kleine-koenig@baylibre.com/). > This requires named initializers for .driver_data. But even without that > this is a nice cleanup making the macro better readable. > > Gcc is happy with simplifying the assignment further using > PCI_VDEVICE(BROADCOM, BCM ## id ## _DEVICE_ID), but this is a bit fishy > because PCI_VDEVICE also assigns .class and .class_mask (using list > initializers), so I didn't convert that. In the meantime I learned that doing that would break W=1 builds, so it was a good choice to not go that path. > Once all pci_device_id use > named initializers, the two zeros can be dropped from PCI_VDEVICE and > this entry simplified accordingly. Is this patch still on someone's radar? Ideally for application in time for 7.2-rc1? Best regards Uwe