From: Piotr Zarycki <piotr.zarycki@gmail.com>
To: Sean Christopherson <seanjc@google.com>
Cc: kvm@vger.kernel.org, linux-kselftest@vger.kernel.org,
vkuznets@redhat.com, shuah@kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3] selftests: add swap() macro to kselftest.h
Date: Thu, 16 Jul 2026 21:00:13 +0200 [thread overview]
Message-ID: <alkp6pv1Z-zHTka6@arch-piotr> (raw)
In-Reply-To: <ak-2To4F5tNjyolt@google.com>
O Thu, Jul 09, 2026 at 07:55:10AM -0700, Sean Christopherson wrote:
> On Thu, Jun 25, 2026, Piotr Zarycki wrote:
> > Add swap() to tools/testing/selftests/kselftest.h with an #ifndef guard.
> >
> > Guard the local swap() definition in mm/uffd-stress.c with #ifndef to
> > prevent a redefinition warning.
> >
> > Use swap() in hyperv_tlb_flush.c to replace the open-coded PTE swap and
> > remove the TODO comment.
> >
> > Signed-off-by: Piotr Zarycki <piotr.zarycki@gmail.com>
> > ---
> > Changes in v3:
> > - Add #ifndef guard to mm/uffd-stress.c to fix a redefinition warning;
> > uffd-stress.c defines its own swap() without a guard, which conflicts
> > when kselftest.h is included first via uffd-common.h.
>
> Why not explicitly include kselftest.h in mm/uffd-stress.c and drop uffd-stress.c's
> version of swap()?
Dropped the local definition entirely. Sending v4.
next prev parent reply other threads:[~2026-07-16 18:59 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-05-28 9:45 [PATCH] KVM: selftests: hyperv_tlb_flush: use swap() to swap PTEs Piotr Zarycki
2026-05-28 13:13 ` Sean Christopherson
2026-05-28 14:07 ` Piotr Zarycki
2026-05-28 14:10 ` [PATCH v2] " Piotr Zarycki
2026-05-28 15:35 ` Piotr Zarycki
2026-06-25 7:09 ` [PATCH v3] selftests: add swap() macro to kselftest.h Piotr Zarycki
2026-07-09 14:55 ` Sean Christopherson
2026-07-16 19:00 ` Piotr Zarycki [this message]
2026-07-16 15:11 ` [PATCH v4] " Piotr Zarycki
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alkp6pv1Z-zHTka6@arch-piotr \
--to=piotr.zarycki@gmail.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-kselftest@vger.kernel.org \
--cc=seanjc@google.com \
--cc=shuah@kernel.org \
--cc=vkuznets@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome