mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Aaro Koskinen <aaro.koskinen@iki.fi>
To: Dan Carpenter <error27@gmail.com>
Cc: Aaro Koskinen <aaro.koskinen@iki.fi>,
	gregkh@suse.de, devel@driverdev.osuosl.org,
	linux-kernel@vger.kernel.org, arnaud.patard@rtp-net.org
Subject: Re: [PATCH 21/22] staging: xgifb: rename XGINew_SetRegANDOR() to xgifb_reg_and_or()
Date: Sat, 12 Mar 2011 17:23:59 +0200 (EET)	[thread overview]
Message-ID: <alpine.DEB.1.10.1103121721570.29704@loser> (raw)
In-Reply-To: <20110311213740.GD2008@bicker>

Hi,

On Sat, 12 Mar 2011, Dan Carpenter wrote:
> On Thu, Mar 10, 2011 at 11:02:46PM +0200, Aaro Koskinen wrote:
>> Rename XGINew_SetRegANDOR() to xgifb_reg_and_or().
>>
>> Signed-off-by: Aaro Koskinen <aaro.koskinen@iki.fi>
>> ---
>
>> -void XGINew_SetRegANDOR(unsigned long Port, unsigned short Index,
>> -		unsigned short DataAND, unsigned short DataOR)
>> +void xgifb_reg_and_or(unsigned long port, u8 index, unsigned data_and,
>                                             ^^^^^^^^  ^^^^^^^^^^^^^^^^^
>> +		      unsigned data_or)
>                      ^^^^^^^^^^^^^^^^
> I wish the change log had mentioned some of these data type changes.  It
> doesn't cause a bug, but it still should have been mentioned.

Yes, you are right. Those cleanups were actually ment to be in a separate
patch. I will redo the patches.

Thanks,

A.

  reply	other threads:[~2011-03-12 15:23 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-03-10 21:02 [PATCH 00/22] staging: xgifb: more cleanups Aaro Koskinen
2011-03-10 21:02 ` [PATCH 01/22] staging: xgifb: vb_ext: move functions to avoid forward declarations Aaro Koskinen
2011-03-10 21:02 ` [PATCH 02/22] staging: xgifb: vb_init: " Aaro Koskinen
2011-03-10 21:02 ` [PATCH 03/22] staging: xgifb: vb_setmode: " Aaro Koskinen
2011-03-10 21:02 ` [PATCH 04/22] staging: xgifb: delete unsupported chip types Aaro Koskinen
2011-03-10 21:02 ` [PATCH 05/22] staging: xgifb: delete dead code for chip types < XG40 Aaro Koskinen
2011-03-10 21:02 ` [PATCH 06/22] staging: xgifb: eliminate redudant chip type >= XG40 checks Aaro Koskinen
2011-03-10 21:02 ` [PATCH 07/22] staging: xgifb: delete unused LINUXBIOS code Aaro Koskinen
2011-03-10 21:02 ` [PATCH 08/22] staging: xgifb: delete redundant extended register access enable Aaro Koskinen
2011-03-10 21:02 ` [PATCH 09/22] staging: xgifb: delete incorrect I/O mapping Aaro Koskinen
2011-03-10 21:02 ` [PATCH 10/22] staging: xgifb: use mdelay() for millisecond delays Aaro Koskinen
2011-03-10 21:02 ` [PATCH 11/22] staging: xgifb: replace DelayUS() with udelay() Aaro Koskinen
2011-03-10 21:02 ` [PATCH 12/22] staging: xgifb: vb_util: include the .h file Aaro Koskinen
2011-03-10 21:02 ` [PATCH 13/22] staging: xgifb: vb_util: delete commented-out code Aaro Koskinen
2011-03-10 21:02 ` [PATCH 14/22] staging: xgifb: replace XGINew_GetReg2() with inb() Aaro Koskinen
2011-03-10 21:02 ` [PATCH 15/22] staging: xgifb: replace XGINew_GetReg3() with inl() Aaro Koskinen
2011-03-10 21:02 ` [PATCH 16/22] staging: xgifb: replace XGINew_SetReg3() with outb() Aaro Koskinen
2011-03-10 21:02 ` [PATCH 17/22] staging: xgifb: replace XGINew_SetReg4() with outl() Aaro Koskinen
2011-03-10 21:02 ` [PATCH 18/22] staging: xgifb: rename XGINew_SetReg1() to xgifb_reg_set() Aaro Koskinen
2011-03-10 21:02 ` [PATCH 19/22] staging: xgifb: rename XGINew_GetReg1() to xgifb_reg_get() Aaro Koskinen
2011-03-10 21:02 ` [PATCH 20/22] staging: xgifb: rename XGINew_SetRegOR() to xgifb_reg_or() Aaro Koskinen
2011-03-10 21:02 ` [PATCH 21/22] staging: xgifb: rename XGINew_SetRegANDOR() to xgifb_reg_and_or() Aaro Koskinen
2011-03-11 21:37   ` Dan Carpenter
2011-03-12 15:23     ` Aaro Koskinen [this message]
2011-03-10 21:02 ` [PATCH 22/22] staging: xgifb: rename XGINew_SetRegAND() to xgifb_reg_and() Aaro Koskinen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.DEB.1.10.1103121721570.29704@loser \
    --to=aaro.koskinen@iki.fi \
    --cc=arnaud.patard@rtp-net.org \
    --cc=devel@driverdev.osuosl.org \
    --cc=error27@gmail.com \
    --cc=gregkh@suse.de \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®