From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1761483Ab3DCL3i (ORCPT ); Wed, 3 Apr 2013 07:29:38 -0400 Received: from smtp.citrix.com ([66.165.176.89]:5106 "EHLO SMTP.CITRIX.COM" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1758493Ab3DCL3h (ORCPT ); Wed, 3 Apr 2013 07:29:37 -0400 X-IronPort-AV: E=Sophos;i="4.87,401,1363132800"; d="scan'208";a="17190262" Date: Wed, 3 Apr 2013 12:29:31 +0100 From: Stefano Stabellini X-X-Sender: sstabellini@kaball.uk.xensource.com To: Nicolas Pitre CC: Stefano Stabellini , "xen-devel@lists.xensource.com" , "linux-kernel@vger.kernel.org" , "linux-arm-kernel@lists.infradead.org" , "will.deacon@arm.com" , "arnd@arndb.de" , "rob.herring@calxeda.com" , "marc.zyngier@arm.com" , "linux@arm.linux.org.uk" Subject: Re: [PATCH v5 1/3] arm: introduce psci_smp_ops In-Reply-To: Message-ID: References: <1364919374-7836-1-git-send-email-stefano.stabellini@eu.citrix.com> User-Agent: Alpine 2.02 (DEB 1266 2009-07-14) MIME-Version: 1.0 Content-Type: text/plain; charset="US-ASCII" Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, 2 Apr 2013, Nicolas Pitre wrote: > On Tue, 2 Apr 2013, Stefano Stabellini wrote: > > > Rename virt_smp_ops to psci_smp_ops and move them to arch/arm/kernel/psci_smp.c. > > Remove mach-virt/platsmp.c, now unused. > > Compile psci_smp if CONFIG_ARM_PSCI and CONFIG_SMP. > > > > Add a cpu_die smp_op based on psci_ops.cpu_off. > > > > Initialize PSCI before setting smp_ops in setup_arch. > > Use psci_smp_ops if the platform doesn't provide its own smp_ops. > > [...] > > > @@ -766,9 +767,13 @@ void __init setup_arch(char **cmdline_p) > > unflatten_device_tree(); > > > > arm_dt_init_cpu_maps(); > > + psci_init(); > > #ifdef CONFIG_SMP > > if (is_smp()) { > > - smp_set_ops(mdesc->smp); > > + if (mdesc->smp) > > + smp_set_ops(mdesc->smp); > > + else if (psci_smp_available()) > > + smp_set_ops(&psci_smp_ops); > > Didn't we agree to do this the other way around, i.e. > > if (psci_smp_available()) > smp_set_ops(&psci_smp_ops); > else if (mdesc->smp) > smp_set_ops(mdesc->smp); > > ? Yes, we agreed about it. However that change was in a separate patch that I have dropped from this version of the series, that is why it is missing. I'll add back the change but I'll keep it in a separate patch to leave the original one, now acked twice and reviewed once, untouched. > This way you won't need the ->smp_init for Xen and that won't conflict > with MCPM. See my other reply on the subject.