From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755650Ab3LDLFa (ORCPT ); Wed, 4 Dec 2013 06:05:30 -0500 Received: from smtp02.citrix.com ([66.165.176.63]:28613 "EHLO SMTP02.CITRIX.COM" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754084Ab3LDLF2 (ORCPT ); Wed, 4 Dec 2013 06:05:28 -0500 X-IronPort-AV: E=Sophos;i="4.93,824,1378857600"; d="scan'208";a="78095078" Date: Wed, 4 Dec 2013 11:05:07 +0000 From: Stefano Stabellini X-X-Sender: sstabellini@kaball.uk.xensource.com To: Ian Campbell CC: Stefano Stabellini , "Konrad Rzeszutek Wilk" , , , , , , , , , , , , , , , , , , , Subject: Re: [PATCH] xen/pvhvm: If xen_platform_pci=0 is set don't blow up. In-Reply-To: <1386154783.17466.14.camel@kazak.uk.xensource.com> Message-ID: References: <1386105246-14337-1-git-send-email-konrad.wilk@oracle.com> <1386149848.13256.86.camel@kazak.uk.xensource.com> <1386154783.17466.14.camel@kazak.uk.xensource.com> User-Agent: Alpine 2.02 (DEB 1266 2009-07-14) MIME-Version: 1.0 Content-Type: text/plain; charset="US-ASCII" X-DLP: MIA2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, 4 Dec 2013, Ian Campbell wrote: > On Wed, 2013-12-04 at 10:51 +0000, Stefano Stabellini wrote: > > On Wed, 4 Dec 2013, Ian Campbell wrote: > > > > +bool xen_has_pv_devices(void) > > > > +{ > > > > + if (!xen_domain()) > > > > + return false; > > > > + > > > > + if (xen_hvm_domain()) { > > > > + /* User requested no unplug, so no PV drivers. */ > > > > + if (xen_emul_unplug & XEN_UNPLUG_NEVER) > > > > + return false; > > > > > > I think you need > > > if (xen_emul_unpug & XEN_UNPLUG_UNNECESSARY) > > > return true; > > > don't you? > > > > XEN_UNPLUG_UNNECESSARY was introduced to enable the platform PCI device > > even if it didn't respond properly to the unplug protocol. > > The corresponding parameter is called "unnecessary" because if you pass > > it to the kernel you mean that it is unnecessary to unplug the emulated > > devices but you can use the pv devices anyway. > > > > So no, we shouldn't check for XEN_UNPLUG_UNNECESSARY here. > > Oh, we will eventually fall through to the return true, so it does > actually work out OK. > > I'd still be in favour of handling each option explicitly, for clarity. > Which means checking for XEN_UNPLUG_UNNECESSARY. I think is wrong to check for any xen_emul_unpug options in this function. The xen_emul_unpug options should be used to set the right value of xen_platform_pci_unplug. (See my other reply.) > > > > + /* And user has xen_platform_pci=0 set in guest config as > > > > + * driver did not modify the value. */ > > > > + if (!xen_platform_pci_unplug) > > > > + return false; > > I assume this check doesn't trigger if unnecessary has been specified? right