mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Julia Lawall <julia.lawall@lip6.fr>
To: Javier Martinez Canillas <javier@dowhile0.org>
Cc: Wolfram Sang <wsa@the-dreams.de>, Michal Marek <mmarek@suse.cz>,
	Nicolas Palix <nicolas.palix@imag.fr>,
	Linux Kernel <linux-kernel@vger.kernel.org>,
	Coccinelle <cocci@systeme.lip6.fr>
Subject: Re: [Cocci] [PATCH 1/1] scripts/coccinelle: use BIT() macro if possible
Date: Sun, 27 Apr 2014 11:36:22 +0200 (CEST)	[thread overview]
Message-ID: <alpine.DEB.2.02.1404271135590.2006@localhost6.localdomain6> (raw)
In-Reply-To: <CABxcv==8F2CghQKVDp==5Mx8-OBJnc+yZWEBqi7OFGij8OHaeg@mail.gmail.com>



On Sun, 27 Apr 2014, Javier Martinez Canillas wrote:

> Hello Wolfram,
> 
> Thanks a lot for your feedback.
> 
> On Sun, Apr 27, 2014 at 7:14 AM, Wolfram Sang <wsa@the-dreams.de> wrote:
> > On Sun, Apr 27, 2014 at 02:29:46AM +0200, Javier Martinez Canillas wrote:
> >> Using the BIT() macro instead of manually shifting bits
> >> makes the code less error prone and also more readable.
> >
> > Does it? It is a taste thing, yet I don't think it makes the code that
> > much more readable that it is worth changing the whole tree.
> >
> 
> I believe there is a reason for that macro but yes I agree with you
> that is a matter of taste and the it shouldn't be enforced.
> 
> I'm doing a big refactoring for the GPIO subsystem and was told to use
> coccinelle so this patch was part of my learning. I posted it because
> I thought that it could be useful but I don't mind the patch to be
> dropped if that is not the case.

Perhaps it could be useful in files that already use BIT somewhere?

julia

  reply	other threads:[~2014-04-27  9:36 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-04-27  0:29 Javier Martinez Canillas
2014-04-27  5:14 ` [Cocci] " Wolfram Sang
2014-04-27  8:58   ` Javier Martinez Canillas
2014-04-27  9:36     ` Julia Lawall [this message]
2014-04-27 10:24       ` Javier Martinez Canillas
2014-04-27 10:29 ` Julia Lawall
2014-04-27 10:41   ` Javier Martinez Canillas

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.DEB.2.02.1404271135590.2006@localhost6.localdomain6 \
    --to=julia.lawall@lip6.fr \
    --cc=cocci@systeme.lip6.fr \
    --cc=javier@dowhile0.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mmarek@suse.cz \
    --cc=nicolas.palix@imag.fr \
    --cc=wsa@the-dreams.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®