From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754232AbbBKT72 (ORCPT ); Wed, 11 Feb 2015 14:59:28 -0500 Received: from mail-we0-f179.google.com ([74.125.82.179]:39787 "EHLO mail-we0-f179.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753004AbbBKT71 (ORCPT ); Wed, 11 Feb 2015 14:59:27 -0500 Date: Wed, 11 Feb 2015 11:59:20 -0800 (PST) From: David Rientjes X-X-Sender: rientjes@chino.kir.corp.google.com To: "Kirill A. Shutemov" cc: Andrew Morton , linux-mm@kvack.org, linux-kernel@vger.kernel.org, Linus Torvalds , Michel Lespinasse , Rik van Riel Subject: Re: [PATCH 1/4] mm: rename FOLL_MLOCK to FOLL_POPULATE In-Reply-To: <1423674728-214192-2-git-send-email-kirill.shutemov@linux.intel.com> Message-ID: References: <1423674728-214192-1-git-send-email-kirill.shutemov@linux.intel.com> <1423674728-214192-2-git-send-email-kirill.shutemov@linux.intel.com> User-Agent: Alpine 2.10 (DEB 1266 2009-07-14) MIME-Version: 1.0 Content-Type: TEXT/PLAIN; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, 11 Feb 2015, Kirill A. Shutemov wrote: > After commit a1fde08c74e9 FOLL_MLOCK has lost its original meaning: we > don't necessary mlock the page if the flags is set -- we also take > VM_LOCKED into consideration. > s/necessary/necessarily/ > Since we use the same codepath for __mm_populate(), let's rename > FOLL_MLOCK to FOLL_POPULATE. > > Signed-off-by: Kirill A. Shutemov Acked-by: David Rientjes