From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754273AbbBKT7l (ORCPT ); Wed, 11 Feb 2015 14:59:41 -0500 Received: from mail-we0-f181.google.com ([74.125.82.181]:49483 "EHLO mail-we0-f181.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754236AbbBKT7j (ORCPT ); Wed, 11 Feb 2015 14:59:39 -0500 Date: Wed, 11 Feb 2015 11:59:33 -0800 (PST) From: David Rientjes X-X-Sender: rientjes@chino.kir.corp.google.com To: "Kirill A. Shutemov" cc: Andrew Morton , linux-mm@kvack.org, linux-kernel@vger.kernel.org, Linus Torvalds , Michel Lespinasse , Rik van Riel Subject: Re: [PATCH 2/4] mm: rename __mlock_vma_pages_range() to populate_vma_page_range() In-Reply-To: <1423674728-214192-3-git-send-email-kirill.shutemov@linux.intel.com> Message-ID: References: <1423674728-214192-1-git-send-email-kirill.shutemov@linux.intel.com> <1423674728-214192-3-git-send-email-kirill.shutemov@linux.intel.com> User-Agent: Alpine 2.10 (DEB 1266 2009-07-14) MIME-Version: 1.0 Content-Type: TEXT/PLAIN; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, 11 Feb 2015, Kirill A. Shutemov wrote: > __mlock_vma_pages_range() doesn't necessary mlock pages. It depends on > vma flags. The same codepath is used for MAP_POPULATE. > s/necessary/necessarily/ > Let's rename __mlock_vma_pages_range() to populate_vma_page_range(). > > This patch also drops mlock_vma_pages_range() references from > documentation. It has gone in commit cea10a19b797. > > Signed-off-by: Kirill A. Shutemov I think it makes sense to drop the references about "downgrading" mm->mmap_sem in the documentation since populate_vma_page_range() can be called with it held either for read or write depending on the context. Acked-by: David Rientjes