mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Thomas Gleixner <tglx@linutronix.de>
To: "pang.xunlei" <pang.xunlei@linaro.org>
Cc: linux-kernel@vger.kernel.org, rtc-linux@googlegroups.com,
	John Stultz <john.stultz@linaro.org>,
	Alessandro Zummo <a.zummo@towertech.it>
Subject: Re: [PATCH RFC 05/12] time: Convert rtc_tm_to_time_unsafe() to rtc_tm_to_time() in rtc_hctosys()
Date: Mon, 27 Oct 2014 23:13:39 +0100 (CET)	[thread overview]
Message-ID: <alpine.DEB.2.11.1410272312000.5308@nanos> (raw)
In-Reply-To: <alpine.DEB.2.11.1410272244270.5308@nanos>

On Mon, 27 Oct 2014, Thomas Gleixner wrote:

> On Mon, 27 Oct 2014, pang.xunlei wrote:
> > The kernel uses 32-bit signed value(time_t) for seconds since 1970-01-01:00:00:00, so it
> > will overflow at 2038-01-19 03:14:08 on 32-bit systems. We call this "2038 safety" issue.
> 
> We really know that by now. No need to repeat that for every patch. 
>  
> > As part of addressing 2038 saftey for in-kernel uses, this patch creates no functional change
> > in existing users, and converts rtc_tm_to_time_unsafe() to rtc_tm_to_time() in rtc_hctosys().
> 
> Please line break your changelogs properly. That's how it should look
> like:
> 
> > As part of addressing 2038 saftey for in-kernel uses, this patch
> > creates no functional change in existing users, and converts
> > rtc_tm_to_time_unsafe() to rtc_tm_to_time() in rtc_hctosys().
>  
> Can you spot the difference?
> 
> > @@ -26,9 +26,10 @@ static int __init rtc_hctosys(void)
> >  {
> >  	int err = -ENODEV;
> >  	struct rtc_time tm;
> > -	struct timespec tv = {
> > +	struct timespec64 tv = {
> >  		.tv_nsec = NSEC_PER_SEC >> 1,
> >  	};
> > +	struct timespec ts32;
> 
> So this is exactly why I dislike this whole flag day conversion
> thing. If you add
> 
>        rtc_tm_to_time64()
>        do_settimeofday64()
> 
> in the first place, you can convert the whole function in one go
> without introducing intermediate variables which then need to be
> undone later again.

Aside of that ts32 is a complete misnomer because on 64 bit struct
timespec already has a 64bit seconds representation.

Thanks,

	tglx

  reply	other threads:[~2014-10-27 22:13 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-10-27  5:46 [PATCH RFC 02/12] time: Add mktime() safe version(using time64_t) pang.xunlei
2014-10-27  5:46 ` [PATCH RFC 03/12] time: Rename rtc_tm_to_time() to rtc_tm_to_time_unsafe() pang.xunlei
2014-10-27  5:46 ` [PATCH RFC 04/12] time: Add rtc_tm_to_time() safe version(using time64_t) pang.xunlei
2014-10-27  5:46 ` [PATCH RFC 05/12] time: Convert rtc_tm_to_time_unsafe() to rtc_tm_to_time() in rtc_hctosys() pang.xunlei
2014-10-27 22:03   ` Thomas Gleixner
2014-10-27 22:13     ` Thomas Gleixner [this message]
2014-10-27  5:46 ` [PATCH RFC 06/12] time: Fix build warnings for time64_t to __kernel_time_t warning on 64-bit systems pang.xunlei
2014-10-27 21:41   ` Thomas Gleixner
2014-10-27  5:46 ` [PATCH RFC 07/12] time: Rename rtc_time_to_tm() to rtc_time_to_tm_unsafe() pang.xunlei
2014-10-27  5:46 ` [PATCH RFC 08/12] time: Add rtc_time_to_tm() safe version(using time64_t) pang.xunlei
2014-10-27  5:46 ` [PATCH RFC 09/12] time: Convert rtc_time_to_tm_unsafe() to rtc_time_to_tm() in alarm_set_rtc() pang.xunlei
2014-10-27  5:46 ` [PATCH RFC 10/12] time: Convert do_settimeofday() to use timespec64 pang.xunlei
2014-10-27  5:46 ` [PATCH RFC 11/12] time: Convert xen_read_wallclock() " pang.xunlei
     [not found]   ` <alpine.DEB.2.02.1410271525560.22875@kaball.uk.xensource.com>
2014-10-29 13:04     ` Xunlei Pang
2014-10-27  5:46 ` [PATCH RFC 12/12] time: Convert pvclock_read_wallclock() " pang.xunlei

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.DEB.2.11.1410272312000.5308@nanos \
    --to=tglx@linutronix.de \
    --cc=a.zummo@towertech.it \
    --cc=john.stultz@linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pang.xunlei@linaro.org \
    --cc=rtc-linux@googlegroups.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®