From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755968AbbAZPtu (ORCPT ); Mon, 26 Jan 2015 10:49:50 -0500 Received: from resqmta-ch2-02v.sys.comcast.net ([69.252.207.34]:35298 "EHLO resqmta-ch2-02v.sys.comcast.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753512AbbAZPts (ORCPT ); Mon, 26 Jan 2015 10:49:48 -0500 Date: Mon, 26 Jan 2015 09:49:47 -0600 (CST) From: Christoph Lameter X-X-Sender: cl@gentwo.org To: Vladimir Davydov cc: Andrew Morton , Pekka Enberg , David Rientjes , Joonsoo Kim , Johannes Weiner , Michal Hocko , linux-mm@kvack.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH -mm 2/3] slab: zap kmem_cache_shrink return value In-Reply-To: Message-ID: References: Content-Type: TEXT/PLAIN; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon, 26 Jan 2015, Vladimir Davydov wrote: > @@ -2400,11 +2400,16 @@ int __kmem_cache_shrink(struct kmem_cache *cachep) > return (ret ? 1 : 0); > } > > +void __kmem_cache_shrink(struct kmem_cache *cachep) > +{ > + __cache_shrink(cachep); > +} > + Why do we need this wrapper? Rename __cache_shrink to __kmem_cache_shrink instead?